Bug 2245310 - geany-plugins-2.0.0 is available
Summary: geany-plugins-2.0.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: geany-plugins
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-10-20 17:42 UTC by Upstream Release Monitoring
Modified: 2023-11-04 03:45 UTC (History)
3 users (show)

Fixed In Version: geany-plugins-2.0-3.fc39 geany-plugins-2.0-3.fc38 geany-plugins-2.0-3.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-11-03 18:45:18 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 2.0.0 (#2245310) (1000 bytes, patch)
2023-10-20 17:42 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2023-10-20 17:42:15 UTC
Releases retrieved: 2.0.0
Upstream release that is considered latest: 2.0.0
Current version/release in rawhide: 1.38-12.fc40
URL: http://plugins.geany.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/5517/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/geany-plugins

Comment 1 Upstream Release Monitoring 2023-10-20 17:42:21 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-hpznl30z/geany-plugins.spec']' returned non-zero exit status 1.

StdOut:
warning: Macro expanded in comment on line 213: %{version}-%{release}

warning: Macro expanded in comment on line 305: %{version}-%{release}

warning: Macro expanded in comment on line 410: %{version}-%{release}

warning: Macro expanded in comment on line 464: %{version}-%{release}

warning: Macro expanded in comment on line 529: %{version}-%{release}

warning: Macro expanded in comment on line 640: %{version}-%{release}

warning: Macro expanded in comment on line 673: %{version}-%{release}

warning: Macro expanded in comment on line 779: %{geany_plug_docdir}/devhelp

warning: Macro expanded in comment on line 780: %{_datadir}/%{name}/devhelp/

warning: Macro expanded in comment on line 781: %{_libdir}/geany/devhelp.so

warning: Macro expanded in comment on line 810: %{geany_plug_docdir}/geanylua/

warning: Macro expanded in comment on line 811: %{_libdir}/geany/geanylua.so

warning: Macro expanded in comment on line 812: %{_datadir}/%{name}/geanylua/

warning: Macro expanded in comment on line 813: %{_libdir}/%{name}/geanylua/

warning: Macro expanded in comment on line 837: %{geany_plug_docdir}/geanypy/

warning: Macro expanded in comment on line 838: %{_libdir}/geany/geanypy.so

warning: Macro expanded in comment on line 839: %{_libdir}/geany/geanypy/*

warning: Macro expanded in comment on line 840: %{_libdir}/geany/*.py*

warning: Macro expanded in comment on line 847: %{geany_plug_docdir}/geniuspaste/

warning: Macro expanded in comment on line 848: %{_libdir}/geany/geniuspaste.so

warning: Macro expanded in comment on line 849: %{_datadir}/%{name}/geniuspaste/

warning: Macro expanded in comment on line 875: %{geany_plug_docdir}/multiterm/

warning: Macro expanded in comment on line 876: %{_libdir}/geany/multiterm.so

warning: Macro expanded in comment on line 926: %{geany_plug_docdir}/updatechecker/

warning: Macro expanded in comment on line 927: %{_libdir}/geany/updatechecker.so

warning: Macro expanded in comment on line 934: %{geany_plug_docdir}/webhelper/

warning: Macro expanded in comment on line 935: %{_libdir}/geany/webhelper.so

setting SOURCE_DATE_EPOCH=1697760000
error: Bad file: ./geany-plugins-2.0.0.tar.bz2: No such file or directory

RPM build warnings:
    Macro expanded in comment on line 213: %{version}-%{release}

    Macro expanded in comment on line 305: %{version}-%{release}

    Macro expanded in comment on line 410: %{version}-%{release}

    Macro expanded in comment on line 464: %{version}-%{release}

    Macro expanded in comment on line 529: %{version}-%{release}

    Macro expanded in comment on line 640: %{version}-%{release}

    Macro expanded in comment on line 673: %{version}-%{release}

    Macro expanded in comment on line 779: %{geany_plug_docdir}/devhelp

    Macro expanded in comment on line 780: %{_datadir}/%{name}/devhelp/

    Macro expanded in comment on line 781: %{_libdir}/geany/devhelp.so

    Macro expanded in comment on line 810: %{geany_plug_docdir}/geanylua/

    Macro expanded in comment on line 811: %{_libdir}/geany/geanylua.so

    Macro expanded in comment on line 812: %{_datadir}/%{name}/geanylua/

    Macro expanded in comment on line 813: %{_libdir}/%{name}/geanylua/

    Macro expanded in comment on line 837: %{geany_plug_docdir}/geanypy/

    Macro expanded in comment on line 838: %{_libdir}/geany/geanypy.so

    Macro expanded in comment on line 839: %{_libdir}/geany/geanypy/*

    Macro expanded in comment on line 840: %{_libdir}/geany/*.py*

    Macro expanded in comment on line 847: %{geany_plug_docdir}/geniuspaste/

    Macro expanded in comment on line 848: %{_libdir}/geany/geniuspaste.so

    Macro expanded in comment on line 849: %{_datadir}/%{name}/geniuspaste/

    Macro expanded in comment on line 875: %{geany_plug_docdir}/multiterm/

    Macro expanded in comment on line 876: %{_libdir}/geany/multiterm.so

    Macro expanded in comment on line 926: %{geany_plug_docdir}/updatechecker/

    Macro expanded in comment on line 927: %{_libdir}/geany/updatechecker.so

    Macro expanded in comment on line 934: %{geany_plug_docdir}/webhelper/

    Macro expanded in comment on line 935: %{_libdir}/geany/webhelper.so


RPM build errors:
    Bad file: ./geany-plugins-2.0.0.tar.bz2: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2023-10-20 17:42:22 UTC
Created attachment 1994868 [details]
Update to 2.0.0 (#2245310)

Comment 3 Fedora Update System 2023-10-24 09:24:33 UTC
FEDORA-2023-6e660a7451 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-6e660a7451

Comment 4 Fedora Update System 2023-10-24 09:24:45 UTC
FEDORA-2023-c0407cd6cf has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-c0407cd6cf

Comment 5 Fedora Update System 2023-10-24 09:24:58 UTC
FEDORA-2023-2106a1a955 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-2106a1a955

Comment 6 Fedora Update System 2023-10-25 02:19:22 UTC
FEDORA-2023-2106a1a955 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-2106a1a955`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-2106a1a955

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2023-10-25 02:29:25 UTC
FEDORA-2023-6e660a7451 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-6e660a7451`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-6e660a7451

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-10-25 02:52:55 UTC
FEDORA-2023-c0407cd6cf has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-c0407cd6cf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-c0407cd6cf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2023-10-26 01:52:10 UTC
FEDORA-2023-c0407cd6cf has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-c0407cd6cf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-c0407cd6cf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2023-10-26 02:47:17 UTC
FEDORA-2023-6e660a7451 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-6e660a7451`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-6e660a7451

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2023-10-26 02:52:40 UTC
FEDORA-2023-2106a1a955 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-2106a1a955`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-2106a1a955

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2023-10-27 01:19:44 UTC
FEDORA-2023-6e660a7451 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-6e660a7451`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-6e660a7451

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2023-10-27 02:14:24 UTC
FEDORA-2023-c0407cd6cf has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-c0407cd6cf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-c0407cd6cf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2023-10-27 02:17:37 UTC
FEDORA-2023-2106a1a955 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-2106a1a955`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-2106a1a955

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2023-11-03 18:45:18 UTC
FEDORA-2023-c0407cd6cf has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2023-11-04 03:41:54 UTC
FEDORA-2023-6e660a7451 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2023-11-04 03:45:26 UTC
FEDORA-2023-2106a1a955 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.