Bug 2246802 - python-fastavro-1.9.4 is available
Summary: python-fastavro-1.9.4 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-fastavro
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2249519 2249863 2256960 2256974 2256975 2257076 2257285 2257548
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-10-29 03:11 UTC by Upstream Release Monitoring
Modified: 2024-02-23 01:31 UTC (History)
4 users (show)

Fixed In Version: python-fastavro-1.9.4-1.fc39 python-fastavro-1.9.4-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-23 01:23:58 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 1.9.0 (#2246802) (644 bytes, patch)
2023-10-29 03:11 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.9.1 (#2246802) (643 bytes, patch)
2023-12-08 05:38 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.9.2 (#2246802) (644 bytes, patch)
2023-12-21 22:55 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.9.3 (#2246802) (643 bytes, patch)
2024-01-09 04:25 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 1.9.4 (#2246802) (644 bytes, patch)
2024-02-13 17:59 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2023-10-29 03:11:20 UTC
Releases retrieved: 1.9.0
Upstream release that is considered latest: 1.9.0
Current version/release in rawhide: 1.8.4-1.fc40
URL: https://github.com/fastavro/fastavro

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/16842/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-fastavro

Comment 1 Upstream Release Monitoring 2023-10-29 03:11:30 UTC
Created attachment 1996076 [details]
Update to 1.9.0 (#2246802)

Comment 2 Upstream Release Monitoring 2023-10-29 03:31:01 UTC
the-new-hotness/release-monitoring.org's scratch build of python-fastavro-1.9.0-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=108258517

Comment 3 Sandro 2023-10-29 08:50:38 UTC
Needs `cramjam`, thin Python bindings to de/compression algorithms in Rust, https://pypi.org/project/cramjam/

Not available in Fedora, yet.

Comment 4 Ben Beasley 2023-11-09 14:56:47 UTC
I had a look at cramjam[1] and discussed it in the “Fedora Rust” Matrix room.

The core of it is a Rust crate that has been published on crates.io as “cramjam”[2], but is not kept up to date there anymore. It corresponds to the “libcramjam” directory[3] in the upstream GitHub project. It is in the same workspace with the Python extension[4] and a “cramjam-cli”[5] that is written purely in Rust but published on PyPi[6] so it can be installed via pip. We can ignore the CLI for now. The Python extension (and CLI) reference the crate by path[7], which is normally not OK but is acceptable when the code is in the same workspace. Furthermore, regarding the crate and the out-of-date version on crates.io, Fabio Valentini wrote that “there is no need to package separately if the library isn’t used for anything else.”

So we should just package a python-cramjam package, broadly similar to python-orjson, with a virtual Provides for bundled “crate(shell-escape)”. No rust-cramjam.

Now, on to dependencies. It asks for old versions of the zstd and pyo3 crates, and these bounds will need to be loosened so we can use current versions. Hopefully that’s straightforward. Also, the crates brotli2, lz4, numpy, and snap will need to be packaged (or unretired and updated in the case of brotli2) as rust-brotli2, rust-lz4, rust-numpy, and rust-snap, respectively, along with any dependencies they might have.

I started looking at packaging rust-lz4 and found that rust-lz4-sys needs to be patched[8] to support a system (shared library) copy of liblz4. Even following the example of bzip2-sys[9][10], that was more than I was prepared to tackle at the time, and I put the project on the back burner. I still think it’s all possible with sufficient effort.

[1] https://pypi.org/project/cramjam
[2] https://crates.io/crates/cramjam
[3] https://github.com/milesgranger/pyrus-cramjam/tree/master/libcramjam
[4] https://github.com/milesgranger/pyrus-cramjam/tree/master/cramjam-python
[5] https://github.com/milesgranger/pyrus-cramjam/tree/master/cramjam-cli
[6] https://pypi.org/project/cramjam-cli/
[7] https://github.com/milesgranger/pyrus-cramjam/blob/0bea714eaa814a3c26fd0e3ab15745c690518ac8/cramjam-python/Cargo.toml#L23
[8] https://github.com/10XGenomics/lz4-rs/issues/36
[9] https://github.com/alexcrichton/bzip2-rs/pull/58
[10] https://github.com/alexcrichton/bzip2-rs/pull/78

Comment 5 Ben Beasley 2023-11-13 17:54:58 UTC
(In reply to Ben Beasley from comment #4)
> Also, the crates brotli2, lz4,
> numpy, and snap will need to be packaged (or unretired and updated in the
> case of brotli2) as rust-brotli2, rust-lz4, rust-numpy, and rust-snap,
> respectively, along with any dependencies they might have.

Actually, I think this will only need rust-brotli, which is already packaged, not rust-brotli2. I’m also not sure where I picked up rust-numpy as a requirement; it might not be needed either.

Comment 6 Upstream Release Monitoring 2023-12-08 05:38:12 UTC
Releases retrieved: 1.9.1
Upstream release that is considered latest: 1.9.1
Current version/release in rawhide: 1.8.4-3.fc40
URL: https://github.com/fastavro/fastavro

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/16842/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-fastavro

Comment 7 Upstream Release Monitoring 2023-12-08 05:38:15 UTC
Created attachment 2003291 [details]
Update to 1.9.1 (#2246802)

Comment 8 Upstream Release Monitoring 2023-12-08 05:47:59 UTC
the-new-hotness/release-monitoring.org's scratch build of python-fastavro-1.9.1-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=110039568

Comment 9 Upstream Release Monitoring 2023-12-21 22:55:42 UTC
Releases retrieved: 1.9.2
Upstream release that is considered latest: 1.9.2
Current version/release in rawhide: 1.8.4-3.fc40
URL: https://github.com/fastavro/fastavro

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/16842/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-fastavro

Comment 10 Upstream Release Monitoring 2023-12-21 22:55:45 UTC
Created attachment 2005331 [details]
Update to 1.9.2 (#2246802)

Comment 11 Upstream Release Monitoring 2023-12-21 23:04:15 UTC
the-new-hotness/release-monitoring.org's scratch build of python-fastavro-1.9.2-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=110668707

Comment 12 Upstream Release Monitoring 2024-01-09 04:25:03 UTC
Releases retrieved: 1.9.3
Upstream release that is considered latest: 1.9.3
Current version/release in rawhide: 1.8.4-5.fc40
URL: https://github.com/fastavro/fastavro

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/16842/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-fastavro

Comment 13 Upstream Release Monitoring 2024-01-09 04:25:07 UTC
Created attachment 2007866 [details]
Update to 1.9.3 (#2246802)

Comment 14 Upstream Release Monitoring 2024-01-09 04:40:02 UTC
the-new-hotness/release-monitoring.org's scratch build of python-fastavro-1.9.3-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=111505977

Comment 15 Upstream Release Monitoring 2024-02-13 17:59:42 UTC
Releases retrieved: 1.9.4
Upstream release that is considered latest: 1.9.4
Current version/release in rawhide: 1.8.4-7.fc40
URL: https://github.com/fastavro/fastavro

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/16842/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-fastavro

Comment 16 Upstream Release Monitoring 2024-02-13 17:59:46 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-gskb8vqs/python-fastavro.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1707782400
error: Bad file: ./fastavro-1.9.4.tar.gz: No such file or directory

RPM build errors:
    Bad file: ./fastavro-1.9.4.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 17 Upstream Release Monitoring 2024-02-13 17:59:47 UTC
Created attachment 2016631 [details]
Update to 1.9.4 (#2246802)

Comment 18 Fedora Update System 2024-02-14 16:42:09 UTC
FEDORA-2024-6cca6fb603 (python-cramjam-2.8.1-1.fc39 and python-fastavro-1.9.4-1.fc39) has been submitted as an update to Fedora 39.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-6cca6fb603

Comment 19 Fedora Update System 2024-02-14 17:40:28 UTC
FEDORA-2024-7c670ce3a9 (python-cramjam-2.8.1-1.fc38 and python-fastavro-1.9.4-1.fc38) has been submitted as an update to Fedora 38.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-7c670ce3a9

Comment 20 Fedora Update System 2024-02-15 01:37:14 UTC
FEDORA-2024-6cca6fb603 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-6cca6fb603`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-6cca6fb603

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2024-02-15 01:53:07 UTC
FEDORA-2024-7c670ce3a9 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-7c670ce3a9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-7c670ce3a9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2024-02-23 01:23:58 UTC
FEDORA-2024-6cca6fb603 (python-cramjam-2.8.1-1.fc39 and python-fastavro-1.9.4-1.fc39) has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Fedora Update System 2024-02-23 01:31:52 UTC
FEDORA-2024-7c670ce3a9 (python-cramjam-2.8.1-1.fc38 and python-fastavro-1.9.4-1.fc38) has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.