Bug 225086 - FTP install fails when it starts using wrong directory on server
FTP install fails when it starts using wrong directory on server
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
: 229181 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-01-28 15:50 EST by Dax Kelson
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-24 17:40:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
traceback from anaconda (202.47 KB, text/plain)
2007-01-28 15:50 EST, Dax Kelson
no flags Details

  None (edit)
Description Dax Kelson 2007-01-28 15:50:01 EST
Description of problem:

I have done many sucessful NFS installs of RHEL5beta2. Today I tried a FTP
install and about 2/3rds the way through installing packages it claimed it had a
problem reading the sabayon RPM. I checked the FTP server and the package was
fine. Note that I'm "skipping" inputing a installation number.

I rebooted and tried the install again and got the same error.

The FTP server PATH is: /pub/netinstall/RHEL5

I did a packet capture and observed the following when I hit the "Retry" button
on the sabayon popup message:

  0.778021 -> FTP Request: USER anonymous
  0.778040 -> TCP 21 > 34766 [ACK] Seq=21 Ack=17
Win=5792 Len=0 TSV=53594358 TSER=2189332
  0.779906 -> FTP Response: 331 Please specify the
  0.780047 -> FTP Request: PASS anonymous@
  0.780932 -> FTP Response: 230 Login successful.
  0.781183 -> FTP Request: CWD /
  0.781388 -> FTP Response: 250 Directory
successfully changed.
  0.781541 -> FTP Request: CWD pub
  0.781746 -> FTP Response: 250 Directory
successfully changed.
  0.781919 -> FTP Request: CWD netinstall
  0.782063 -> FTP Response: 250 Directory
successfully changed.
  0.782219 -> FTP Request: CWD RHEL6
  0.782392 -> FTP Response: 550 Failed to change

Notice that Anaconda tried changing into the RHEL6 directory instead of RHEL5!

On the server I created symlink from RHEL6 to RHEL5, clicked retry and the
install continued for 5 more minutes and then bombed out. I'm attaching the
traceback for the bombout.
Comment 1 Dax Kelson 2007-01-28 15:50:02 EST
Created attachment 146782 [details]
traceback from anaconda
Comment 2 David Timms 2007-04-05 19:52:51 EDT
Seems this is duplicated by bug 229181. Suspected cause:
Comment 3 David Cantrell 2007-07-24 17:40:40 EDT
This is now working correctly in RHEL 5.1 nightly builds.  Closing as nextrelease.
Comment 4 David Cantrell 2007-08-23 14:30:44 EDT
*** Bug 229181 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.