Bug 225280 - Merge Review: aspell-pl - Polish dictionaries for Aspell
Merge Review: aspell-pl - Polish dictionaries for Aspell
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-29 16:05 EST by Nobody's working on this, feel free to take it
Modified: 2011-09-05 01:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-05 01:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+


Attachments (Terms of Use)
New spec file (2.29 KB, text/plain)
2007-02-03 07:44 EST, Michał Bentkowski
no flags Details
aspell-pl-6.0-2.20061121 (2.52 KB, text/plain)
2007-02-03 13:48 EST, Michał Bentkowski
no flags Details

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-29 16:05:56 EST
Fedora Merge Review: aspell-pl

http://cvs.fedora.redhat.com/viewcvs/devel/aspell-pl/
Comment 1 Michał Bentkowski 2007-02-03 07:42:25 EST
I'll attach a new spec file which fixes many things in this spec file, but its
great feature is that it makes output file much smaller:

20M     /repo/core/RPMS.core/aspell-pl-0.51-5.2.2.x86_64.rpm
2,3M    /home/ecik/rpmbuild/RPMS/x86_64/aspell-pl-6.0-1.20061121.x86_64.rpm

This is done due to using of affix compression.
I've also made some fixes to make this package fit for Extras.
Comment 2 Michał Bentkowski 2007-02-03 07:44:30 EST
Created attachment 147271 [details]
New spec file
Comment 3 Dawid Gajownik 2007-02-03 09:14:00 EST
(In reply to comment #2)
> Created an attachment (id=147271) [edit]
> New spec file

Uhmm... you can't remove epoch tag now, because it will break update path from
FC6 to F7.

BTW It's not a blocker but it would be nicer to change order of tags to be
compatible with default Fedora's spec template
(/etc/rpmdevtools/spectemplate-minimal.spec from rpmdevtools package) :)
Comment 4 Michał Bentkowski 2007-02-03 13:48:20 EST
Created attachment 147277 [details]
aspell-pl-6.0-2.20061121

New, prettier spec file ;)
Comment 5 Jef Spaleta 2007-02-03 17:46:05 EST
excellent..... (In reply to comment #4)
> Created an attachment (id=147277) [edit]
> aspell-pl-6.0-2.20061121
> 
> New, prettier spec file ;)

I was going to start marching my way through these aspell library packages as
part of the merge review. The new build section you added to enable compression
appears to be a general item that I can replicate in all the specs for all the
libs.  Would you agree?

I'm going to do the review of your new spec file... and make that the basis of
my merge review.  The compression is just too damn good to not use for all the
dictionaries.

-jef
Comment 6 Jef Spaleta 2007-02-03 18:13:38 EST
bah no i can't actually do the merge review of the new specfile, because it's
using a different upstream src tarball. So i can't actually do the md5sum check
against upstream and an srpm...there's no valid srpm which uses the new src
location yet.

I'll have to wait for the owner of this to incorporate your new spec, but other
dictionaries I'll be able to include your compression fix and roll a spec
without the other srcball change issue.

Removing my review flag, until I can get a new srpm to chew on.
-jef
Comment 7 Michał Bentkowski 2007-02-04 05:42:29 EST
(In reply to comment #6)
> I'll be able to include your compression fix and roll a spec
> without the other srcball change issue.

Yeah, but in this case that compression fix can by applied thanks to a new
tarball.
Comment 8 Parag AN(पराग) 2007-03-30 06:27:12 EDT
Review:
+ package builds in mock (development i386).
- rpmlint is NOT silent for SRPM and RPM.
  But following messages are ignorable
  E: aspell-pl no-binary
  E: aspell-pl only-non-binary-in-usr-lib
  E: aspell-pl configure-without-libdir-spec
+ SPEC file contains explanation about above warnings.
+ source files match upstream.
3139a69a1bd9ccb1d853d30aa024fc2b  aspell6-pl-6.0_20061121-0.tar.bz2
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is small; no -doc subpackage required.
+ %doc does not affect runtime.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage exists.
+ no .la files.
+ no translations are available.
+ Dose owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Requires: aspell >= 12:0.60
+ Provides: aspell-pl = 50:6.0_20061121-1.fc7
+ Not a GUI APP.

APPROVED.
Comment 9 Parag AN(पराग) 2007-04-10 23:31:07 EDT
As build is available now, therefore CLOSING this review.
Comment 10 Ivana Varekova 2011-05-04 03:58:03 EDT
New Package SCM Request
=======================
Package Name: aspell-pl
Short Description: Polish dictionaries for Aspell
Owners: varekova
Branches:
InitialCC:
Comment 11 Jason Tibbitts 2011-05-05 11:26:44 EDT
This package already exists in the package database; you cannot file a new
package request for it.

Could you describe what you need the SCM admins to do for you?
Comment 12 Jason Tibbitts 2011-05-10 11:12:48 EDT
I'll clear the fedora-cvs flag so this doesn't appear in the ticket list.
Please do re-raise the flag if you provide the information I requested.
Comment 13 Parag AN(पराग) 2011-07-04 05:25:14 EDT
Ivana,
  Can this review be closed or you need any branch for this package?

Note You need to log in before you can comment on or make changes to this bug.