Bug 22545 - xinetd calls rlogin instead of rexec
Summary: xinetd calls rlogin instead of rexec
Status: CLOSED DUPLICATE of bug 18107
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rsh
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-19 20:27 UTC by Mike Gahagan
Modified: 2007-04-18 16:30 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-12-19 20:27:43 UTC


Attachments (Terms of Use)

Description Mike Gahagan 2000-12-19 20:27:40 UTC
/etc/xinetd.d/rexec provided by the rsh rpm (rsh-server-0.17-2.2.i386.rpm)
incorrectly configures xinetd to start in.rlogind instead of in.rexecd.


fix/workaround: (if you haven't figured it out already :))

change the 'server = /usr/sbin/in.rlogind' line in /etc/xinetd.d/rexec to
'server = /usr/sbin/in.rexecd'

rexec should then work as expected, provided that it is enabled.

Comment 1 Jeff Johnson 2000-12-28 01:02:59 UTC

*** This bug has been marked as a duplicate of 18107 ***


Note You need to log in before you can comment on or make changes to this bug.