Bug 22569 - "tar tzf -" hang
"tar tzf -" hang
Status: CLOSED DUPLICATE of bug 18546
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2000-12-20 00:51 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-12-20 00:51:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-20 00:51:24 EST
when using "tar tzf -", it will hang.
I debug into tar source codes, and found that "tar-1.13.17-exitcode.patch"
use "waitpid()" system call, it use third parameter with zero, which means
that it will hang until child process exit, but "gzip -d" child process
never exit.
Comment 1 Daniel Roesen 2000-12-20 03:06:58 EST

*** This bug has been marked as a duplicate of 18546 ***
Comment 2 Daniel Roesen 2000-12-20 03:07:25 EST
Fix is in Rawhide btw...

Note You need to log in before you can comment on or make changes to this bug.