Bug 18546 - tar cannot read from pipe
tar cannot read from pipe
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
: 20608 22569 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 12:12 EDT by olex
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 12:12:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description olex 2000-10-06 12:12:18 EDT
tar fails when reading from a pipe. The following example first creates a
small compressed tar file, and proceeds to display the error:

# make test archive
# file1 and file2 are just some files
tar zcf test.tgz file1 file2

# this is the error
cat test.tgz | tar tvzf -

On my i810 celeron 633, this last command newer finishes. However, "tar
tvfz test.tgz" works as excepted.

Of course, letting tar read from a pipe works on older Red Hat releases.
Comment 1 Bernhard Rosenkraenzer 2000-10-06 13:02:59 EDT
Noticed and fixed a couple of days ago.
Comment 2 Daniel Roesen 2000-11-10 00:23:11 EST
*** Bug 20608 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Roesen 2000-12-20 03:06:54 EST
*** Bug 22569 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.