Bug 22573 - Problems with turkish locale settings ...
Summary: Problems with turkish locale settings ...
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Need Real Name
URL:
Whiteboard:
Keywords:
: 22574 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-20 09:19 UTC by Tanju Aktug
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 08:32:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tanju Aktug 2000-12-20 09:19:49 UTC
In turkish we have to forms of "i" one is "i" and as uppercase "]" and the other is "}" and uppercase is "I".
The postgresql use some internal sql codes for creating views. And the code is written in uppercase, however it works as normal caracters.
So sql engine could not understand turkish lower case of "INSERT", it looks "}nsert" because of local transformation of
upper and lower case caracters...
The two envirmontal variables, which addressed at the documentation of postgresql, could not effect when they
assigned as "en" ...
So we could not use posgresql at our server.

Comment 1 Bill Nottingham 2000-12-20 16:57:08 UTC
*** Bug 22574 has been marked as a duplicate of this bug. ***

Comment 2 Trond Eivind Glomsrxd 2000-12-20 23:11:56 UTC
Could that be a glibc locale problem?

Comment 3 Tanju Aktug 2001-01-09 08:32:50 UTC
A similiar bug was reported by me about RPM package and resolved by your team. The bug number was
22492. May be this additional information could help to resolve this bug...
Best regards.

Comment 4 Trond Eivind Glomsrxd 2001-03-02 23:40:01 UTC
After seeing discussions on this topic on pgsql-hackers (
http://www.postgresql.org/mhonarc/pgsql-hackers/2001-02/thrd2.html#00961
 if you're not subscribe), I've decided not to touch this issue until it's
solved in the standard postgresql package.


Note You need to log in before you can comment on or make changes to this bug.