Bug 225749 - Merge Review: fetchmail
Merge Review: fetchmail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:36 EST by Nobody's working on this, feel free to take it
Modified: 2012-03-13 10:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 10:41:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mhlavink: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:36:10 EST
Fedora Merge Review: fetchmail

http://cvs.fedora.redhat.com/viewcvs/devel/fetchmail/
Initial Owner: mitr@redhat.com
Comment 1 Patrice Dumas 2008-09-28 17:12:34 EDT
During the build, there is:

krb5-config points to kerberosV under /usr
configure: WARNING: Kerberos IV support is obsolete. Use --with-kerberos5 if possible.
krb5-config points to kerberosIV under /usr


The obsolete should be versionned, I guess it is:
Obsoletes: fetchmailconf < 5.9.0-16

But it is not obvious that fetchmail obsoletes fetchmailconf, since it 
doesn't provides the functionality. However, if the fetchmailconf dependency disappeared, it may be indeed better to have it removed.
Comment 2 Robert Scheck 2008-12-28 16:08:17 EST
The fetchmail initscript for daemon functionality needs to get installed that 
users can use it more easily in the future. Maybe the initscript itself needs
some love before, possible (currently somewhere in contrib inside of tarball).

Adding current fetchmail maintainer on Cc, that he gets aware about this bug
report...
Comment 3 Michal Hlavinka 2009-12-04 07:16:55 EST
in short:

Legend: + = PASSED, - = FAILED, 0 = Not Applicable

+ MUST[1]: rpmlint must be run on every package. The output should be posted in the review
+ MUST: package named according to the Package Naming Guidelines
+ MUST: The spec file name must match the base package %{name}
+ MUST: The package must meet the Packaging Guidelines .
+ MUST: The package licensed with a Fedora approved license and meets the Licensing Guidelines
+ MUST: The License field in the package spec file matches the actual license
+ MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.
+ MUST: The spec file must be written in American English.
+ MUST: The spec file for the package MUST be legible.
+ MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use md5sum for this task

$ curl -s  http://download.berlios.de/fetchmail/fetchmail-6.3.13.tar.bz2 | md5sum
db792fb311bc358e95ed0437389269ac  -
$ cat sources
db792fb311bc358e95ed0437389269ac  fetchmail-6.3.13.tar.bz2
311379d6f44f5713f42bc4f047e4f1b4  fetchmail-6.3.13.tar.bz2.asc
$ curl -s  http://download.berlios.de/fetchmail/fetchmail-6.3.13.tar.bz2.asc | md5sum
311379d6f44f5713f42bc4f047e4f1b4  -

+ MUST: The package successfully compiles and builds into binary rpms on at least one primary architecture
+ MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch
+ MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines
+ MUST: The spec file handles locales properly. This is done by using the %find_lang macro
0 MUST: Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun. [10]
+ MUST: Packages must NOT bundle copies of system libraries
+ MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review, along with the rationalization for relocation of that specific package. Without this, use of Prefix: /usr is considered a blocker
+ MUST: Package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory
+ MUST: Package must not list a file more than once in the spec file's %files listings
+ MUST: Permissions on files must be set properly. Every %files section must include a %defattr(...) line.
+ MUST: Each package must have a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT).
+ MUST: Each package must consistently use macros
+ MUST: The package must contain code, or permissable content
0 MUST: Large documentation files must go in a -doc subpackage
+ MUST: If a package includes something as %doc, it must not affect the runtime of the application
0 MUST: Header files must be in a -devel package
0 MUST: Static libraries must be in a -static package
0 MUST: Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig'
0 MUST: If a package contains library files with a suffix (e.g. libfoo.so.1.1), then library files that end in .so (without suffix) must go in a -devel package
0 MUST: devel packages must require the base package using a fully versioned dependency: Requires: %{name} = %{version}-%{release}
+ MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built
0 MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section
+ MUST: Packages must not own files or directories already owned by other packages
+ MUST: At the beginning of %install, each package MUST run rm -rf %{buildroot} (or $RPM_BUILD_ROOT)
+ MUST: All filenames in rpm packages must be valid UTF-8

-----------------

comments:

1)rpmlint *.spec *.src.rpm x86_64/*
fetchmail.spec:18: W: unversioned-explicit-obsoletes fetchmailconf
fetchmail.src:18: W: unversioned-explicit-obsoletes fetchmailconf
fetchmail.x86_64: W: obsolete-not-provided fetchmailconf
3 packages and 1 specfiles checked; 0 errors, 3 warnings.

with %define fetchmailconf 1:
fetchmailconf.x86_64: W: summary-ended-with-dot A GUI utility for configuring your fetchmail preferences.

What's the status of fetchmailconf? When looking through koji builds it seems it was not built for a long time. Is Obsolete tag still required? Is fetchmailconf section still required? 

-------------

Looks good, but please explain fetchmailconf status

-----

re comment #1:  --with-kerberos5 is already used 
re comment #2: I think missing fetchmail initscript does not make fetchmail unusable so this request for enhancement should go through separate bug (RFE).
Comment 4 Vitezslav Crhonek 2012-03-13 08:06:24 EDT
(In reply to comment #3)
> 
> What's the status of fetchmailconf? When looking through koji builds it seems
> it was not built for a long time. Is Obsolete tag still required? Is
> fetchmailconf section still required? 
> 
> -------------
> 
> Looks good, but please explain fetchmailconf status
> 

fetchmailconf is obsolete since 2005, I removed it in fetchmail-6.3.21-3.fc18.
Comment 5 Michal Hlavinka 2012-03-13 10:41:50 EDT
verified, everything looks ok now

Note You need to log in before you can comment on or make changes to this bug.