Bug 22577 - broken links
broken links
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: howto (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ed Bailey
:
: 32823 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-20 09:17 EST by Gerald Teschl
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 17:13:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2000-12-20 09:17:15 EST
Since the howto index is in

/usr/share/doc/HOWTO/other-formats/html/HOWTO-INDEX-html/HOWTO-INDEX/

and not in 

/usr/share/doc/HOWTO/other-formats/html/HOWTO-INDEX/

all links are broken.
Comment 1 Michael Schwendt 2000-12-20 13:45:36 EST
As I've put the single-file HowTo's into a web-server directory, I've had to fix
this, too, by moving HOWTO-INDEX.html to its parent directory. But there's at
least one more broken link to a specific HowTo: Bootdisk HowTo.
Comment 2 Michael Schwendt 2000-12-20 13:47:15 EST
--- HOWTO-INDEX.html.orig   Tue Jul 11 18:31:00 2000
+++ HOWTO-INDEX.html    Mon Dec 18 15:57:47 2000
@@ -423,7 +423,7 @@
 ><LI
 ><P
 ><A
-HREF="../Bootdisk-HOWTO/index.html"
+HREF="../Bootdisk-HOWTO.html"
 TARGET="_top"
 >Bootdisk-HOWTO</A
 >,
@@ -8029,4 +8029,4 @@
 ></DIV
 ></BODY
 ></HTML
->
\ No newline at end of file
+>
Comment 3 Gerald Teschl 2001-04-17 10:38:55 EDT
The links in  /usr/share/doc/HOWTO/other-formats/html/HOWTO-INDEX/howtos.html 
still dont work in howto-html-7.1-1.
The following perl code will fix it:

perl -i -e 's@\.\./([^/]+)\.html@../$1-html/$1.html@' -p
/usr/share/doc/HOWTO/other-formats/html/HOWTO-INDEX/howtos.html
Comment 4 Gerald Teschl 2001-04-17 10:48:36 EDT
*** Bug 32823 has been marked as a duplicate of this bug. ***
Comment 5 Michael Schwendt 2001-04-17 12:42:06 EDT
The index of individual single-file HOWTO's

  /usr/share/doc/HOWTO/other-formats/html_single/HOWTO-INDEX.html

is still broken, too. I think more than a Perl one-liner is needed here. For
instance, from that index jump to section "4.6. Programming" and try to follow
the link to the "Software Building HOWTO". It points to

  /usr/share/doc/HOWTO/other-formats/Software-Building-HOWTO.html

but

  /usr/share/doc/HOWTO/other-formats/html_single/Software-Building-HOWTO.html

is correct. On the contrary, the link to

  /usr/share/doc/HOWTO/other-formats/Software-Release-Practice-HOWTO/index.html

should actually be:

 
/usr/share/doc/HOWTO/other-formats/html_single/Software-Release-Practice-HOWTO.html

Note how the "/index.html" changed and not only the directory.
Comment 6 Michael Schwendt 2001-04-17 12:53:29 EDT
These help for the two mentioned cases. The first one can break other (good)
links though:

cd /usr/share/doc/HOWTO/other-formats/html_single
perl -i -e 's@\.\./([^/]+)\.html@$1.html@' -p HOWTO-INDEX.html
perl -i -e 's@\.\./([^/]+)/index\.html@$1.html@' -p HOWTO-INDEX.html
Comment 7 Ed Bailey 2001-07-31 13:58:54 EDT
Ok, I'm back to the point of working on this project again.  On review, I think
there's really only two possible approaches to the problem of HTML versions of
HOWTO-INDEX not pointing to the appropriate content:

1. Leaving the HOWTO-INDEX unchanged.

2. Removing the HOWTO-INDEX completely.
The problem doesn't seem to be readily fixable in an automated fashion, and I do
not have the resources available to spend more than a few hours creating the
howto* RPMs for each release.

Which approach would you prefer?
Comment 8 Gerald Teschl 2001-07-31 17:35:36 EDT
I understand if you do not have the time. However, where are all the working
indexes on the internet coming from!? (Are these all hand fixed).

As to your question, the index seems to be quite important but its useless
with so many broken links. My opinion is that it is better to fix most
of them using the two lines of perl from above than to remove the index or
to incude the borken one.
Comment 9 Michael Schwendt 2001-07-31 18:23:50 EDT
Hmm, I've also thought that the index page has been created automatically with
some software system and then messed up by moving the linked files.

We have just tried to suggest a few fast Perl one-liner hacks to fix the
majority of bad links. That's better than a completely unusable index.

If you want to provide a real usable package, consider breaking up the fixing
process into two steps and most likely a bit more complex Perl code. A first
step could extract the links and print the expressions necessary to fix them.
Examples given on this bug page. Then go through the human-readable output
manually and drop everything that is good already and which would be messed up
by applying regular expressions without verification. Use a second step to let
the leftover Perl expressions apply the fixes.
Keep in mind that every kind of off-line documentation for Linux is very important.
Comment 10 Gerald Teschl 2001-08-01 17:13:00 EDT
Just downloaded the link "HTML (multiple pages) - all HOWTOs" from

http://www.linuxdoc.org/docs.html#howto

and extracted the tar file. All links seem to work.
Comment 11 Ed Bailey 2001-09-17 13:57:15 EDT
OK, I have a solution in place.  It'll be present in the Documentation CD for
the next release of Red Hat Linux.  I'm closing this with status RAWHIDE as that
seems to be the status closes to "look for it in the next release". :-)

Thanks for working with me to help get this fixed.

Note You need to log in before you can comment on or make changes to this bug.