Bug 225777 - Merge Review: gawk
Merge Review: gawk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Package Reviews List
:
Depends On: 223686
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:40 EST by Nobody's working on this, feel free to take it
Modified: 2008-01-17 15:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 15:54:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dan: fedora‑review+


Attachments (Terms of Use)
new spec file with all issues fixed (10.91 KB, text/plain)
2007-02-04 05:31 EST, Dan Horák
no flags Details

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:40:45 EST
Fedora Merge Review: gawk

http://cvs.fedora.redhat.com/viewcvs/devel/gawk/
Initial Owner: kzak@redhat.com
Comment 1 Dan Horák 2007-02-03 10:54:06 EST
few notes
- %makeinstall should not be used
(http://fedoraproject.org/wiki/Packaging/Guidelines#head-fcaf3e6fcbd51194a5d0dbcfbdd2fcb7791dd002)
- make check should go into %check
- can parallel "make %{?_smp_mflags}" be used in %build?
Comment 2 Dan Horák 2007-02-03 11:15:14 EST
rpmlint on the srpm gives 4 warnings:
W: gawk summary-ended-with-dot The GNU version of the awk text processing utility.
W: gawk no-url-tag
W: gawk make-check-outside-check-section make check (already mentioned in #1)
W: gawk mixed-use-of-spaces-and-tabs (spaces: line 86, tab: line 21)
Comment 3 Dan Horák 2007-02-03 12:19:21 EST
Is there a reason for including the docs in postscript? I think not, but when it
is, then -docs subpackage is required.
Comment 4 Dan Horák 2007-02-03 14:09:47 EST
Here is the summary and formal review:

OK	source files match upstream:
	  5703f72d0eea1d463f735aad8222655f  gawk-3.1.5.tar.bz2
	  5e260a21e93a29ff9066c39850ece860  gawk-3.1.5-ps.tar.gz
OK	package meets naming and versioning guidelines.
OK	specfile is properly named, is cleanly written and uses macros consistently.
OK	dist tag is present.
OK	license field matches the actual license.
OK	license is open source-compatible. License text included in package.
OK	latest version is being packaged.
OK	BuildRequires are proper.
OK	compiler flags are appropriate.
OK	%clean is present.
OK	package builds in mock (i386).
OK	package installs properly
OK	debuginfo package looks complete.
OK	final provides and requires looks sane
OK	no shared libraries are added to the regular linker search paths.
OK	owns the directories it creates.
OK	doesn't own any directories it shouldn't.
OK	no duplicates in %files.
OK	file permissions are appropriate.
OK	code, not content.
OK	%docs are not necessary for the proper functioning of the package.
OK	no headers.
OK	no pkgconfig files.
OK	no libtool .la droppings.
OK	not a GUI app.

MUST FIX:

BAD build root is NOT correct.
      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BAD	rpmlint is NOT silent, problems are in the spec file only
W: gawk summary-ended-with-dot The GNU version of the awk text processing utility.
W: gawk no-url-tag
W: gawk make-check-outside-check-section make check
W: gawk mixed-use-of-spaces-and-tabs (spaces: line 86, tab: line 21)

The URL is http://www.gnu.org/software/gawk/gawk.html

BAD	%check is NOT present, but "make check" target exists and is used
BAD	scriptlets present, but not sane (bug #223686).
BAD	documentation is NOT small, so -docs subpackage may be necessary.
BAD	parallel make not used
Comment 5 Robert Scheck 2007-02-03 14:16:23 EST
Why do we need /usr/share/doc/gawk-3.1.5/awkcard.ps and /usr/share/doc/gawk-
3.1.5/gawk.ps? Personally, I would like to avoid a -docs subpackage because of 
these two files because the rest is only a couple of README files.
Comment 6 Dan Horák 2007-02-03 14:38:56 EST
My opinion is to remove the *.ps files, which removes the whole source file
gawk-3.1.5-ps.tar.gz, and also the whole /usr/share/docs/gawk-3.1.5/README_d
directory, because it contains no relevant info. Perhaps README.multibyte and
README.tests could be useful. As a result, there will be no need to create the
docs subpackage.
Comment 7 Robert Scheck 2007-02-03 14:40:32 EST
+1 - even if we're not at the mailing lists here and it's no voting...
Comment 8 Dan Horák 2007-02-04 05:31:25 EST
Created attachment 147296 [details]
new spec file with all issues fixed

Hopefully all issues are fixed, only an entry in the changelog is missing ;-)
Comment 9 Patrice Dumas 2007-02-05 05:39:13 EST
Why do you want to remove the .ps files? It contains the manual in
viewable and printable format? There is an info manual but it is not
a substitute.
Comment 10 Dan Horák 2007-02-06 03:51:25 EST
I don't think it is different, because when I look into the
gawk-3.1.5-doc.tar.gz package available from GNU mirror sites, then it contains
the dvi file and all temporary TeX files with a log. And the second line there
is "/tmp/gawk-3.1.5/doc/gawk.texi" which means the source file and from this
file is also generated the info manual.
Comment 11 Patrice Dumas 2007-02-06 04:21:28 EST
They correspond wit the same manual, indeed, but an info manual
isn't a substitute for a printable/viewable manual. I like info,
but many dislike it, so I think that having a ps file additionaly
is a good thing. An html manual or pdf manual would have been better
but they are not shipped upstream.
Comment 12 Dan Horák 2007-02-07 05:32:07 EST
I can agree, that a printable version is useful, but then it should be packaged
due its size as a subpackage or its own package.
Comment 13 Patrice Dumas 2007-02-07 05:36:25 EST
(In reply to comment #12)
> I can agree, that a printable version is useful, but then it should be packaged
> due its size as a subpackage or its own package.

Agreed. I think that a -doc sub-package would be nice.
Comment 14 Karel Zak 2007-02-07 16:41:50 EST
Thanks for your enthusiasm. I'm going to fix/improve the package in next week(s).
Comment 15 Karel Zak 2007-02-12 08:40:25 EST
I'm not sure with -doc sub-package. There is already all docs in man pages and
info files. Maybe we waste a space on mirrors and CDs with this *.ps docs and we
should remove it at all. 

I think 1% of people who look for printable docs can found it at ftp.gnu.org --
we can add there README.pritable-docs with link to
ftp://ftp.gnu.org/gnu/gawk/gawk-%{version}-ps.tar.gz.

Comments?
Comment 16 Karel Zak 2007-02-12 09:07:50 EST
All items are fixed in gawk-3.1.5-15.fc7 (it's without PS files and a sub-package).
Comment 17 Patrice Dumas 2007-02-12 09:14:26 EST
I don't think those docs are useful because they are printable
but because they are viewable. I personally think that it would 
be nice to have something easier to view on a display than info 
files. And also that it would make sense to have that on the 
media for something as basic as awk. It is certainly used in 
scripts permitting network access. 

It is not a blocker for me anyway, only a suggestion.
Comment 18 Dan Horák 2007-02-13 09:08:31 EST
Everything looks good now, so package is APPROVED.
And let the printable docs problem remain open for some volunteer :-)
Comment 19 Dan Horák 2007-02-13 09:10:44 EST
And Karel, you could close bug #223686 as it is fixed now too.
Comment 20 petrosyan 2007-03-05 01:17:50 EST
The first sentence in the package description of gawk has a grammatical error.
"The gawk packages contains the GNU version of awk, a text processing utility."
it should be "The gawk package contains the GNU version of awk, a text
processing utility."
Comment 21 Karel Zak 2007-03-05 03:42:20 EST
(In reply to comment #20)
> The first sentence in the package description of gawk has a grammatical error.

 The typo has been fixed in CVS. Thanks.
Comment 22 Patrice Dumas 2007-06-01 03:28:59 EDT
I think that this bug should be closed now.
Comment 23 Patrice Dumas 2007-10-27 16:44:18 EDT
I think that this bug should be closed now.
Comment 24 Dan Horák 2007-10-28 06:05:43 EDT
Looks like there was a maintainer change. Stepan, can you check the package and
close this bug?
Comment 25 Patrice Dumas 2007-11-28 17:23:10 EST
Dan, this bug should be assigned to you, and Stepan should
be in CC. And this bug should be closed.

Note You need to log in before you can comment on or make changes to this bug.