This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 225794 - Merge Review: ghostscript-fonts
Merge Review: ghostscript-fonts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Susi Lehtola
Fedora Package Reviews List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 13:43 EST by Nobody's working on this, feel free to take it
Modified: 2009-06-10 11:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 11:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
susi.lehtola: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:43:25 EST
Fedora Merge Review: ghostscript-fonts

http://cvs.fedora.redhat.com/viewcvs/devel/ghostscript-fonts/
Initial Owner: twaugh@redhat.com
Comment 1 Roozbeh Pournader 2007-02-03 10:42:04 EST
Random notes:
* URL field points to an empty page. Should perhaps be changed to
http://www.gnu.org/software/ghostscript/ghostscript.html
* New upstream version (6.0) is available from http://ftp.gnu.org/gnu/ghostscript/
* BuildRoot should be changed to
%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
* The "Requires:" on ghostscript is probably unnecessary.
* May need to add some requirements for post and postun scripts.
Comment 2 Tim Waugh 2007-02-06 11:28:01 EST
Thanks!

> * New upstream version (6.0) is available from http://ftp.gnu.org/gnu/ghostscript/

6.0 is an older release (see the timestamp).

New package built: 5.50-15.fc7
Comment 3 Roozbeh Pournader 2007-02-07 09:13:51 EST
(In reply to comment #2)
> 6.0 is an older release (see the timestamp).

Worst than that, they are exactly the same thing. The bits are exactly the same!
I would still recommend using 6.0, so people won't think we are not using the
latest version in Fedora.

More random notes:
* Your new URL is still not good. The tarball is not provided from the
sourceforge servers, and not any real info either. It's a dead project. It just
says go to GNU for more info. Use either
http://savannah.gnu.org/projects/ghostscript/ or
http://www.gnu.org/software/ghostscript/. The second is preferred, as its more
user oriented. (BLOCKER)

* The URL in the Source line does not work anymore either. Use
http://ftp.gnu.org/gnu/ghostscript/gnu-gs-fonts-std-%{version}.tar.gz

* You should change the "Requires: fontconfig" line to different lines for
requirements after installation and uninstallation. Currently, one can ask
rpm/yum to remove both fontconfig and ghostscript-fonts and fontconfig may get
removed before ghostscript-fonts, making the post uninstallation scripts fail. A
similar scenario can happen with installation. Also, you need to have
mkfontscale, mkfontdir, and chkfontpath during some of these. (BLOCKER)

Suggested lines:
Requires: fontconfig
Requires(post): /usr/bin/mkfontscale /usr/bin/mkfontdir
Requires(post): /usr/sbin/chkfontpath
Requires(post): fontconfig
Requires(postun): /usr/sbin/chkfontpath
Requires(postun): fontconfig

* Copy the files during the %install section using the '-p' option of cp (or use
install -p).

* Have an empty %build section.

* Use %{_datadir} instead of /usr/share in the %files section. Also consider
adding a "/" at the end to show that we are actually including a directory and
files in there.

* There is nothing in the source tarball that says the license of the files is
GPL, as the license field of the spec file says. They may as well be proprietary
software, as far as a random observer can tell. Since contacting upstream for
including a license may not be trivial, the spec file should at least document
why we have made sure this is licensed under the GPL. (BLOCKER)

* The summary ends with a dot. It shouldn't.

* I don't think the use of parenthesized "(TM)" is really necessary in the
Summary line. The Fedora EULA already says that all trademarks are owned by
their respective owners.

* The part of the description that says you'll need to install this for
ghostscript to work is not that important to be worth a mention. That is simply
a Requires line in the ghostscript package.
Comment 4 Tim Waugh 2007-02-07 12:31:06 EST
Tagged and built as 5.50-16.fc7.

I changed the License tag to say 'Distributable'.
Comment 5 Alexei Podtelezhnikov 2007-02-09 10:22:01 EST
Still confused. What about 8.11 with much better international support?
Current offering pales in comparison. I don't know what was the reason 
to "upgrade" to old tiny set.

ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/fonts/ghostscript-fonts-std-8.11.tar.gz

This has been raised before in bug 203369 and bug 113866.
These are GPL. We are not in freeze yet. Why would you refuse them now?
Comment 6 Roozbeh Pournader 2007-02-09 10:47:57 EST
Leaving the rest of the review to other people, as I can't say I understand all
the story of the different versions and licenses.
Comment 7 Alexei Podtelezhnikov 2007-02-10 14:55:39 EST
Tim just clarified [see bug 203369] that this package only contains other, 
miscellaneous, or additional (whatever...) fonts for ghostscript. The more 
important fonts for ghostscript come from urw-fonts and are shared with X.org. 
This is cool!

Description does mention this but can be more upfront about this in the first 
sentence. Maybe, the packages should be more appropriately renamed to 
ghostscript-fonts-other?
Comment 8 Susi Lehtola 2009-05-21 07:10:20 EDT
Assigning.
Comment 9 Susi Lehtola 2009-05-21 07:35:26 EDT
- This is a legacy font package, so Font guidelines are not valid here.

- Change
 Requires(post): /usr/bin/mkfontscale /usr/bin/mkfontdir
to
 Requires(post): xorg-x11-font-utils
as this is the package that provides those since Fedora Core 2 (2004).

- I'm not totally sure you need
 Requires(post): fontconfig
 Requires(postun): fontconfig
as you already have Requires: fontconfig. Besides, this is probably automatically picked up by rpm. Doesn't hurt having them, though.

- Change references to /etc to %{_sysconfdir}

- Setting umask is probably not necessary as this is done by rpm.

- Replace `which mkfontdir` with plain mkfontdir.

- Drop
 %dir %{catalogue}
in %files section, as
 $ rpm -qf /etc/X11/fontpath.d/
 filesystem-2.4.19-1.fc10.i386
is already owned on every installation.

- I can't find a single mention of a license in the tarball!
Comment 10 Tim Waugh 2009-06-10 10:00:33 EDT
(In reply to comment #9)
> - Change
>  Requires(post): /usr/bin/mkfontscale /usr/bin/mkfontdir
> to
>  Requires(post): xorg-x11-font-utils
> as this is the package that provides those since Fedora Core 2 (2004).

Done.

> - I'm not totally sure you need
>  Requires(post): fontconfig
>  Requires(postun): fontconfig
> as you already have Requires: fontconfig. Besides, this is probably
> automatically picked up by rpm. Doesn't hurt having them, though.

Left alone.

> - Change references to /etc to %{_sysconfdir}

Done.

> - Setting umask is probably not necessary as this is done by rpm.
> - Replace `which mkfontdir` with plain mkfontdir.

Not sure about these.  The scriptlets were copied from urw-fonts, so if they need fixing they ought to be fixed in both places.

> - Drop
>  %dir %{catalogue}
> in %files section, as
>  $ rpm -qf /etc/X11/fontpath.d/
>  filesystem-2.4.19-1.fc10.i386
> is already owned on every installation.

Done.

> - I can't find a single mention of a license in the tarball!  

No, *sigh*.  Tom Callaway looked into the licenses in July last year, and there haven't been any developments since then.

5.50-21.fc12 built.
Comment 11 Susi Lehtola 2009-06-10 10:10:53 EDT
(In reply to comment #10)
> > - Setting umask is probably not necessary as this is done by rpm.
> > - Replace `which mkfontdir` with plain mkfontdir.
> 
> Not sure about these.  The scriptlets were copied from urw-fonts, so if they
> need fixing they ought to be fixed in both places.

urw-fonts hasn't been through a merge review, so you really can't trust that the packaging is sane on all accounts.
Comment 12 Tim Waugh 2009-06-10 10:22:48 EDT
OK, 5.50-22.fc12 built with all suggestions applied.  Thanks!
Comment 13 Susi Lehtola 2009-06-10 10:50:34 EDT
Uh, not so fast, I'll still do the review in full :)
Comment 14 Susi Lehtola 2009-06-10 11:07:16 EDT
rpmlint output is clean.


MUST: The spec file for the package is legible and macros are used consistently. OK
MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}. OK
MUST: The package must be licensed with a Fedora approved license and meet the  Licensing Guidelines. OK

MUST: The License field in the package spec file must match the actual license. ?
- No license information available.

MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. OK
MUST: The package MUST successfully compile and build into binary rpms. OK
MUST: The spec file MUST handle locales properly. N/A
MUST: Optflags are used and time stamps preserved. OK
MUST: A package must own all directories that it creates or require the package that owns the directory. OK
MUST: Files only listed once in %files listings. OK
MUST: Debuginfo package is complete. N/A
MUST: Permissions on files must be set properly. OK
MUST: Clean section exists. OK
MUST: Large documentation files must go in a -doc subpackage. N/A
MUST: All relevant items are included in %doc. Items in %doc do not affect runtime of application. OK
MUST: Desktop files are installed properly. N/A
MUST: No file conflicts with other packages and no general names. OK
MUST: Buildroot cleaned before install. OK
SHOULD: %{?dist} tag is used in release. OK
SHOULD: If the package does not include license text(s) as separate files from upstream, the packager should query upstream to include it. OK
SHOULD: The package builds in mock. OK

I trust spot's legal opinion in the license issue, so the package is

APPROVED
Comment 15 Tim Waugh 2009-06-10 11:14:53 EDT
Thanks!

Note You need to log in before you can comment on or make changes to this bug.