Bug 225923 - Merge Review: jakarta-commons-collections
Merge Review: jakarta-commons-collections
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Permaine Cheung
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:08 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-06 17:37:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pcheung: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:08:39 EST
Fedora Merge Review: jakarta-commons-collections

http://cvs.fedora.redhat.com/viewcvs/devel/jakarta-commons-collections/
Initial Owner: vivekl@redhat.com
Comment 2 Permaine Cheung 2007-03-26 15:38:13 EDT
Please fix items marked by X:
MUST:
* package is named appropriately
 - match upstream tarball or project name
 - try to match previous incarnations in other distributions/packagers for
consistency
 - specfile should be %{name}.spec
 - non-numeric characters should only be used in Release (ie. cvs or
   something)
 - for non-numerics (pre-release, CVS snapshots, etc.), see
   http://fedoraproject.org/wiki/Packaging/NamingGuidelines#PackageRelease
 - if case sensitivity is requested by upstream or you feel it should be
   not just lowercase, do so; otherwise, use all lower case for the name
* is it legal for Fedora to distribute this?
 - OSI-approved
 - not a kernel module
 - not shareware
 - is it covered by patents?
 - it *probably* shouldn't be an emulator
 - no binary firmware
* license field matches the actual license.
* license is open source-compatible.
 - use acronyms for licences where common
* specfile name matches %{name}
* verify source and patches (md5sum matches upstream, know what the patches do)
 - if upstream doesn't release source drops, put *clear* instructions on
   how to generate the the source drop; ie.
  # svn export blah/tag blah
  # tar cjf blah-version-src.tar.bz2 blah
* skim the summary and description for typos, etc.
X correct buildroot
 - should be:
   %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
* if %{?dist} is used, it should be in that form (note the ? and %
locations)
* license text included in package and marked with %doc
* keep old changelog entries; use judgement when removing (too old?
useless?)
* packages meets FHS (http://www.pathname.com/fhs/)
* rpmlint on <this package>.srpm gives no output
 - W: jakarta-commons-collections non-standard-group Development/Libraries/Java
- this is OK
* changelog is OK
* Packager tag should not be used
* Vendor tag should not be used
* Distribution tag should not be used
* use License and not Copyright
* Summary tag should not end in a period
* if possible, replace PreReq with Requires(pre) and/or Requires(post)
* specfile is legible
 - this is largely subjective; use your judgement
* package successfully compiles and builds on at least x86
* BuildRequires are proper
 - builds in mock will flush out problems here
 - the following packages don't need to be listed in BuildRequires:
   bash
   bzip2
   coreutils
   cpio
   diffutils
   fedora-release (and/or redhat-release)
   gcc
   gcc-c++
   gzip
   make
   patch
   perl
   redhat-rpm-config
   rpm-build
   sed
   tar
   unzip
   which
* summary should be a short and concise description of the package
* description expands upon summary (don't include installation
instructions)
* make sure lines are <= 80 characters
X specfile written in American English
- the Summary for the tomcat5 subpackage says "Collection dependency ...." and
description says "Collections dependency ....", (note the collections vs.
collection) maybe it should be consistent with the other subpackages, and use
"%{summary}." for the description.
X make a -doc sub-package if necessary
 - just a question: is there any manual subpackage when not built with with_maven?
* packages including libraries should exclude static libraries if possible
* don't use rpath
* config files should usually be marked with %config(noreplace)
* GUI apps should contain .desktop files
* should the package contain a -devel sub-package?
* use macros appropriately and consistently
 - ie. %{buildroot} and %{optflags} vs. $RPM_BUILD_ROOT and $RPM_OPT_FLAGS
* don't use %makeinstall
* locale data handling correct (find_lang)
 - if translations included, add BR: gettext and use %find_lang %{name} at the
   end of %install
* consider using cp -p to preserve timestamps
* split Requires(pre,post) into two separate lines
* package should probably not be relocatable
* package contains code
 - see http://fedoraproject.org/wiki/Packaging/Guidelines#CodeVsContent
 - in general, there should be no offensive content
* package should own all directories and files
* there should be no %files duplicates
* file permissions should be okay; %defattrs should be present
* %clean should be present
* %doc files should not affect runtime
* if it is a web apps, it should be in /usr/share/%{name} and *not* /var/www
* verify the final provides and requires of the binary RPMs
[pcheung@to-fcjpp1 ~]$ rpm -qp --provides
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-3.1-9jpp.1.fc7.x86_64.rpm
commons-collections = 0:3.1-9jpp.1.fc7
jakarta-commons-collections-3.1.jar.so()(64bit)
jakarta-commons-collections = 0:3.1-9jpp.1.fc7
[pcheung@to-fcjpp1 ~]$ rpm -qp --requires
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-3.1-9jpp.1.fc7.x86_64.rpm
/bin/sh
/bin/sh
java-gcj-compat
java-gcj-compat
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libdl.so.2()(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libgcj_bc.so.1()(64bit)
libm.so.6()(64bit)
libpthread.so.0()(64bit)
librt.so.1()(64bit)
libz.so.1()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rtld(GNU_HASH)
[pcheung@to-fcjpp1 ~]$ rpm -qp --provides
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-debuginfo-3.1-9jpp.1.fc7.x86_64.rpm
jakarta-commons-collections-3.1.jar.so.debug()(64bit)
jakarta-commons-collections-testframework-3.1.jar.so.debug()(64bit)
jakarta-commons-collections-tomcat5-3.1.jar.so.debug()(64bit)
jakarta-commons-collections-debuginfo = 0:3.1-9jpp.1.fc7
[pcheung@to-fcjpp1 ~]$ rpm -qp --requires
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-debuginfo-3.1-9jpp.1.fc7.x86_64.rpm
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[pcheung@to-fcjpp1 ~]$ rpm -qp --provides
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-javadoc-3.1-9jpp.1.fc7.x86_64.rpm
jakarta-commons-collections-javadoc = 0:3.1-9jpp.1.fc7
[pcheung@to-fcjpp1 ~]$ rpm -qp --requires
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-javadoc-3.1-9jpp.1.fc7.x86_64.rpm
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[pcheung@to-fcjpp1 ~]$ rpm -qp --provides
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-testframework-3.1-9jpp.1.fc7.x86_64.rpm
jakarta-commons-collections-testframework-3.1.jar.so()(64bit)
jakarta-commons-collections-testframework = 0:3.1-9jpp.1.fc7
[pcheung@to-fcjpp1 ~]$ rpm -qp --requires
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-testframework-3.1-9jpp.1.fc7.x86_64.rpm
/bin/sh
/bin/sh
jakarta-commons-collections = 0:3.1-9jpp.1.fc7
java-gcj-compat
java-gcj-compat
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libdl.so.2()(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libgcj_bc.so.1()(64bit)
libm.so.6()(64bit)
libpthread.so.0()(64bit)
librt.so.1()(64bit)
libz.so.1()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
[pcheung@to-fcjpp1 ~]$ rpm -qp --provides
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-testframework-javadoc-3.1-9jpp.1.fc7.x86_64.rpm
jakarta-commons-collections-testframework-javadoc = 0:3.1-9jpp.1.fc7
[pcheung@to-fcjpp1 ~]$ rpm -qp --requires
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-testframework-javadoc-3.1-9jpp.1.fc7.x86_64.rpm
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[pcheung@to-fcjpp1 ~]$ rpm -qp --provides
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-tomcat5-3.1-9jpp.1.fc7.x86_64.rpm
jakarta-commons-collections-tomcat5-3.1.jar.so()(64bit)
jakarta-commons-collections-tomcat5 = 0:3.1-9jpp.1.fc7
[pcheung@to-fcjpp1 ~]$ rpm -qp --requires
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-tomcat5-3.1-9jpp.1.fc7.x86_64.rpm
/bin/sh
/bin/sh
java-gcj-compat
java-gcj-compat
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libdl.so.2()(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libgcj_bc.so.1()(64bit)
libm.so.6()(64bit)
libpthread.so.0()(64bit)
librt.so.1()(64bit)
libz.so.1()(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
 
X run rpmlint on the binary RPMs
[pcheung@to-fcjpp1 review]$ rpmlint
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-*rpm
W: jakarta-commons-collections non-standard-group Development/Libraries/Java
W: jakarta-commons-collections non-standard-group Development/Libraries/Java
E: jakarta-commons-collections-debuginfo description-line-too-long This package
provides debug information for package jakarta-commons-collections.
W: jakarta-commons-collections-javadoc non-standard-group Development/Documentation
W: jakarta-commons-collections-testframework non-standard-group Development/Testing
W: jakarta-commons-collections-testframework no-documentation
W: jakarta-commons-collections-testframework filename-too-long-for-joliet
jakarta-commons-collections-testframework-3.1-9jpp.1.fc7.x86_64.rpm
W: jakarta-commons-collections-testframework-javadoc non-standard-group
Development/Documentation
W: jakarta-commons-collections-testframework-javadoc
filename-too-long-for-joliet
jakarta-commons-collections-testframework-javadoc-3.1-9jpp.1.fc7.x86_64.rpm
W: jakarta-commons-collections-tomcat5 non-standard-group Development/Libraries/Java
 
Is it possible to fix the error?  What about the filename-too-long-for-joliet
warnings? (Or are those (description and filename) all auto-generated?)
 
SHOULD:
* package should include license text in the package and mark it with %doc
* package should build on i386
* package should build in mock
Comment 3 Matt Wringe 2007-03-29 16:47:24 EDT
(In reply to comment #2)
> X correct buildroot
>  - should be:
>    %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Fixed

> X specfile written in American English
> - the Summary for the tomcat5 subpackage says "Collection dependency ...." and
> description says "Collections dependency ....", (note the collections vs.
> collection) maybe it should be consistent with the other subpackages, and use
> "%{summary}." for the description.
Fixed

> X make a -doc sub-package if necessary
>  - just a question: is there any manual subpackage when not built with with_maven?
The manual needs maven1 to build, maven1 is not in Fedora so we can not build
the manual using the generated ant tasks. Since maven2 is now in Fedora, when
the project updates to maven2 we can then generate the manual.

>  
> X run rpmlint on the binary RPMs
> [pcheung@to-fcjpp1 review]$ rpmlint
>
/var/lib/mock/fedora-development-x86_64-core-pcheung/result/jakarta-commons-collections-*rpm
> W: jakarta-commons-collections non-standard-group Development/Libraries/Java
> W: jakarta-commons-collections non-standard-group Development/Libraries/Java
> E: jakarta-commons-collections-debuginfo description-line-too-long This package

The debuginfo rpm is completetly autogenerated, I can't alter the description line.

> provides debug information for package jakarta-commons-collections.
> W: jakarta-commons-collections-javadoc non-standard-group
Development/Documentation
> W: jakarta-commons-collections-testframework non-standard-group
Development/Testing
> W: jakarta-commons-collections-testframework no-documentation
> W: jakarta-commons-collections-testframework filename-too-long-for-joliet
> jakarta-commons-collections-testframework-3.1-9jpp.1.fc7.x86_64.rpm
> W: jakarta-commons-collections-testframework-javadoc non-standard-group
> Development/Documentation
> W: jakarta-commons-collections-testframework-javadoc
> filename-too-long-for-joliet
> jakarta-commons-collections-testframework-javadoc-3.1-9jpp.1.fc7.x86_64.rpm
> W: jakarta-commons-collections-tomcat5 non-standard-group
Development/Libraries/Java
>  
> Is it possible to fix the error?  What about the filename-too-long-for-joliet
> warnings? (Or are those (description and filename) all auto-generated?)

I am not so sure about the joliet warnings, this is because the filename is too
long for the rpm. Since this is only a warning, and this package has been in
Fedora a couple of release with this issue, I think it should be safe to ignore.
The only way to get rid of this message is to rename the packages.

Updated package here:
https://mwringe.108.redhat.com/files/documents/175/324/jakarta-commons-collections-3.1-9jpp.1.src.rpm


Comment 4 Permaine Cheung 2007-04-03 13:46:57 EDT
With the new srpm, rpmlint on the tomcat5 subpackage gives:
W: jakarta-commons-collections-tomcat5 summary-not-capitalized
jakarta-commons-collections dependency for Tomcat5
Please fix this.

Also, the Summary on the main package is just the package name, please fix that
as well.

Thanks.
Comment 5 Matt Wringe 2007-04-03 16:10:50 EDT
(In reply to comment #4)
> With the new srpm, rpmlint on the tomcat5 subpackage gives:
> W: jakarta-commons-collections-tomcat5 summary-not-capitalized
> jakarta-commons-collections dependency for Tomcat5
> Please fix this.
Fixed

> Also, the Summary on the main package is just the package name, please fix that
> as well.
Fixed

Updated srpm:
https://mwringe.108.redhat.com/files/documents/175/324/jakarta-commons-collections-3.1-9jpp.1.src.rpm


Comment 6 Permaine Cheung 2007-04-03 18:06:38 EDT
Running rpmlint on the final binary rpms gives:
W: jakarta-commons-collections non-standard-group Development/Libraries/Java
E: jakarta-commons-collections-debuginfo description-line-too-long This package
provides debug information for package jakarta-commons-collections.
W: jakarta-commons-collections-javadoc non-standard-group Development/Documentation
W: jakarta-commons-collections-testframework non-standard-group Development/Testing
W: jakarta-commons-collections-testframework no-documentation
W: jakarta-commons-collections-testframework filename-too-long-for-joliet
jakarta-commons-collections-testframework-3.1-9jpp.1.fc7.x86_64.rpm
W: jakarta-commons-collections-testframework-javadoc non-standard-group
Development/Documentation
W: jakarta-commons-collections-testframework-javadoc
filename-too-long-for-joliet
jakarta-commons-collections-testframework-javadoc-3.1-9jpp.1.fc7.x86_64.rpm
W: jakarta-commons-collections-tomcat5 non-standard-group Development/Libraries/Java

APPROVED.
Comment 7 Matt Wringe 2007-04-25 21:09:29 EDT
Built into Rawhide
Comment 8 Permaine Cheung 2007-07-06 17:37:16 EDT
Closing bug report

Note You need to log in before you can comment on or make changes to this bug.