Bug 225969 - Merge Review: kernel
Merge Review: kernel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Package Reviews List
: Reopened
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 14:15 EST by Nobody's working on this, feel free to take it
Modified: 2015-02-11 15:41 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-11 15:41:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:15:51 EST
Fedora Merge Review: kernel

http://cvs.fedora.redhat.com/viewcvs/devel/kernel/
Initial Owner: davej@redhat.com
Comment 1 Roozbeh Pournader 2007-02-05 09:40:23 EST
BLOCKER: spec filename is not %{name}.spec

From the review guidelines:
  MUST: The spec file name must match the base package %{name}, in the format
  %{name}.spec
Comment 2 Kyle McMartin 2009-03-30 18:36:09 EDT
Package Change Request
======================
Package Name: kernel
New Branches: F-11
Owners: kyle@redhat.com, davej@redhat.com, cebbert@redhat.com

Branch for F-11, plz.
Comment 3 Kevin Fenzi 2009-03-30 18:51:51 EDT
cvs done.
Comment 4 Jeff Garzik 2010-07-08 00:17:57 EDT
this merge review BZ for "kernel" pkg is outdated and a bit pointless at this point :)  closing.
Comment 5 Parag AN(पराग) 2010-07-08 00:22:38 EDT
So what is outdated here mean? Do you plan to open new bugzilla for kernel package review?
Comment 6 Jeff Garzik 2010-07-08 00:28:27 EDT
The merge occurred long ago.

Any meaningful problems are filed under individual bugzillas assigned to the 'kernel' package, today.
Comment 7 Robert Scheck 2010-07-08 02:49:55 EDT
Jeff, dumb Red Hat employee! You are not allowed to close this review
before a reviewer has set fedora-review+ (and did a qualified package
review according to our Fedora Packaging guidelines); clearing flag...
Comment 8 Rakesh Pandit 2010-07-08 03:21:00 EDT
@Robert
Refrain from using this language. It is not acceptable and does not help either.


@Jeff
Why would you set fedora-review `+` if no review has happened and close it?
Comment 9 Jeff Garzik 2010-07-08 03:42:44 EDT
The reasons were stated in comment #6.

It is a profound waste of resources to open reviews for packages that have been merged for over a decade.  This is even more clear when this bugzilla lays untouched for over three years.

Fedora has hundreds of not-yet-merged packages that _really do_ need review.  The kernel is not one of them.
Comment 10 Parag AN(पराग) 2010-07-08 04:34:36 EDT
Jeff,
   I suppose when you say "packages that have been merged for over a decade", you are knowing this already => https://fedoraproject.org/wiki/Merge_Reviews
Comment 11 Jeff Garzik 2010-07-08 14:21:51 EDT
Yes, existing packages can be reviewed.

It is patently obvious from the activity on this bugzilla that nobody cares enough to do anything except let this entry sit around and clutter to list of packages to be reviewed.
Comment 12 Rakesh Pandit 2010-07-09 02:40:43 EDT
Ok, but closing with resolution to currentrelease and setting flag 'fedora-review' to + does not sync with your justification. No one reviewed it here at least.
Comment 13 Tom "spot" Callaway 2010-10-25 15:52:39 EDT
The kernel is a rather unique package for Fedora. It does a few unique things:

* It makes heavy use of macros, notably, to generate files sections and apply patches.
* Its Release is dynamically generated.
* It has multiple architecture specific sections
* It has specific conflicts, all to prevent conflicts with older userspace components.
* It uses the buildroot starting in %prep, in %build, and in %install. Normally, this would be very bad form, but the complexity of the kernel actually makes it simpler to permit this use. In any other package, this would mandate reworking, so please, don't copy this behavior.

With that stated, here is the first part of a review (against rawhide 2.6.36-1.fc15):

== Part 1: rpmlint ==

kernel.src: W: name-repeated-in-summary C kernel
kernel.x86_64: W: name-repeated-in-summary C kernel

(Given that the Summary is "The Linux kernel", I think this is safe to ignore)

kernel.src: W: spelling-error %description -l en_US vmlinuz -> drumlin, Kremlin, kremlin
kernel.x86_64: W: spelling-error %description -l en_US vmlinuz -> drumlin, Kremlin, kremlin
kernel-debuginfo-common-x86_64.x86_64: W: spelling-error %description -l en_US subpackages -> sub packages, sub-packages, prepackages
kernel-devel.x86_64: W: spelling-error %description -l en_US makefiles -> make files, make-files, makefast
kernel-headers.x86_64: W: spelling-error Summary(en_US) glibc -> glib, glib c, glitch
kernel-headers.x86_64: W: spelling-error %description -l en_US userspace -> user space, user-space, users pace
kernel-headers.x86_64: W: spelling-error %description -l en_US glibc -> glib, glib c, glitch

(False positives, safe to ignore)

kernel.src: W: strange-permission merge.pl 0755L
kernel.src: W: strange-permission find-provides 0755L

(Odd permissions, but not faulty. Safe to ignore.)

kernel.src:221: E: hardcoded-library-path in /usr/lib/debug

(This is the correct debuginfo path for all targets, safe to ignore.)

kernel.src:386: W: macro-in-comment %nobuildarches
kernel.src:432: W: macro-in-comment %post
kernel.src:1002: W: macro-in-comment %{vanillaversion}
kernel.src:1003: W: macro-in-comment %{kversion}
kernel.src:1005: W: macro-in-comment %{kversion}
kernel.src:1883: W: macro-in-comment %{image_install_path}

(Packagers should avoid using macros in comments, but this is a minor error. The easy fix here is to %% comment out any macros in comments, to prevent unexpected and random behavior.)

kernel.src:485: W: unversioned-explicit-obsoletes kernel-smp

(I'm not sure there is an appropriate version here. This one can probably die off in a release or so anyways.)

kernel.src:757: W: unversioned-explicit-obsoletes glibc-kernheaders
kernel-headers.x86_64: W: self-obsoletion glibc-kernheaders obsoletes glibc-kernheaders = 3.0-46

(To resolve these two items, adjust the spec to read: Obsoletes: glibc-kernheaders < 3.0-46)

kernel.src:940: E: use-of-RPM_SOURCE_DIR

(The kernel's custom patch macro needs to use RPM_SOURCE_DIR, and is exempt from any restrictions here.)

kernel.src:944: W: deprecated-grep [u'egrep']
kernel.src:1379: W: deprecated-grep [u'egrep']
kernel.src:1576: W: deprecated-grep [u'fgrep']
kernel.src:1602: W: deprecated-grep [u'egrep']

(Should be changed to grep -E or grep -F, as "egrep" and "fgrep" are deprecated.)

kernel.src:975: W: rpm-buildroot-usage %prep make INSTALL_FW_PATH=$RPM_BUILD_ROOT/lib/firmware firmware_install \
kernel.src:1470: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT%{debuginfodir}/boot
kernel.src:1471: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT%{debuginfodir}/%{image_install_path}
kernel.src:1473: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
kernel.src:1474: W: rpm-buildroot-usage %build install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
kernel.src:1475: W: rpm-buildroot-usage %build install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
kernel.src:1479: W: rpm-buildroot-usage %build dd if=/dev/zero of=$RPM_BUILD_ROOT/boot/initramfs-$KernelVer.img bs=1M count=20
kernel.src:1482: W: rpm-buildroot-usage %build cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
kernel.src:1485: W: rpm-buildroot-usage %build $RPM_BUILD_ROOT/%{image_install_path}/$InstallName-$KernelVer
kernel.src:1486: W: rpm-buildroot-usage %build chmod 755 $RPM_BUILD_ROOT/%{image_install_path}/$InstallName-$KernelVer
kernel.src:1488: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
kernel.src:1491: W: rpm-buildroot-usage %build make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer mod-fw=
kernel.src:1493: W: rpm-buildroot-usage %build make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT vdso_install KERNELRELEASE=$KernelVer
kernel.src:1499: W: rpm-buildroot-usage %build $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernel-$KernelVer.conf
kernel.src:1509: W: rpm-buildroot-usage %build rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
kernel.src:1510: W: rpm-buildroot-usage %build rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
kernel.src:1511: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
kernel.src:1512: W: rpm-buildroot-usage %build (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
kernel.src:1514: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
kernel.src:1515: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
kernel.src:1517: W: rpm-buildroot-usage %build cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
kernel.src:1518: W: rpm-buildroot-usage %build cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
kernel.src:1519: W: rpm-buildroot-usage %build cp System.map $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
kernel.src:1521: W: rpm-buildroot-usage %build cp Module.markers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
kernel.src:1524: W: rpm-buildroot-usage %build rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
kernel.src:1525: W: rpm-buildroot-usage %build rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
kernel.src:1526: W: rpm-buildroot-usage %build rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
kernel.src:1527: W: rpm-buildroot-usage %build cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
kernel.src:1528: W: rpm-buildroot-usage %build cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
kernel.src:1530: W: rpm-buildroot-usage %build cp -a arch/$Arch/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
kernel.src:1533: W: rpm-buildroot-usage %build cp -a arch/$Arch/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
kernel.src:1535: W: rpm-buildroot-usage %build rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
kernel.src:1536: W: rpm-buildroot-usage %build rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
kernel.src:1538: W: rpm-buildroot-usage %build cp -a --parents arch/powerpc/lib/crtsavres.[So] $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
kernel.src:1541: W: rpm-buildroot-usage %build cp -a --parents arch/%{asmarch}/include $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
kernel.src:1543: W: rpm-buildroot-usage %build cp -a include $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
kernel.src:1547: W: rpm-buildroot-usage %build touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
kernel.src:1548: W: rpm-buildroot-usage %build touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
kernel.src:1550: W: rpm-buildroot-usage %build cp $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/config/auto.conf
kernel.src:1554: W: rpm-buildroot-usage %build cp vmlinux.id $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/vmlinux.id
kernel.src:1565: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer
kernel.src:1566: W: rpm-buildroot-usage %build cp vmlinux $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer
kernel.src:1569: W: rpm-buildroot-usage %build find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
kernel.src:1582: W: rpm-buildroot-usage %build LC_ALL=C sort -u > $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.$1
kernel.src:1611: W: rpm-buildroot-usage %build rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.$i
kernel.src:1615: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
kernel.src:1616: W: rpm-buildroot-usage %build mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
kernel.src:1617: W: rpm-buildroot-usage %build ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
kernel.src:1625: W: rpm-buildroot-usage %build rm -rf $RPM_BUILD_ROOT
kernel.src:1626: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT/boot
kernel.src:1627: W: rpm-buildroot-usage %build mkdir -p $RPM_BUILD_ROOT%{_libexecdir}

(See above comments about buildroot. Safe to ignore.)

kernel.src:2188: W: macro-in-%changelog %released_kernel
kernel.src:2232: W: macro-in-%changelog %verify
kernel.src:2411: W: macro-in-%changelog %{expand

(Packagers should avoid using macros in changelog items, but this is a minor error. The easy fix here is to %% comment out any macros in changelog entries, to prevent unexpected and random behavior.)

kernel.src:147: W: mixed-use-of-spaces-and-tabs (spaces: line 103, tab: line 147)

(This is an easy clean up, just replace the use of tabs in line 147 with spaces to match the others.)

kernel.src: W: patch-not-applied Patch0: patch-2.6.%{base_sublevel}-git%{gitrev}.bz2
[ ... repeated for all patches ... ]

(Kernel patches using its own macro routine, safe to ignore these warnings.)

kernel.x86_64: W: obsolete-not-provided kernel-smp

(Normally, you'd want Provides: kernel-smp here, but I don't think this is necessary, given that the Obsoletes: kernel-smp is likely to die off soon.)

kernel.x86_64: E: useless-provides kernel

(This is coming from line 445: Provides: kernel = %{rpmversion}-%{pkg_release}\.
I don't see any reason for this line, as rpm is autoproviding kernel = %{version}-%{release} (and %{version} is being set to %{rpmversion} and %{release} is being set to %{pkg_release}.)

kernel.x86_64: W: unstripped-binary-or-object /lib/modules/2.6.36-1.fc15.x86_64/kernel/drivers/scsi/fcoe/libfcoe.ko
[ ... repeated for all kernel modules ... ]

(Dave Jones thinks this is intentional, possibly because it is necessary for kallsyms to work properly during oopses. Assuming this is true, safe to ignore.)

kernel.x86_64: E: shared-lib-without-dependency-information /lib/modules/2.6.36-1.fc15.x86_64/vdso/vdso32-syscall.so
kernel.x86_64: E: shared-lib-without-dependency-information /lib/modules/2.6.36-1.fc15.x86_64/vdso/vdso.so
kernel.x86_64: E: shared-lib-without-dependency-information /lib/modules/2.6.36-1.fc15.x86_64/vdso/vdso32-int80.so
kernel.x86_64: E: missing-PT_GNU_STACK-section /lib/modules/2.6.36-1.fc15.x86_64/vdso/vdso32-syscall.so
kernel.x86_64: E: missing-PT_GNU_STACK-section /lib/modules/2.6.36-1.fc15.x86_64/vdso/vdso.so
kernel.x86_64: E: missing-PT_GNU_STACK-section /lib/modules/2.6.36-1.fc15.x86_64/vdso/vdso32-int80.so

(I don't begin to claim that I understand what's happening here, but I suspect that these vdso files server a specific purpose and that these warnings do not apply to them.)

kernel.x86_64: W: no-documentation

(At a minimum, COPYING should be present as %doc with the GPLv2 terms.)

kernel.x86_64: E: non-standard-executable-perm /lib/modules/2.6.36-1.fc15.x86_64/kernel/drivers/scsi/fcoe/libfcoe.ko 0744L
[ ... repeated for all kernel modules ... ]

(This is done intentionally, so that the spec can strip the source debugging info, but leave the symbols. Safe to ignore.)

kernel.x86_64: W: dangling-relative-symlink /lib/modules/2.6.36-1.fc15.x86_64/build ../../../usr/src/kernels/2.6.36-1.fc15.x86_64

(It seems odd that /lib/modules/2.6.36-1.fc15.x86_64/build is packaged in kernel, but the symlink it points to is in kernel-devel. Is there a reason that the /lib/modules/2.6.36-1.fc15.x86_64/build ownership isn't in kernel-devel?)

kernel.x86_64: W: non-conffile-in-etc /etc/ld.so.conf.d/kernel-2.6.36-1.fc15.x86_64.conf

(Should this be marked as %config(noreplace)?)

kernel-debuginfo-common-x86_64.x86_64: W: devel-file-in-non-devel-package /usr/src/debug/kernel-2.6.36.fc15/linux-2.6.36.x86_64/drivers/net/mlx4/en_cq.c
[ ... repeated for all kernel .c and .h files ... ]

(Safe to ignore.)

kernel-devel.x86_64: E: useless-provides kernel-devel

(This is being thrown by line 831: Provides: kernel-devel = %{version}-%{release}%{?1:.%{1}}\ but is actually necessary if the macro is triggered with a pretty_name. Safe to ignore.)

kernel-devel.x86_64: W: no-documentation
(There are documentation files included in kernel-devel, they are not marked as %doc though. Recognizing that the kernel-devel file list is autogenerated, I can't see a good way to accomplish this file marking, so I propose that this is safe to ignore.)

kernel-devel.x86_64: E: zero-length /usr/src/kernels/2.6.36-1.fc15.x86_64/include/config/fb/via.h
[ ... repeated for several hundred empty kernel .h files ... ]

(I assume that all of these zero length header files are kernel header files which are not intended to be exposed/exported to userspace. Perhaps it makes sense to iterate through the buildroot at the end of install and delete all of the zero length header files? Might speed up the -devel transaction.)

kernel-devel.x86_64: E: version-control-internal-file /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/selinux/genheaders/.gitignore
kernel-devel.x86_64: E: version-control-internal-file /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/kconfig/.gitignore
kernel-devel.x86_64: E: version-control-internal-file /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/basic/.gitignore
kernel-devel.x86_64: E: version-control-internal-file /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/kconfig/lxdialog/.gitignore
kernel-devel.x86_64: E: version-control-internal-file /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/selinux/mdp/.gitignore
kernel-devel.x86_64: E: version-control-internal-file /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/.gitignore
kernel-devel.x86_64: E: version-control-internal-file /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mod/.gitignore
kernel-devel.x86_64: E: version-control-internal-file /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/genksyms/.gitignore
kernel-devel.x86_64: E: version-control-internal-file /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/dtc/.gitignore

(These files should be deleted from the buildroot at the end of %install. Easy fix.)

kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/rt-tester/rt-tester.py 0644L /usr/bin/python
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/headers_install.pl 0644L /usr/bin/perl
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/gcc-x86_32-has-stack-protector.sh 0644L /bin/sh
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/gfp-translate 0644L /bin/bash
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/kconfig/lxdialog/check-lxdialog.sh 0644L /bin/sh
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/export_report.pl 0644L /usr/bin/perl
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mksysmap 0644L /bin/sh
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/package/builddeb 0644L /bin/sh
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/gen_initramfs_list.sh 0644L /bin/bash
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/bootgraph.pl 0644L /usr/bin/perl
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/tracing/draw_functrace.py 0644L /usr/bin/python
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/headers_check.pl 0644L /usr/bin/perl
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/selinux/install_policy.sh 0644L /bin/sh
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/gcc-version.sh 0644L /bin/sh
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/profile2linkerlist.pl 0644L /usr/bin/perl
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/kconfig/streamline_config.pl 0644L /usr/bin/perl
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/markup_oops.pl 0644L /usr/bin/perl
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mkmakefile 0644L /bin/sh
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/package/buildtar 0644L /bin/sh
kernel-devel.x86_64: E: non-executable-script /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/gcc-x86_64-has-stack-protector.sh 0644L /bin/sh

(These script files are being packaged, but probably set to chmod -x to prevent kernel-devel from picking up dependencies. This list of files should be reviewed to see whether they should remain in kernel-devel or be deleted from the buildroot at the end of %install. If any of these files are useful and are kept in kernel-devel, they should be set executable so proper dependencies are found for these scripts by RPM.)

kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/selinux/mdp/.mdp.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/.kallsyms.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/.conmakehash.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/.config
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/basic/.fixdep.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/kconfig/.conf.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/kconfig/.conf.o.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mod/.modpost.o.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/basic/.docproc.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/selinux/genheaders/.genheaders.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/.unifdef.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mod/.mk_elfconfig.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mod/.elfconfig.h.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/basic/.hash.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mod/.file2alias.o.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mod/.sumversion.o.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/kconfig/.zconf.tab.o.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mod/.modpost.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/kconfig/.kxgettext.o.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/mod/.empty.o.cmd
kernel-devel.x86_64: W: hidden-file-or-dir /usr/src/kernels/2.6.36-1.fc15.x86_64/scripts/.pnmtologo.cmd

(Are any of these hidden files useful in kernel-devel? If so, it is okay to keep them, otherwise, they should be deleted from the %buildroot at the end of %install.)

kernel-headers.x86_64: W: no-documentation

(Safe to ignore.)

perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/Util.py
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/python/check-perf-trace.py
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/Core.pm
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/python/syscall-counts-by-pid.py
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/SchedGui.py
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/Util.pm
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/python/syscall-counts.py
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/Context.pm
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/perl/failed-syscalls.pl
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/Core.py
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/perl/check-perf-trace.pl
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/python/sctop.py
perf.x86_64: E: script-without-shebang /usr/libexec/perf-core/scripts/python/failed-syscalls-by-pid.py

(Safe to ignore.)
Comment 14 Cole Robinson 2015-02-11 15:37:19 EST
Mass reassigning all merge reviews to their component. For more details, see this FESCO ticket:

  https://fedorahosted.org/fesco/ticket/1269

If you don't know what merge reviews are about, please see:

  https://fedoraproject.org/wiki/Merge_Reviews

How to handle this bug is left to the discretion of the package maintainer.
Comment 15 Josh Boyer 2015-02-11 15:41:39 EST
If someone wants to get around to doing this, please post patches on the fedora kernel list.

Note You need to log in before you can comment on or make changes to this bug.