Bug 226032 - Merge Review: libjpeg
Merge Review: libjpeg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:25 EST by Nobody's working on this, feel free to take it
Modified: 2012-06-15 12:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-31 04:49:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:25:48 EST
Fedora Merge Review: libjpeg

http://cvs.fedora.redhat.com/viewcvs/devel/libjpeg/
Initial Owner: tgl@redhat.com
Comment 1 Matthias Saou 2007-08-31 13:12:25 EDT
Please find an updated spec file and a patch to the current spec file containing
some suggested changes and fixes :
http://thias.fedorapeople.org/merge-review/libjpeg/

- Use original IJG source URL and switch to official gz (no bz2 in sight...).
- Move "make test" to %%check section.
- Include install patch to support DESTDIR and fix man pages location.

It could also make sense to split off the binaries and their man pages into a
"tools" sub-package, or maybe "-n jpeg-tools" to not contain "lib" in the name.
Comment 2 Matthias Saou 2007-08-31 13:23:06 EDT
Possibly another detail : Does linking statically also require the headers?
Probably, and in which case, we need to either :
- Have the static sub-package require the devel sub-package
- Also include the headers in the static sub-package
Comment 3 Matthias Saou 2007-09-12 07:24:33 EDT
Ping? It would be nice to get this package cleaned up for Fedora 8.
Comment 4 Matthias Saou 2007-10-22 11:14:27 EDT
Too late for Fedora 8... ping again?
Comment 5 Matthias Saou 2008-12-22 17:13:57 EST
I've updated the modified spec file and patch against the latest libjpeg from CVS, still found here :
http://thias.fedorapeople.org/merge-review/libjpeg/
Comment 6 Robert Scheck 2009-01-13 16:55:24 EST
Tom, can you please show up at this bug report?
Comment 7 Tom Lane 2009-01-13 18:25:26 EST
I haven't been too excited about this because hacking on those 1998-vintage makefiles is just putting lipstick on a pig :-(.  I am hopeful that the sourceforge project will produce an update sometime soon and then we'll have an upstream that is worth cleaning up.

BTW, the ftp.uu.net address *is* the original, well-published, and still functional URL.  Let's not have any historical revisionism in the specfile.
Comment 8 Matthias Saou 2009-01-14 08:21:25 EST
(In reply to comment #7)
> BTW, the ftp.uu.net address *is* the original, well-published, and still
> functional URL.  Let's not have any historical revisionism in the specfile.

My bad, I had to hunt down a working URL when I saw that there was no .tar.bz2 there, but that has been resolved since.

As for the makefile change, the one I suggest is trivial and (IMHO) clean. It just sets the paths to the usual Fedora values and adds a $(DESTDIR).

I've just has a look at the sf.net project, and the latest files in CVS don't look much different, so it seems like you have high hopes... I'd suggest cleaning up the package as much as possible now, and if things ever get better later, then great, but if they don't, we'll at least have the package in a somewhat cleaner state.
Comment 9 Matthias Saou 2009-12-08 12:50:31 EST
I still vote for the porcine beautifying :-)
http://libjpeg.cvs.sourceforge.net/viewvc/libjpeg/libjpeg/
Only a handful of changes in the last 3 years, and none that look anything like cleanups or refactoring, the vintage makefiles seem here to stay.
Comment 10 Peter Lemenkov 2012-03-31 04:49:30 EDT
Time to close this ticket since libjpeg was retired (in the favour of libjpeg-turbo).
Comment 11 Parag AN(पराग) 2012-06-15 12:26:56 EDT
This bug just popped out when I searched for packages under review but looks like this package was retired already.

Dropping the flag fedora-review?

Note You need to log in before you can comment on or make changes to this bug.