Bug 2260500 - WebRTC videochat (Google Meet) doesn't work
Summary: WebRTC videochat (Google Meet) doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 39
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2262218 2262257 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-01-26 13:58 UTC by Yauhen Shulitski
Modified: 2024-02-09 01:25 UTC (History)
21 users (show)

Fixed In Version: firefox-122.0-5.fc38 firefox-122.0-5.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-05 01:46:33 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Debian BTS 1061495 0 None None None 2024-01-26 15:33:49 UTC
Mozilla Foundation 1875201 0 -- NEW No vp8 or vp9 WebRTC video sent with --with-system-libvpx 2024-01-26 15:28:52 UTC

Description Yauhen Shulitski 2024-01-26 13:58:36 UTC
Hi,

Videochat WebRTC solutions like Google Meet don't work in the latest Firefox 122 build from fedora. It does work if I just download tar.gz file from the official firefox website (https://www.mozilla.org/en-US/firefox/download/thanks/).

Reproducible: Always

Steps to Reproduce:
1. Start Google meet meeting with camera enabled
Actual Results:  
No one in the meeting can see or hear you 

Expected Results:  
Your videocamera stream is visible for all participants

Reproducible on Firefox 122.0-1.fc39

Comment 1 Martin Stransky 2024-01-26 14:35:19 UTC
Can you try to attend the meeting with new profile?
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Test_Firefox_with_a_new_profile

Can you also try another WebRTC page?
https://mozilla.github.io/webrtc-landing/gum_test.html

Also can you try to run Firefox under X11? Run on terminal with MOZ_ENABLE_WAYLAND=0 env variable like:

MOZ_ENABLE_WAYLAND=0 firefox

Thanks.

Comment 2 Yauhen Shulitski 2024-01-26 14:56:22 UTC
Hi Martin,

getUserMedia call works locally for me without problem. I also tried different WebRTC solutions and it is the same problem - I can see the video preview, but no one can see my video. I tried running it with 
`MOZ_ENABLE_WAYLAND=0 firefox` no luck, also tried it in the new profile - no luck.

Comment 3 Florian Weimer 2024-01-26 15:28:52 UTC
https://bugzilla.mozilla.org/show_bug.cgi?id=1875201 suggests it's due to --with-system-libvpx, which we use in Fedora builds.

Comment 4 Frédéric Bérat 2024-01-30 12:04:24 UTC
Since I face the same problem, I tried everything suggested here without success.

I can confirm that the flatpak works without troubles.

I'm currently using the following workaround, even though I don't like changing `about:config` stuff:

https://bugzilla.mozilla.org/show_bug.cgi?id=1875201#c16

Comment 5 Martin Stransky 2024-02-01 12:26:36 UTC
New builds (122.0-5) are on the way:
https://koji.fedoraproject.org/koji/packageinfo?packageID=37

Comment 6 Martin Stransky 2024-02-01 12:27:29 UTC
*** Bug 2262257 has been marked as a duplicate of this bug. ***

Comment 7 Martin Stransky 2024-02-01 12:28:35 UTC
*** Bug 2262218 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2024-02-02 08:19:40 UTC
FEDORA-2024-11e68f58e9 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2024-11e68f58e9

Comment 9 Fedora Update System 2024-02-02 08:19:41 UTC
FEDORA-2024-611d3daff4 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2024-611d3daff4

Comment 10 Juha Heljoranta 2024-02-02 11:39:04 UTC
122.0-5 fixed the problem for me.

Comment 11 Yauhen Shulitski 2024-02-02 12:22:24 UTC
Yeah, 122.0-5 fixes the problem. Thanks, Martin!

Comment 12 Fedora Update System 2024-02-03 01:08:27 UTC
FEDORA-2024-11e68f58e9 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-11e68f58e9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-11e68f58e9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2024-02-05 01:46:33 UTC
FEDORA-2024-11e68f58e9 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2024-02-09 01:25:25 UTC
FEDORA-2024-611d3daff4 (firefox-122.0-5.fc39) has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.