Bug 22607 - Testing X setup kills installer
Summary: Testing X setup kills installer
Status: CLOSED DUPLICATE of bug 22753
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-20 20:29 UTC by Wade Minter
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-22 13:34:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wade Minter 2000-12-20 20:29:32 UTC
My video card and monitor were both detected successfully during the
install.  I set up X to use 1152xwhatever@16bit, and hit the "Test X setup"
button.

The Gnome test desktop came up without problems, and I hit the confirm
button.  When the installer came back to the installer screens, there were
a lot of artifacts on the display, and the screen wouldn't update any
more.  Hitting "next" seemed to advance the installer, judging by disk
access, but the screen stayed exactly the same.

Upon rebooting and starting the installer again, the same garbled screen
was there when X started, but was quickly replaced by the normal
installer.  Installation without testing X proceeded normally.

The video card is a 3DFX Voodoo3-3000, 16MB.

Comment 1 Joshua Buysse 2000-12-21 07:59:46 UTC
Verified, Voodoo 3.  

One thing to add.  I tried using 1400x1050 first, which did not give me a 
usable screen, so I pressed 'n' to tell the installer that it didn't work.  
When I did that, the "Test setting" button remained pressed and the interface 
became unresponsive, but I was still able to change the resolution and test 
again.  When I accepted the result, the system hung.  Ctrl-Alt-F1 wouldn't 
break out either.

Comment 2 Michael Fulbright 2000-12-21 19:20:23 UTC
Assigning for a developer.

Comment 3 Brent Fox 2000-12-22 13:34:22 UTC
Hmm.  When you get to the syslinux prompt, try typing 'nofb'.  This will force
the installer to skip framebuffer mode altogether and start the graphical
installer with whatever X server that card uses.  I'm trying to figure out if
this bug is related to framebuffer mode.

Comment 4 Brent Fox 2000-12-28 22:27:53 UTC

*** This bug has been marked as a duplicate of 22753 ***


Note You need to log in before you can comment on or make changes to this bug.