Bug 226078 - Merge Review: libxklavier
Merge Review: libxklavier
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 14:31 EST by Nobody's working on this, feel free to take it
Modified: 2009-08-21 05:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 05:03:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 14:31:14 EST
Fedora Merge Review: libxklavier

http://cvs.fedora.redhat.com/viewcvs/devel/libxklavier/
Initial Owner: rstrode@redhat.com
Comment 1 Parag AN(पराग) 2009-07-24 06:45:55 EDT
Review:
+ package builds in mock (rawhide i686).
koji Build =>http://koji.fedoraproject.org/koji/taskinfo?taskID=1497503
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
37c6e9fb8b436d6a646a6eea09cf196baad28756  libxklavier-4.0.tar.bz2
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ libxklavier.pc file present.
+ -devel subpackage present.
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ ldconfig scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Package  libxklavier-4.0-3.fc12.i686=>
Provides: libxklavier.so.15
Requires: libX11.so.6 libXi.so.6 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.3.4) libc.so.6(GLIBC_2.4) libglib-2.0.so.0 libgobject-2.0.so.0 libxkbfile.so.1 libxklavier.so.15 libxml2.so.2 rtld(GNU_HASH)
+ Package libxklavier-devel-4.0-3.fc12.i686 =>
Provides: pkgconfig(libxklavier) = 4.0
Requires: /usr/bin/pkg-config libxklavier.so.15 pkgconfig(libxml-2.0)

+ Not a GUI application

Should:
1) follow http://fedoraproject.org/wiki/PackagingGuidelines#Timestamps
Comment 2 Parag AN(पराग) 2009-07-24 06:50:31 EDT
I also don't get why we need
Requires: libxml2-devel
for -devel subpackage?
Comment 3 Matthias Clasen 2009-07-24 15:08:55 EDT
It used to be necessary because the  .pc file has a Requires: libxml-2.0
Nowadays, pkg-config autodeps should take care of it, so it can go.
Comment 4 Parag AN(पराग) 2009-08-07 01:05:10 EDT
There are no blockers for this review.
APPROVED

Note You need to log in before you can comment on or make changes to this bug.