Bug 22610 - Running kernel fails to detect CARDBUS (PCMCIA) network card
Running kernel fails to detect CARDBUS (PCMCIA) network card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-20 15:31 EST by Anders Carlsson
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-31 06:32:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anders Carlsson 2000-12-20 15:31:51 EST
I have a PCMCIA network card, a 3Com 100/10 BASE-TX Fast Ethernet (model 
3c575) in my Laptop (A Dell Inspiron 5000e) The PCMCIA card worked during 
installation but it fails to be detected after reboot. I tried insmodding 
the correct module but the device couldn't be detected.

The problem may be that the network card driver was recently moved to 
another module (I think it was the 3c59x module). I have a friend that has 
the same computer and the same network card and it works fine under his 
own-compiled kernel.
Comment 1 Tim Waugh 2000-12-21 13:21:56 EST
What kernel version is your friend using?

We both have Dell Inspirons.  You could try 2.4.0-test13pre3-ac3: there's a
work-around for some Dell Inspiron 5000e bug I think.

(It didn't work for my system though, so perhaps it's something else.)
Comment 2 Anders Carlsson 2000-12-21 15:13:47 EST
Here's also the output when running cardctl ident

[root@braxen /root]# cardctl ident
Socket 0:
  no product info available
Socket 1:
  product info: "3Com Corporation", "3CCFE575CT", "LAN Cardbus Card", "004"
  manfid: 0x0101, 0x5257
  function: 6 (network)

Comment 3 Glen Foster 2001-01-11 16:15:17 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 4 Michael K. Johnson 2001-01-19 12:59:18 EST
*** Bug 23820 has been marked as a duplicate of this bug. ***
Comment 5 Arjan van de Ven 2001-01-22 14:49:20 EST
What pcmcia-cs package are you using ?
Comment 6 Arjan van de Ven 2001-01-31 06:32:46 EST
Found + fixed the bug. The fix should appear in rawhide soon.
(probably as 0.99.18 or later)
Comment 7 Arjan van de Ven 2001-02-14 05:26:32 EST
This is believed to be fixed in current Rawhide kernels.

If these kernels does not fix the problem for you, please reopen this
bug.


Note You need to log in before you can comment on or make changes to this bug.