Bug 2262554 - Dnf5 select almost 1000 packages when only one would be needed
Summary: Dnf5 select almost 1000 packages when only one would be needed
Keywords:
Status: CLOSED DUPLICATE of bug 2262370
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf5
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-02-03 22:14 UTC by Göran Uddeborg
Modified: 2024-02-05 12:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-05 11:37:13 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Göran Uddeborg 2024-02-03 22:14:22 UTC
Description of problem:
On a system I tried to install f2fs-tools. Dnf5 selected to change around 1000 packages. Downloading the RPM file and testing to install with "rpm --test -i" didn't require anything other package. RPM and DNF5 seems to disagree.

Version-Release number of selected component (if applicable):
dnf5-5.1.11-1.fc39.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. sudo dnf5 install f2fs-tools

Actual results:
Transaction Summary:
 Installing:       35 packages
 Upgrading:       943 packages
 Replacing:       960 packages
 Removing:          2 packages
 Downgrading:       4 packages


Expected results:
Just installing this particular package.

Additional info:
The system where I see this is quite a mix, with packages from many different releases of Fedora and some from other sources. For some reasons I don't want to make a general upgrade. As a system it would certainly not be supported, if there was any support for Fedora systems. But this would not be a reason for dnf5 to get confused, I would have thought.

I need to do other changes to the system, which obviously may modify the "test case". I've made a copy of /usr/lib/sysimage if that could be used for debugging. Is there anything I should do with that to track down the issue? Would you like me to attach any of the files in that copy?

Comment 1 amatej 2024-02-05 11:37:13 UTC
Thank you for the report.

This is almost certainly caused by the `SOLVER_FLAG_FOCUS_BEST` flag we tried to introduce a while back.

However it turned out to be problematic in use cases like your.
You can check out some more details here: https://github.com/rpm-software-management/dnf5/issues/1106


The flag has since been reverted: https://github.com/rpm-software-management/dnf5/pull/1211 and the fix should land in fedora soon.
It should also be available in our nightly copr repo if you want to test it out: https://copr.fedorainfracloud.org/coprs/rpmsoftwaremanagement/dnf-nightly/

*** This bug has been marked as a duplicate of bug 2262370 ***

Comment 2 Göran Uddeborg 2024-02-05 12:31:49 UTC
Yes, it looks very similar indeed, thanks!


Note You need to log in before you can comment on or make changes to this bug.