Bug 226294 - (php) Merge Review: php
Merge Review: php
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Package Reviews List
:
Depends On: 246210
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 15:39 EST by Nobody's working on this, feel free to take it
Modified: 2014-09-23 00:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: ice-3.5.1-9.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-23 00:49:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against php.spec (2.65 KB, patch)
2007-02-19 13:39 EST, Remi Collet
no flags Details | Diff
patch for .spec file to merge with php-extras (3.12 KB, patch)
2007-06-19 13:15 EDT, Dmitry Butskoy
no flags Details | Diff

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:39:56 EST
Fedora Merge Review: php

http://cvs.fedora.redhat.com/viewcvs/devel/php/
Initial Owner: jorton@redhat.com
Comment 1 Christopher Stone 2007-02-05 20:01:03 EST
Requires: httpd-mmn = %(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)

php requires httpd-mmn?  If it does, then this line is totally ineffective.  I
have php installed with no httpd-mmn package.

Perhaps httpd-devel needs to be added to BR or some kind of build prereq.

I was looking at some of the *really* old patches, for example:
php-4.3.2-libtool15.patch

I don't get this patch, esp since you compile using --with-pic.  My ignorance
level is pretty amazingly high when it comes to autoconf stuff, but I'm
wondering if some of the old patches are still required?

I think it makes tons of sense to package php-pear in this package, and send the
old php-pear to /dev/null.  We can then make a php-pear-PEAR package that
basically uses a standard pear class spec file created with fedora-newrpmspec
command.
Comment 2 Joe Orton 2007-02-06 04:47:26 EST
httpd-mmn is a provided by httpd to ensure there is an ABI dependency for
packages containing DSOs for httpd.  httpd-devel is BRed by php.

The -libtool15 patch probably is indeed redundant now.  I'll remove it at the
next rebuild and see if anything breaks.
Comment 3 Christopher Stone 2007-02-08 12:46:59 EST
- rpmlint output:
W: php invalid-license The PHP License v3.01
W: php unversioned-explicit-obsoletes php-dbg
W: php unversioned-explicit-obsoletes php3
W: php unversioned-explicit-obsoletes phpfi
W: php unversioned-explicit-obsoletes stronghold-php
W: php unversioned-explicit-provides php-pcntl
W: php unversioned-explicit-provides php-readline
W: php unversioned-explicit-provides php-bz2
W: php unversioned-explicit-provides php-calendar
W: php unversioned-explicit-provides php-ctype
W: php unversioned-explicit-provides php-curl
W: php unversioned-explicit-provides php-date
W: php unversioned-explicit-provides php-exif
W: php unversioned-explicit-provides php-ftp
W: php unversioned-explicit-provides php-gettext
W: php unversioned-explicit-provides php-gmp
W: php unversioned-explicit-provides php-hash
W: php unversioned-explicit-provides php-iconv
W: php unversioned-explicit-provides php-libxml
W: php unversioned-explicit-provides php-mime_magic
W: php unversioned-explicit-provides php-openssl
W: php unversioned-explicit-provides php-pcre
W: php unversioned-explicit-provides php-posix
W: php unversioned-explicit-provides php-pspell
W: php unversioned-explicit-provides php-reflection
W: php unversioned-explicit-provides php-session
W: php unversioned-explicit-provides php-shmop
W: php unversioned-explicit-provides php-simplexml
W: php unversioned-explicit-provides php-sockets
W: php unversioned-explicit-provides php-spl
W: php unversioned-explicit-provides php-sysvsem
W: php unversioned-explicit-provides php-sysvshm
W: php unversioned-explicit-provides php-sysvmsg
W: php unversioned-explicit-provides php-tokenizer
W: php unversioned-explicit-provides php-wddx
W: php unversioned-explicit-provides php-zlib
W: php unversioned-explicit-provides php-json
W: php unversioned-explicit-provides php-zip
W: php unversioned-explicit-obsoletes php-openssl
W: php unversioned-explicit-obsoletes php-pecl-zip
W: php unversioned-explicit-obsoletes php-json
W: php unversioned-explicit-obsoletes php-pecl-pdo-devel
W: php unversioned-explicit-obsoletes mod_php3-imap
W: php unversioned-explicit-obsoletes stronghold-php-imap
W: php unversioned-explicit-obsoletes mod_php3-ldap
W: php unversioned-explicit-obsoletes stronghold-php-ldap
W: php unversioned-explicit-obsoletes php-pecl-pdo-sqlite
W: php unversioned-explicit-obsoletes php-pecl-pdo
W: php unversioned-explicit-provides php_database
W: php unversioned-explicit-provides php-mysqli
W: php unversioned-explicit-obsoletes mod_php3-mysql
W: php unversioned-explicit-obsoletes stronghold-php-mysql
W: php unversioned-explicit-provides php_database
W: php unversioned-explicit-obsoletes mod_php3-pgsql
W: php unversioned-explicit-obsoletes stronghold-php-pgsql
W: php unversioned-explicit-provides php_database
W: php unversioned-explicit-obsoletes stronghold-php-odbc
W: php unversioned-explicit-obsoletes php-domxml
W: php unversioned-explicit-obsoletes php-dom
W: php unversioned-explicit-provides php-dom
W: php unversioned-explicit-provides php-xsl
W: php unversioned-explicit-provides php-domxml
E: php use-of-RPM_SOURCE_DIR
W: php mixed-use-of-spaces-and-tabs (spaces: line 326, tab: line 344)
W: php invalid-license The PHP License v3.01
E: php obsolete-not-provided php-dbg
E: php obsolete-not-provided php3
E: php obsolete-not-provided phpfi
E: php obsolete-not-provided stronghold-php
W: php no-documentation
E: php non-standard-gid /var/lib/php/session apache
E: php non-standard-dir-perm /var/lib/php/session 0770
W: php-bcmath invalid-license The PHP License v3.01
W: php-bcmath no-documentation
W: php-cli invalid-license The PHP License v3.01
W: php-common invalid-license The PHP License v3.01
E: php-common obsolete-not-provided php-pecl-zip
W: php-dba invalid-license The PHP License v3.01
W: php-dba no-documentation
W: php-debuginfo invalid-license The PHP License v3.01
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/mbstring/libmbfl/filters/mbfilter_iso8859_16.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo_mysql/mysql_driver.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/mbstring/libmbfl/filters/mbfilter_iso8859_16.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo/php_pdo_int.h
W: php-debuginfo spurious-executable-perm /usr/src/debug/php-5.2.0/ext/pdo/pdo.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_exceptions.h
W: php-debuginfo spurious-executable-perm /usr/src/debug/php-5.2.0/ext/spl/php_spl.h
W: php-debuginfo spurious-executable-perm /usr/src/debug/php-5.2.0/ext/pdo/pdo_dbh.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/main/streams/streams.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_functions.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo_mysql/mysql_statement.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo/php_pdo_driver.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/Zend/zend_iterators.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/Zend/zend_iterators.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/main/php_streams.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo_odbc/odbc_driver.c
E: php-debuginfo wrong-script-end-of-line-encoding
/usr/src/debug/php-5.2.0/ext/pdo_odbc/odbc_driver.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo_odbc/php_pdo_odbc_int.h
E: php-debuginfo wrong-script-end-of-line-encoding
/usr/src/debug/php-5.2.0/ext/pdo_odbc/php_pdo_odbc_int.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_array.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_array.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_directory.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_directory.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_exceptions.c
W: php-debuginfo spurious-executable-perm /usr/src/debug/php-5.2.0/ext/spl/php_spl.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_observer.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_observer.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_iterators.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/simplexml/php_simplexml_exports.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_iterators.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_engine.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo_odbc/pdo_odbc.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo_mysql/php_pdo_mysql_int.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo/pdo_stmt.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo_mysql/pdo_mysql.c
W: php-debuginfo spurious-executable-perm /usr/src/debug/php-5.2.0/ext/pdo/php_pdo.h
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/pdo_odbc/odbc_stmt.c
E: php-debuginfo wrong-script-end-of-line-encoding
/usr/src/debug/php-5.2.0/ext/pdo_odbc/odbc_stmt.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/mbstring/oniguruma/regext.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/Zend/zend_interfaces.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/Zend/zend_interfaces.h
W: php-debuginfo spurious-executable-perm /usr/src/debug/php-5.2.0/ext/spl/spl_sxe.c
W: php-debuginfo spurious-executable-perm /usr/src/debug/php-5.2.0/ext/spl/spl_sxe.h
W: php-debuginfo spurious-executable-perm /usr/src/debug/php-5.2.0/ext/pcntl/pcntl.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/mbstring/oniguruma/enc/utf16_be.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/mbstring/oniguruma/enc/utf16_le.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/spl/spl_engine.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/mbstring/oniguruma/enc/utf32_be.c
W: php-debuginfo spurious-executable-perm
/usr/src/debug/php-5.2.0/ext/mbstring/oniguruma/enc/utf32_le.c
W: php-devel invalid-license The PHP License v3.01
E: php-devel obsolete-not-provided php-pecl-pdo-devel
E: php-devel only-non-binary-in-usr-lib
W: php-devel conffile-without-noreplace-flag /etc/rpm/macros.php
W: php-gd invalid-license The PHP License v3.01
W: php-gd no-documentation
W: php-imap invalid-license The PHP License v3.01
E: php-imap obsolete-not-provided mod_php3-imap
E: php-imap obsolete-not-provided stronghold-php-imap
W: php-imap no-documentation
W: php-ldap invalid-license The PHP License v3.01
E: php-ldap obsolete-not-provided mod_php3-ldap
E: php-ldap obsolete-not-provided stronghold-php-ldap
W: php-ldap no-documentation
W: php-mbstring invalid-license The PHP License v3.01
W: php-mbstring no-documentation
W: php-mysql invalid-license The PHP License v3.01
E: php-mysql obsolete-not-provided mod_php3-mysql
E: php-mysql obsolete-not-provided stronghold-php-mysql
W: php-mysql no-documentation
W: php-ncurses invalid-license The PHP License v3.01
W: php-ncurses no-documentation
W: php-odbc invalid-license The PHP License v3.01
E: php-odbc obsolete-not-provided stronghold-php-odbc
W: php-odbc no-documentation
W: php-pdo invalid-license The PHP License v3.01
E: php-pdo obsolete-not-provided php-pecl-pdo-sqlite
E: php-pdo obsolete-not-provided php-pecl-pdo
W: php-pdo no-documentation
W: php-pgsql invalid-license The PHP License v3.01
E: php-pgsql obsolete-not-provided mod_php3-pgsql
E: php-pgsql obsolete-not-provided stronghold-php-pgsql
W: php-pgsql no-documentation
W: php-snmp invalid-license The PHP License v3.01
W: php-snmp no-documentation
W: php-soap invalid-license The PHP License v3.01
W: php-soap no-documentation
W: php-xml invalid-license The PHP License v3.01
W: php-xml no-documentation
W: php-xmlrpc invalid-license The PHP License v3.01
W: php-xmlrpc no-documentation

Oh my, thats a lot! heh.  Any chance we can clean these up?  Looks like most of
these are pretty trivial to fix.
Comment 4 Christopher Stone 2007-02-15 14:27:21 EST
ping?
Comment 5 Remi Collet 2007-02-17 02:14:22 EST
Extras provide a php-extras .src.rpm (dmitry@butskoy.name, adding it to Cc)
which rebuild php only to provide php-mhash ans php-mcrypt.

I think this extensions should be enable in main php package

%package      mhash
Summary:      A module for PHP applications that use Mhash.
Group:                Development/Languages
BuildRequires:        mhash-devel
Requires:     php-common = %{version}-%{release}

%description mhash
The php-mhash package is a dynamic shared object (DSO) for the Apache
Web server that adds Mhash support to PHP.

%package      mcrypt
Summary:      A module for PHP applications that use Mcrypt.
Group:                Development/Languages
BuildRequires:        libmcrypt-devel
Requires:     php-common = %{version}-%{release}

%description mcrypt
The php-mcrypt package is a dynamic shared object (DSO) for the Apache
Web server that adds Mcrypt support to PHP.

And use --with-mhash=shared --with-mcrypt=shared


Comment 6 Remi Collet 2007-02-17 08:23:23 EST
i saw php-5.2.1 in rawhide... cool.

Patch 9 is not applied ;)

php 5.2.1 now shipped with memory_limit set to 128 Mb ? what about fedora RPM ?


Does php-snmp must requires "net-snmp" as it already requires libnetsnmp.so.10 ?

Regards
Comment 7 Robert Scheck 2007-02-17 08:56:00 EST
Ehm, PHP 5.2.1 for Fedora ships "memory_limit = 32M", not more and not less.
Comment 8 Dmitry Butskoy 2007-02-19 08:00:42 EST
for comment #8 :
> which rebuild php only to provide php-mhash ans php-mcrypt.

Not only, also php-dbase and php-tidy.

I.e., add all 4 ones, and I will drop an extra hackish package at all :)
Comment 9 Remi Collet 2007-02-19 13:39:05 EST
Created attachment 148354 [details]
Patch against php.spec

Tanks dmitry, i forget this 2.

Here is a patch against php.spec to provide this 4 extensions.

Regards
Comment 10 Joe Orton 2007-02-19 13:51:21 EST
I haven't had time to go through the rpmlint list exhaustively, it looks 99%
useless.  Can someone sort out the wheat from the chaff?

- invalid-license and no-docs warnings are obviously bogus
- the php-$MODULE provides are deliberately not versioned, and versioning these
would be tricky because many of the modules have versions independently in PEAR;
that's not going to get fixed in a hurry.
- the Obsoletes for the old-style mod_php3 et al could probably be dropped,
adding Provides for them is not particularly useful at this point
- the debuginfo perms mismatches should be fixed in find-debuginfo.sh not in
every spec file, filed bug 228987 for that
Comment 11 Joe Orton 2007-02-19 14:06:59 EST
Enabling mhash, mcrypt and tidy is something that can only happen *after* the
merge not before.

Enabling dbase should be subject of a normal RFE bug, it's nothing to do with
the package review per se.
Comment 12 Joe Orton 2007-02-19 14:10:28 EST
The explicit "Requires: net-snmp" is desired, yes, per bug 174800.

(s/PEAR/PECL/ in my comment above)
Comment 13 Christopher Stone 2007-02-22 14:45:38 EST
(In reply to comment #10)
> I haven't had time to go through the rpmlint list exhaustively, it looks 99%
> useless.  Can someone sort out the wheat from the chaff?

That's not going to be me.  I'm doing this on a volunteer basis, and quite
frankly  it is not worth my time to deal with this.   Therefore I'm removing
myself from this review.
Comment 14 Christopher Stone 2007-02-22 15:03:26 EST
Reassigning to jorton@redhat.com, I think this is how it was originally set.
Comment 15 Dmitry Butskoy 2007-06-15 09:57:35 EDT
For comment #11 :

> Enabling mhash, mcrypt and tidy is something that can only happen *after* the
merge not before.

The merge is done.

Since "freetds" is in Fedora, mssql can be enabled now, i.e.:
dbase, mhash, mcrypt, mssql, tidy

I feel that users want to have php-mssql immediately now. I already add it for
FC6 (in my php-extras package), but what is the best way for F7 and further?
Either I rebuild php-extras in F7 with mssql support, or maybe wait a little and
merge all 5 subpackages with the main php ?

Any thoughts?
Comment 16 Dmitry Butskoy 2007-06-15 10:01:35 EDT
Comment on attachment 148354 [details]
Patch against php.spec

brroken patch, due to "/opt/interbase" ?...
And not all 5 sub-packages present.
Comment 17 Dmitry Butskoy 2007-06-18 12:41:15 EDT
I can provide a patch, if such a "merging" update is possible in the nearest
future...



Comment 18 Joe Orton 2007-06-18 14:31:46 EDT
Dmitry: yes please!
Comment 19 Dmitry Butskoy 2007-06-19 13:15:08 EDT
Created attachment 157395 [details]
patch for .spec file to merge with php-extras

Get it now! :)

It successfully compiled, checked and creates all of 5 additional php
subpackages.

Note, that current php version (5.2.2 in F7 and 5.2.3 in devel) is newer than
in php-extras (5.2.1), hence no problem with update path.
Comment 20 Joe Orton 2007-06-19 13:23:26 EDT
Dmitry: excellent, nice patch! Thanks a lot.

I don't think dbase needs to be in a separate subpackage since it doesn't bring
any extra library dependencies, so I changed that to simply package the DSO in
-common.  Should we obsolete php-extra (somehow?) at some point?
Comment 21 Dmitry Butskoy 2007-06-20 08:19:38 EDT
> Should we obsolete php-extras

No. "php-extras" is a name of a source rpm package only.
All the binary sub-packages it previously produced have the same names now.
Since the version of these new sub-packages is 5.2.2-x, which is newer than old
5.1.6-x, all updates should be fine without any obsoletes or extras epoching.

Just the tags "F7" and "devel" should be removed from CVS for php-extras, and
php-extras srpm should be removed from the rawhide repository.

"dbase goes to -common" -- OK!
Comment 22 Dmitry Butskoy 2007-06-26 12:44:53 EDT
Well, see new sub-packages in devel.

But what about the current F7 release?
Depending of your plans, I should either still update my php-extras, or wait
(how long?) for an upcoming update of the main php package...
Comment 23 Dmitry Butskoy 2007-06-29 05:20:22 EDT
It seems we forget to add "Obsoletes: php-dbase" to php-common package...
Comment 24 Fedora Update System 2014-09-08 13:54:27 EDT
ice-3.5.1-9.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/ice-3.5.1-9.fc21
Comment 25 Fedora Update System 2014-09-09 22:13:31 EDT
Package ice-3.5.1-9.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ice-3.5.1-9.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10506/ice-3.5.1-9.fc21
then log in and leave karma (feedback).
Comment 26 Fedora Update System 2014-09-23 00:49:52 EDT
ice-3.5.1-9.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.