Bug 226420 - Merge Review: slang
Merge Review: slang
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 15:59 EST by Nobody's working on this, feel free to take it
Modified: 2008-12-12 09:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 09:33:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
limburgher: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 15:59:30 EST
Fedora Merge Review: slang

http://cvs.fedora.redhat.com/viewcvs/devel/slang/
Initial Owner: mlichvar@redhat.com
Comment 1 Michael Schwendt 2007-12-22 11:50:59 EST
$ cd slang/devel
$ cvs remove -f slang-2.1.2-makefile.patch
$ cvs commit -m ''

The file is unused and has been superseded.


$ rpmlint /home/qa/tmp/rpm/RPMS/slang-2.1.3-1.fc8.i386.rpm 
slang.i386: W: file-not-utf8 /usr/share/doc/slang-2.1.3/changes.txt

 => minor -- a few contributor's fornames use various encodings


> warning: call to '__warn_memset_zero_len' declared with
> attribute warning: memset used with constant zero length
> parameter; this could be due to transposed parameters

This is a false positive.


> checking for the onig library and header files oniguruma.h... no

oniguruma-devel is in Fedora, so add --without-onig  for
reproducible builds if it should not be built with. Else add
it as BuildRequires.


Else I don't see any packaging problems.
Comment 2 Miroslav Lichvar 2008-01-24 10:28:19 EST
slang-2.1.3-2.fc9 buildrequires oniguruma-devel and the old makefile patch has
been removed.
Comment 3 Jon Ciesla 2008-12-11 12:02:26 EST
On current version:
rpmlint on SRPM is clean.

rpmlint on RPMS:

slang.i386: W: file-not-utf8 /usr/share/doc/slang-2.1.4/changes.txt
The character encoding of this file is not UTF-8.  Consider converting it in
the specfile's %prep section for example using iconv(1).

Easily fixable.

slang-static.i386: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

Fix if static-only docs exist.

Source tag should be Source0.

Comment in spec on patch upstream status.

Otherwise, looks good on full review, no other blockers.

Also noticed that this review had been flagged + but never assigned or closed.
Comment 4 Miroslav Lichvar 2008-12-12 06:43:37 EST
The changelog is a mix of UTF8 and ISO-8859-1.

Source seems to be a valid rpm tag, or is there a guideline requiring use of Source0?

The patches were not send to upstream, they just fix some file permissions, rpath and disable using a private glibc symbol to follow our guidelines.
Comment 5 Jon Ciesla 2008-12-12 08:31:09 EST
(In reply to comment #4)
> The changelog is a mix of UTF8 and ISO-8859-1.

Right.  Should be UTF-8.

> Source seems to be a valid rpm tag, or is there a guideline requiring use of
> Source0?

I got confused, I was thinking pf Patch vs. Patch0.  Still a good practice, but not a blocker.

> The patches were not send to upstream, they just fix some file permissions,
> rpath and disable using a private glibc symbol to follow our guidelines.

https://fedoraproject.org/wiki/Packaging/Guidelines#All_patches_should_have_an_upstream_bug_link_or_comment
So fix the changelog ang comment on the patches in the spec and we're good.
Comment 6 Miroslav Lichvar 2008-12-12 09:26:36 EST
Should be fixed in slang-2.1.4-2.fc11.
Comment 7 Jon Ciesla 2008-12-12 09:33:33 EST
Excellent, thank you!

APPROVED.

Note You need to log in before you can comment on or make changes to this bug.