This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 226487 - Merge Review: texi2html
Merge Review: texi2html
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:10 EST by Nobody's working on this, feel free to take it
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 04:17:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
pertusus: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:10:01 EST
Fedora Merge Review: texi2html

http://cvs.fedora.redhat.com/viewcvs/devel/texi2html/
Initial Owner: jnovy@redhat.com
Comment 1 Patrice Dumas 2007-02-05 11:09:20 EST
I have integrated the patches and the ja translation upstream.
Some strings have changed in cvs, and the ja file should be 
updated accordingly from the cvs file.

Link to the file in cvs:
http://cvs.savannah.nongnu.org/viewcvs/texi2html/i18n/ja?rev=1.1&root=texi2html&view=auto
Comment 2 Jindrich Novy 2007-02-06 04:34:19 EST
Do you plan to release a new texi2html upstream release anytime soon? The
preferred way is to update to an official upstream release instead of
backporting changes to a 1.5 year old texi2html ;-)
Comment 3 Patrice Dumas 2007-02-06 05:05:17 EST
I am not the upstream maintainer, I am the main contributor.
I already asked twice for a release... 

Do you want to update the ja translations before the release?
Comment 4 Jindrich Novy 2007-02-06 05:12:06 EST
Definitely. Maybe it would be good to update to a current CVS snapshot to
include your and other fixes to F7 texi2html if there's no will from the
upstream maintainer to come out with the new upstream release.

Is the current CVS texi2html in a good shape or do you know about any
breakages/regressions introduced since texi2html-1.76?
Comment 5 Patrice Dumas 2007-02-06 05:53:00 EST
There are no known regressions. Some bugfixes, some new features, 
some documented incompatibilities. It should be perfectly right
to use the CVS snapshot.

In theory I could do a release, but I prefer if Derek takes care 
of that. The only remaining issue is a license issue, the documentation
license is unclear. The original documentation author allowed us to use
whatever license we want, but once again I'd like that Derek chose.
Comment 6 Patrice Dumas 2007-02-06 05:55:48 EST
(In reply to comment #4)
> Definitely. 

I don't really get it. Do you prefer a release before you update
the ja translation to match the changes in strings in cvs, do
you want to fix them later, or are you indifferent?
Comment 7 Jindrich Novy 2007-02-06 06:11:58 EST
I could update the ja translation only as we have translation included
separately in the RH CVS, but as I understand it now, I need to update to the
texi2html cvs snapshot in the same time so that the strings match the newer
version of texi2html? Or are the new translations compatible with the old
texi2html-1.76?
Comment 8 Patrice Dumas 2007-02-06 06:29:15 EST
(In reply to comment #7)
> I could update the ja translation only as we have translation included
> separately in the RH CVS,

I was thinking that you would have wanted to update them in the texi2html 
CVS... such that they are updated for the next upstream release.

> but as I understand it now, I need to update to the
> texi2html cvs snapshot in the same time so that the strings match the newer
> version of texi2html? 

The ja translation is now in texi2html CVS, so if you update to the cvs
snapshot the ja translation will be in the snapshot, and not (only) in 
RH CVS anymore -- except if you want to patch it in RH CVS.

> Or are the new translations compatible with the old
> texi2html-1.76?

No, they aren't, in the sense that translations that were in texi2html-1.76
and are not in texi2html-1.77/1.78 are in the OBSOLETE_STRINGS hash.
Comment 9 Jindrich Novy 2007-02-06 06:40:39 EST
Ok, thanks for the clarification.

Could you please ask Derek if he could do a new texi2html release once again
maybe even with a link to this bug? If you agree, I'll wait for a week or so and
if no new release is out I'm going to package a texi2html cvs snapshot which
contains the newer ja translations.
Comment 10 Jindrich Novy 2007-02-14 06:40:46 EST
I just updated texi2html to the latest CVS snapshot as of today.
Comment 11 Patrice Dumas 2007-02-14 11:15:55 EST
Could you please add a comment explaining how you generated the
cvs snapshot such that sources may be checked.

Also I think that it would be better to remove the .gz in 
install-info scriptlets.

Also I suggest adding a Requires for latex2html, and maybe for
tetex-tex4ht (after the merge).
Comment 12 Patrice Dumas 2007-02-14 11:30:28 EST
I don't know if the dependency on perl(Text::Unidecode) is 
detected automatically. If not, it should be added after
the merge.

texi2html could own  $sysconfdir/texinfo/ and $datadir/texinfo/
together with texinfo, since users may want to put an htmlxref.cnf
in those directories, which could be used by texi2html, and
makeinfo (once it is implemented in makeinfo).
Comment 13 Jindrich Novy 2007-02-14 11:32:23 EST
(In reply to comment #11)
> Could you please add a comment explaining how you generated the
> cvs snapshot such that sources may be checked.

After checking it out from cvs I did:
autoreconf
./configure
make dist

what generated the source tarball for me. I renamed it to reflect that it's not
an official release, but a prerelease made from a CVS snapshot.

> Also I think that it would be better to remove the .gz in 
> install-info scriptlets.

No problem to remove it.

> Also I suggest adding a Requires for latex2html, and maybe for
> tetex-tex4ht (after the merge).

I'm going to add the latex2html Requires. I'm not quite sure we want to add
tex4ht dependency as it's not in Core and used only in examples?
Comment 14 Jindrich Novy 2007-02-14 11:43:47 EST
(In reply to comment #12)
> I don't know if the dependency on perl(Text::Unidecode) is 
> detected automatically. If not, it should be added after
> the merge.

Nope, only these perl requires are autodetected:
perl(Cwd)
perl(Exporter)
perl(File::Spec)
perl(Getopt::Long)
perl(POSIX)
perl(strict)
perl(vars)


> texi2html could own  $sysconfdir/texinfo/ and $datadir/texinfo/
> together with texinfo, since users may want to put an htmlxref.cnf
> in those directories, which could be used by texi2html, and
> makeinfo (once it is implemented in makeinfo).

Hmmm, won't this clash with texinfo? %{_datadir}/texinfo is owned by texinfo
itself already.
Comment 15 Patrice Dumas 2007-02-14 15:48:25 EST
(In reply to comment #13)
> (In reply to comment #11)
> > Could you please add a comment explaining how you generated the
> > cvs snapshot such that sources may be checked.
> 
> After checking it out from cvs I did:
> autoreconf
> ./configure
> make dist
> 
> what generated the source tarball for me.

I tried but it didn't worked. There were permissions issues for the
just updated files. Since the autotools generated files are already 
there, why not repackage the fresh cvs checkout? It is easier
to verify the sources then. 
Here is something that could work and be reproducible:

cvs -z3 -d:pserver:anonymous@cvs.savannah.nongnu.org:/sources/texi2html co -D
20070214 -d texi2html-1.77-20070214cvs texi2html
cd texi2html-1.77-20070214cvs
chmod a+x autogen.sh config.guess config.sub configure install-sh mdate-sh
missing mkinstalldirs buildt2h.sh doc/mdate-sh
cd ..
tar cjvf texi2html-1.77-20070214cvs.tar.bz2 texi2html-1.77-20070214cvs

> I'm going to add the latex2html Requires. I'm not quite sure we want to add
> tex4ht dependency as it's not in Core and used only in examples?

It is not really an example, it is an init file. With
  texi2html --init-file tex4ht.init
httex is used to render @tex and @math similarly than -l2h uses 
latex2html. Of course the dependency could only be added after the merge.
It adds functionality, however, it also brings in the whole TeX
stuff, so adding it as a Requires or not is not obvious.
Comment 16 Patrice Dumas 2007-02-14 15:56:57 EST
(In reply to comment #14)

> Nope, only these perl requires are autodetected:
> perl(Cwd)
> perl(Exporter)
> perl(File::Spec)
> perl(Getopt::Long)
> perl(POSIX)
> perl(strict)
> perl(vars)

Ok, so Text::Unidecode should be added, but after the merge, 
since it is in extras. It is not surprising that it isn't
detected, since weird things are done to ensure that it
is detected at runtime.

> > texi2html could own  $sysconfdir/texinfo/ and $datadir/texinfo/
> > together with texinfo, since users may want to put an htmlxref.cnf
> > in those directories, which could be used by texi2html, and
> > makeinfo (once it is implemented in makeinfo).
> 
> Hmmm, won't this clash with texinfo? %{_datadir}/texinfo is owned by texinfo
> itself already.

Both texi2html and makeinfo are able to take advantage of what is
in %{_datadir}/texinfo and %_sysconfdir/texinfo/ (more precisely of 
an htmlxref.cnf file) since we agreed on the location and format 
of htmlxref.cnf. Similarly both should put the html manuals in
%{_datadir}/texinfo/html. Otherwise said %{_datadir}/texinfo/ is not 
specific of an implementation of a texinfo to html converter, but
of the texinfo language.
Comment 17 Patrice Dumas 2007-02-18 08:11:44 EST
The release is on its way, so there shouldn't be a need for 
a cvs snapshot.
Comment 18 Patrice Dumas 2007-06-05 16:38:42 EDT
It took much longuer, Derek had too much work. That allowed 
to fix more bugs, though. 1.78 to be downloaded at:

http://download.savannah.nongnu.org/releases/texi2html/

As a side note, I'd appreciate being in initialCC or 
co-maintainer.
Comment 19 Jindrich Novy 2007-06-06 00:40:37 EDT
Ok, texi2html is now updated to 1.78. You are also co-maintainer now.
Comment 20 Patrice Dumas 2007-06-06 14:29:13 EDT
By being in pkg.acl, will I get the bug reports and the cvs
changes? Personally, when I add a co-maintainer I use

http://fedoraproject.org/wiki/PackageMaintainers/CVSAdminProcedure
Comment 21 Patrice Dumas 2007-06-06 14:32:17 EDT
What about my other comments?
Comment 22 Patrice Dumas 2007-07-31 11:57:33 EDT
Do you agree with my proposals, such that I can provide you 
with a patch or are you disagreeing?
Comment 23 Patrice Dumas 2007-08-28 08:14:20 EDT
I committed the changes I was advocating. You can build if you like them,
I can revert the changes you dislike if you want to.

I also clarified the licenses. There is currently no tag for the
texi2html documentation license, I asked spot to add it to the wiki,
in the mean time I used MIT-like.
Comment 24 Jindrich Novy 2007-08-28 08:25:36 EDT
Thanks, it's building now. btw. texlive 0.11 will be out in a few minutes.
Comment 25 Patrice Dumas 2007-08-28 09:01:09 EDT
APPROVED. 

I'll take care of the documentation license tag.
Comment 26 Patrice Dumas 2007-09-11 05:17:58 EDT
I add this here since it was discussed above.

I just commited changes in texi2html cvs (no need to backport,
will be in the next release), to fix handling of @math, 
and it happens that with latex2html, the result cannot be
correct, since mixing of @-commands and tex commands is
allowed in @math, so something like
@math{@var{\phi}} is right, but badly interpreted by latex2html,
while with tex4ht the result is now right (since it now uses 
httexi for @math and httex for @tex). In my opinion this is 
a good reason to have a tex4ht dependency. What is your advice?
Comment 27 Jindrich Novy 2007-09-11 05:34:36 EDT
Hi Patrice, feel free to add the tex4ht dependency when the result with tex4ht
is right.
Comment 28 Patrice Dumas 2007-09-11 05:43:36 EDT
Ok, I'll do it for the texi2html release. I prefer
doing it later with post-texlive tex4ht in order to
have the right name.

Note You need to log in before you can comment on or make changes to this bug.