Bug 226509 - Merge Review: tzdata
Merge Review: tzdata
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Package Reviews List
:
Depends On:
Blocks: F9MergeReviewTarget
  Show dependency treegraph
 
Reported: 2007-01-31 16:12 EST by Nobody's working on this, feel free to take it
Modified: 2009-09-21 16:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 10:41:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
tibbs: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:12:50 EST
Fedora Merge Review: tzdata

http://cvs.fedora.redhat.com/viewcvs/devel/tzdata/
Initial Owner: pmachata@redhat.com
Comment 1 Petr Machata 2007-02-07 14:47:42 EST
Tidied up version commited, not built.
rpmlint is silent, for both source and binary rpm.
Comment 2 Bernard Johnson 2007-03-06 23:58:59 EST
Is there no URL for the Source0: tzdata-base-0.tar.bz2?  What is upstream?
Comment 3 Petr Machata 2007-03-07 03:57:12 EST
No, there is none.  I don't think it's upstream package, it's a simple building
infrastructure.
Comment 4 Jason Tibbitts 2007-12-21 23:58:01 EST
OK, let's have a look.

The tzdata-base-0.tar.bz2 file is indeed a bit weird.  I understand what it's
used for, and if I'm correct, the maintainer of this packages just repacks it
and uploads to the buildsys when a file needs to be changed.  That's OK; it just
needs to be commented in the spec so that everyone will know where it comes
from:  http://fedoraproject.org/wiki/Packaging/SourceURL

Normally I would suggest that you drop the Conflicts: tag and the versioned
BuildRequires: for glibc-common, but given what this packages is used for I
suspect that leaving them in might save some user of a never-updated RH9 system
who might want to install this on their system.  Or maybe we don't care about
that, but I'll leave it to the maintainer to make that decision.

It's not clear to me just which parts of the resulting package are under the
LGPL and which are public domain, and the specfile needs to make this clear. 
See the "Multiple License Scenario" section of
http://fedoraproject.org/wiki/Packaging/LicensingGuidelines for more information.

It's a bit confusing to have the BuildRequires: and Source: tags in two places,
since they're not specific to the subpackages.  There's also no need to specify
BuildArch: twice.

rpmlint says:

  tzdata.noarch: W: invalid-license Public Domain, LGPLv2+
  tzdata-java.noarch: W: invalid-license Public Domain, LGPLv2+
The license tag should be "Public Domain and LGPLv2+"

  tzdata-java.noarch: W: no-documentation
Not a problem.

Really, all that's needed is some comments and a couple of minor tweaks.  If you
like, I can attach a patch or just commit fixes to CVS, but I'm afraid I'll need
help supplying the licensing breakdown.


Checklist:
* source files match upstream:
   696b5fd267c991bb814a69b0bfff8ca4edf484f5859c955ec15a134a1d7045c9
    tzcode2007j.tar.gz
   0319a3dc08f05a92b5c409cc7278a45fa6194bcdfdd27918554bd3d8d6d33c6d
    tzdata2007j.tar.gz
* package meets naming and versioning guidelines.
* specfile is properly named, is cleanly written and uses macros consistently.
* summary is OK.
* description is OK.
* dist tag is present.
* build root is OK.
* license field matches the actual license (but it does have a syntax issue; see 
   above)
* license is open source-compatible.
* license text not included upstream.
* latest version is being packaged.
* BuildRequires are proper.
* %clean is present.
* package builds in mock (rawhide, x86_64).
* package installs properly
X rpmlint has a valid complaint.
* final provides and requires are sane:
  tzdata-2007j-1.fc9.noarch.rpm
   tzdata = 2007j-1.fc9
  =
   (nothing)

  tzdata-java-2007j-1.fc9.noarch.rpm
   tzdata-java = 2007j-1.fc9
  =
   (nothing)

* %check is present and all tests pass.
* owns the directories it creates.
* doesn't own any directories it shouldn't.
* no duplicates in %files.
* file permissions are appropriate.
* no scriptlets present.
* acceptable content.
* documentation is small, so no -docs subpackage is necessary.
* %docs are not necessary for the proper functioning of the package.
Comment 5 Petr Machata 2008-01-04 09:26:31 EST
Thanks for review.  I committed a cleaned up version, and commented on a meaning
and source of mysterious tzdata-base-0.tar.bz2 file.
Comment 6 Jason Tibbitts 2008-01-04 12:41:19 EST
Thanks for the update.

One thing that I note from reading the nice comments you've added from the spec:

Keep in mind that the License: tag applies only to the final binary package, so
if none of the LGPLv2+ stuff makes it into the built package then there's no
need to have LGPLv2+ in the License: tag.

Otherwise I think this package is fine now.
Comment 7 Petr Machata 2008-01-07 10:37:33 EST
Great, in that case I'm dropping the LGPL part of the License.  All the files
(both the java part and the zoneinfo part) are built from the same set of public
domain sources.
Comment 8 Jason Tibbitts 2008-01-07 10:41:26 EST
Let's call this done, then.

Thanks!

APPROVED

Note You need to log in before you can comment on or make changes to this bug.