Bug 226535 - Merge Review: w3m
Merge Review: w3m
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:16 EST by Nobody's working on this, feel free to take it
Modified: 2014-09-02 08:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-30 12:41:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mtasaka: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)
w3m.spec with some fixes (0.5.1-18) (15.83 KB, text/plain)
2007-03-24 15:01 EDT, Mamoru TASAKA
no flags Details
A patch to simply remove -O compilation flags (522 bytes, patch)
2007-03-26 14:04 EDT, Mamoru TASAKA
no flags Details | Diff
New spec file with a bit more fix (15.96 KB, text/plain)
2007-03-26 14:10 EDT, Mamoru TASAKA
no flags Details
0.5.1-19 spec file (16.21 KB, text/plain)
2007-03-27 10:26 EDT, Mamoru TASAKA
no flags Details

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:16:12 EST
Fedora Merge Review: w3m

http://cvs.fedora.redhat.com/viewcvs/devel/w3m/
Initial Owner: dsantani@redhat.com
Comment 1 Robert Scheck 2007-02-20 16:04:54 EST
Bug #222914 must be fixed before the merge, as the bug report is related to 
packaging. Note, this comment is no formal review - it's just a notice for the 
review.
Comment 2 Parag Nemade 2007-02-21 04:59:34 EST
Bug #222914 is now Fixed in w3m-0.5.1-16.fc7. Thanks for your feedback.
Comment 3 Mamoru TASAKA 2007-03-24 15:01:13 EDT
Created attachment 150834 [details]
w3m.spec with some fixes (0.5.1-18)

Well, for 0.5.1-17.fc7:

* Source0
  - Please check:
    http://fedoraproject.org/wiki/Packaging/SourceURL
(A) It seems that newest gc is 6.8.

* CFlags
    (Please see the attached mock build log)
  - Fedora specific compilation flags are not passed
    (for gc.a).
    For gc.a, it seems okay when ABI_FLAG is set as
    RPM_OPT_FLAGS
    And.. actually this changes debuginfo contents.
(B) NOTE:
    Usually gc should be seperated from this package (w3m)
    and other packages for gc should be created.
    In this case, gc package should provide shared library
    (not static archive). 
    However is this too late for F7?

* Version provides
------------------------------------------------
Provides:  webclient = 0.5.1
------------------------------------------------
  - Any reason to provide version-dependent virtual dependency?
    I don't see the reason, and other package which provide
    "webclient" virtual dependency does not specify version.

* Requires
  - For main package:
------------------------------------------------
    Requires:  perl, openssl
------------------------------------------------
    These should be removed. rpmbuild automatically
    finds these dependencies.

* spec file description
------------------------------------------------
[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
------------------------------------------------
  - The part [ ...... ] is redundant and should be removed.
    RPM_BUILD_ROOT _MUST_ not be empty or / .

* Timestamps
------------------------------------------------
install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/w3m/config
------------------------------------------------
  - Please keep timestamp. i.e. use "install -p".

* Misc
  * w3m.lang usage
------------------------------------------------
find $RPM_BUILD_ROOT%{_libexecdir} -type f -print | grep -v w3mimgdisplay | sed
-e "s,$RPM_BUILD_ROOT,," >> w3m.lang
........
%files
........
%exclude %{_libexecdir}/w3m/w3mimgdisplay
------------------------------------------------
    - At the first description, w3mimgdisplay are already excluded.
      Anyway, these can be unified. Simply,
------------------------------------------------
%files
.......
%{_mandir}/man1/w3mman.1*
%{_libexecdir}/%{name}/
%exclude %{_libexecdir}/w3m/w3mimgdisplay
------------------------------------------------
      should be okay.

* Conditional dependency
  - Well, I found that when I rebuild w3m locally, inline image handler
    is enabled for x11 and fb,
    while for mockbuild only x11 image handler is enabled

    This is because configure reads:
------------------------------------------------
  5785	    enable_image=x11
  5786	    case "`uname -s`" in
  5787	    Linux|linux|LINUX)
  5788		if test -c /dev/fb0; then
  5789		  enable_image=x11,fb
  5790		fi;;
  5791	    esac
  5792	  fi
  5793	  save_ifs="$IFS"; IFS=",";
  5794	  for img in $enable_image; do
------------------------------------------------
    However, on mockbuild /dev/fb0 is not created, so fb image handler
    will not be enabled.
    To fix this, configure option must handle this explicitly.

* lang
  - for Japanese documents, these should be treated as %lang(ja).

* Documentation
(C) doc*/w3m.1 seems unneeded, as they are already included as
    man files. However, I leave this as how you judge.

(D) Question:
    - Should all the documents in doc-jp/ files should be
      converted from EUC-JP to UTF-8?
      I think so, however, if you want to do so, please keep
      timestamps on these files even after encodings are converted,
      as these documents are 3-6 years old.

-------------------------------------------------
My attached spec file should fix all the issues above
expect (A)-(D).
Please check my spec file and comment on (A)-(D)

* NOTE
  I have not checked yet
  * what documentation should be added to this rpm
  * whether license is correct and has no problem
  * some other issues may exist
Comment 4 Mamoru TASAKA 2007-03-24 15:07:22 EDT
Erm..

--------------------------------------------------------------
 (if [ "x$i" = "x$i.gz" ]; then zcat $i; else cat $i; fi )
--------------------------------------------------------------
(E) This if judgment is always false, even if man file is
    gzipped.
    "x$i" is always different from "x$i.gz".
Comment 5 Mamoru TASAKA 2007-03-24 15:46:22 EDT
One more issue found
----------------------------------------------------
+ make gc.a 'ABI_FLAG=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables'
cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -O -I./include -DATOMIC_UNCOLLECTABLE -DNO_SIGNALS
-DNO_EXECUTE_PERMISSION -DSILENT -DALL_INTERIOR_POINTERS   -c -o alloc.o alloc.c
-----------------------------------------------------
(F) optimization level "-O2" is overwritten by the latter "-O",
    which breaks fedora specific compilation flags.
Comment 6 Parag Nemade 2007-03-26 04:53:21 EDT
Updated package SPEC with your SPEC version in w3m-0.5.1-18. Thanks for your
feedback.
But Now I got error while building SRPM for ia64

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.5797
+ umask 022
+ cd /builddir/build/BUILD
+ cd w3m-0.5.1
+ LANG=C
+ export LANG
+ unset DISPLAY
+ pushd gc
~/build/BUILD/w3m-0.5.1/gc ~/build/BUILD/w3m-0.5.1
+ make gc.a 'ABI_FLAG=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4'
cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -O -I./include -DATOMIC_UNCOLLECTABLE -DNO_SIGNALS
-DNO_EXECUTE_PERMISSION -DSILENT -DALL_INTERIOR_POINTERS   -c -o alloc.o alloc.c
alloc.c: In function 'GC_stopped_mark':
alloc.c:482: warning: implicit declaration of function
'GC_cond_register_dynamic_libraries'
alloc.c: In function 'GC_expand_hp_inner':
alloc.c:934: warning: suggest parentheses around && within ||
alloc.c: In function 'GC_collect_or_expand':
alloc.c:997: warning: suggest parentheses around && within ||
alloc.c: In function 'GC_clear_fl_marks':
alloc.c:603: warning: 'hhdr' may be used uninitialized in this function
alloc.c: In function 'GC_set_fl_marks':
alloc.c:578: warning: 'hhdr' may be used uninitialized in this function
alloc.c: In function 'GC_stopped_mark':
alloc.c:472: warning: 'start_time' may be used uninitialized in this function
alloc.c: In function 'GC_try_to_collect_inner':
alloc.c:321: warning: 'start_time' may be used uninitialized in this function
cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -O -I./include -DATOMIC_UNCOLLECTABLE -DNO_SIGNALS
-DNO_EXECUTE_PERMISSION -DSILENT -DALL_INTERIOR_POINTERS   -c -o reclaim.o reclaim.c
cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -O -I./include -DATOMIC_UNCOLLECTABLE -DNO_SIGNALS
-DNO_EXECUTE_PERMISSION -DSILENT -DALL_INTERIOR_POINTERS   -c -o allchblk.o
allchblk.c
cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -O -I./include -DATOMIC_UNCOLLECTABLE -DNO_SIGNALS
-DNO_EXECUTE_PERMISSION -DSILENT -DALL_INTERIOR_POINTERS   -c -o misc.o misc.c
misc.c: In function 'GC_init_inner':
misc.c:692: warning: statement with no effect
misc.c:693: warning: statement with no effect
misc.c:694: warning: statement with no effect
cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -O -I./include -DATOMIC_UNCOLLECTABLE -DNO_SIGNALS
-DNO_EXECUTE_PERMISSION -DSILENT -DALL_INTERIOR_POINTERS -o if_mach ./if_mach.c
cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -O -I./include -DATOMIC_UNCOLLECTABLE -DNO_SIGNALS
-DNO_EXECUTE_PERMISSION -DSILENT -DALL_INTERIOR_POINTERS -o if_not_there
./if_not_there.c
cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -O -I./include -DATOMIC_UNCOLLECTABLE -DNO_SIGNALS
-DNO_EXECUTE_PERMISSION -DSILENT -DALL_INTERIOR_POINTERS -o threadlibs
./threadlibs.c
rm -f mach_dep.o
./if_mach MIPS IRIX5 cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -c -o mach_dep.o ./mips_sgi_mach_dep.s
./if_mach MIPS RISCOS as -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -o mach_dep.o ./mips_ultrix_mach_dep.s
./if_mach MIPS ULTRIX as -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -o mach_dep.o ./mips_ultrix_mach_dep.s
./if_mach POWERPC DARWIN as -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -o mach_dep.o
./powerpc_darwin_mach_dep.s
./if_mach ALPHA LINUX cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -c -o mach_dep.o ./alpha_mach_dep.S
./if_mach SPARC SUNOS5 cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -c -o mach_dep.o
./sparc_mach_dep.S
./if_mach SPARC SUNOS4 as -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -o mach_dep.o
./sparc_sunos4_mach_dep.s
./if_mach SPARC OPENBSD as -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -o mach_dep.o
./sparc_sunos4_mach_dep.s
./if_mach SPARC NETBSD as -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -o mach_dep.o
./sparc_netbsd_mach_dep.s
./if_mach IA64 "" as -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -o ia64_save_regs_in_stack.o
./ia64_save_regs_in_stack.s
^^^^Starting command^^^^
as: unrecognized option `-O2'
make: *** [mach_dep.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.5797 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.5797 (%build)

Comment 7 Mamoru TASAKA 2007-03-26 14:04:29 EDT
Created attachment 150923 [details]
A patch to simply remove -O compilation flags

A patch to simply remove -O compilation flags
in Makefile in gc
Comment 8 Mamoru TASAKA 2007-03-26 14:10:07 EDT
Created attachment 150924 [details]
New spec file with a bit more fix

* I don't have any machines other than x86 computer,
  however I think the patch and the new spec attached
  will fix the issues (E) (F) and ia64 compilation
  problem
  (Well, if build still fails on ia64 or some other
   archtecture, would you fix it?)
* Please comment on (A)-(D).
* I have not checked
  - if some license issue exists
  - what documents should be included
  - etc...
Comment 9 Parag Nemade 2007-03-27 00:33:44 EDT
(In reply to comment #3)
> Created an attachment (id=150834) [edit]
> w3m.spec with some fixes (0.5.1-18)
> 
> Well, for 0.5.1-17.fc7:
> 
> * Source0
>   - Please check:
>     http://fedoraproject.org/wiki/Packaging/SourceURL
> (A) It seems that newest gc is 6.8.
> 
> * CFlags
>     (Please see the attached mock build log)
>   - Fedora specific compilation flags are not passed
>     (for gc.a).
>     For gc.a, it seems okay when ABI_FLAG is set as
>     RPM_OPT_FLAGS
>     And.. actually this changes debuginfo contents.
     Agree.

> (B) NOTE:
>     Usually gc should be seperated from this package (w3m)
>     and other packages for gc should be created.
>     In this case, gc package should provide shared library
>     (not static archive). 
>     However is this too late for F7?
      Don't think so. Yes static library should be removed.
> 
> * Version provides
> ------------------------------------------------
> Provides:  webclient = 0.5.1
> ------------------------------------------------
>   - Any reason to provide version-dependent virtual dependency?
>     I don't see the reason, and other package which provide
>     "webclient" virtual dependency does not specify version.
  
      Ok.
> 
> * Requires
>   - For main package:
> ------------------------------------------------
>     Requires:  perl, openssl
> ------------------------------------------------
>     These should be removed. rpmbuild automatically
>     finds these dependencies.
   yes this should be removed.

> 
> * spec file description
> ------------------------------------------------
> [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
> ------------------------------------------------
>   - The part [ ...... ] is redundant and should be removed.
>     RPM_BUILD_ROOT _MUST_ not be empty or / .

 Ok.

> 
> * Timestamps
> ------------------------------------------------
> install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/w3m/config
> ------------------------------------------------
>   - Please keep timestamp. i.e. use "install -p".
   Yes.

> 
> * Misc
>   * w3m.lang usage
> ------------------------------------------------
> find $RPM_BUILD_ROOT%{_libexecdir} -type f -print | grep -v w3mimgdisplay | sed
> -e "s,$RPM_BUILD_ROOT,," >> w3m.lang
> ........
> %files
> ........
> %exclude %{_libexecdir}/w3m/w3mimgdisplay
> ------------------------------------------------
>     - At the first description, w3mimgdisplay are already excluded.
>       Anyway, these can be unified. Simply,
> ------------------------------------------------
> %files
> .......
> %{_mandir}/man1/w3mman.1*
> %{_libexecdir}/%{name}/
> %exclude %{_libexecdir}/w3m/w3mimgdisplay
> ------------------------------------------------
>       should be okay.

     Agree.
> 
> * Conditional dependency
>   - Well, I found that when I rebuild w3m locally, inline image handler
>     is enabled for x11 and fb,
>     while for mockbuild only x11 image handler is enabled
> 
>     This is because configure reads:
> ------------------------------------------------
>   5785	    enable_image=x11
>   5786	    case "`uname -s`" in
>   5787	    Linux|linux|LINUX)
>   5788		if test -c /dev/fb0; then
>   5789		  enable_image=x11,fb
>   5790		fi;;
>   5791	    esac
>   5792	  fi
>   5793	  save_ifs="$IFS"; IFS=",";
>   5794	  for img in $enable_image; do
> ------------------------------------------------
>     However, on mockbuild /dev/fb0 is not created, so fb image handler
>     will not be enabled.
>     To fix this, configure option must handle this explicitly.
> 
> * lang
>   - for Japanese documents, these should be treated as %lang(ja).

         yes.
> 
> * Documentation
> (C) doc*/w3m.1 seems unneeded, as they are already included as
>     man files. However, I leave this as how you judge.
> 
     Ok. will remove from doc.

> (D) Question:
>     - Should all the documents in doc-jp/ files should be
>       converted from EUC-JP to UTF-8?
>       I think so, however, if you want to do so, please keep
>       timestamps on these files even after encodings are converted,
>       as these documents are 3-6 years old.

        Agree.

> 
> -------------------------------------------------
> My attached spec file should fix all the issues above
> expect (A)-(D).
> Please check my spec file and comment on (A)-(D)
> 
> * NOTE
>   I have not checked yet
>   * what documentation should be added to this rpm
>   * whether license is correct and has no problem
>   * some other issues may exist

Comment 10 Mamoru TASAKA 2007-03-27 00:46:44 EDT
(In reply to comment #9)
> (In reply to comment #3)
> > Created an attachment (id=150834) [edit] [edit]
> > w3m.spec with some fixes (0.5.1-18)
> > 
> > Well, for 0.5.1-17.fc7:
> > 
> > * Source0
> >   - Please check:
> >     http://fedoraproject.org/wiki/Packaging/SourceURL
> > (A) It seems that newest gc is 6.8.
> > 
> > * CFlags
> >     (Please see the attached mock build log)
> >   - Fedora specific compilation flags are not passed
> >     (for gc.a).
> >     For gc.a, it seems okay when ABI_FLAG is set as
> >     RPM_OPT_FLAGS
> >     And.. actually this changes debuginfo contents.
>      Agree.
> 
> > (B) NOTE:
> >     Usually gc should be seperated from this package (w3m)
> >     and other packages for gc should be created.
> >     In this case, gc package should provide shared library
> >     (not static archive). 
> >     However is this too late for F7?
>       Don't think so. Yes static library should be removed.

What I meant here is
* can you split gc tarball from w3m srpm, create gc package
  (with providing gc shared library)
  from gc tarball and have w3m use gc package before F7?
* would you upgrade gc to the newest version?


> > (D) Question:
> >     - Should all the documents in doc-jp/ files should be
> >       converted from EUC-JP to UTF-8?
> >       I think so, however, if you want to do so, please keep
> >       timestamps on these files even after encodings are converted,
> >       as these documents are 3-6 years old.
> 
>         Agree.

"Agree" means that you will change Japanese documents to
UTF-8 with timestamps kept as original?

Comment 11 Robert Scheck 2007-03-27 01:00:47 EDT
In fact there *IS* a separate gc package already in Fedora Extras, but IIRC 
Fedora Core packages currently aren't allowed to depend on Extras packages. Or 
isn't http://redhat.download.fedoraproject.org/pub/fedora/linux/extras/
development/SRPMS/gc-6.8-3.fc7.src.rpm the same type of gc like in w3m? I would 
leave this point open until the merge of Core and Extras happend.
Comment 12 Parag Nemade 2007-03-27 01:17:36 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > (In reply to comment #3)
> > > Created an attachment (id=150834) [edit] [edit] [edit]
> > > w3m.spec with some fixes (0.5.1-18)
> > > 
> > > Well, for 0.5.1-17.fc7:
> > > 
> > > * Source0
> > >   - Please check:
> > >     http://fedoraproject.org/wiki/Packaging/SourceURL
> > > (A) It seems that newest gc is 6.8.
> > > 
> > > * CFlags
> > >     (Please see the attached mock build log)
> > >   - Fedora specific compilation flags are not passed
> > >     (for gc.a).
> > >     For gc.a, it seems okay when ABI_FLAG is set as
> > >     RPM_OPT_FLAGS
> > >     And.. actually this changes debuginfo contents.
> >      Agree.
> > 
> > > (B) NOTE:
> > >     Usually gc should be seperated from this package (w3m)
> > >     and other packages for gc should be created.
> > >     In this case, gc package should provide shared library
> > >     (not static archive). 
> > >     However is this too late for F7?
> >       Don't think so. Yes static library should be removed.
> 
> What I meant here is
> * can you split gc tarball from w3m srpm, create gc package
>   (with providing gc shared library)
>   from gc tarball and have w3m use gc package before F7?
> * would you upgrade gc to the newest version?
> 
> 
> > > (D) Question:
> > >     - Should all the documents in doc-jp/ files should be
> > >       converted from EUC-JP to UTF-8?
> > >       I think so, however, if you want to do so, please keep
> > >       timestamps on these files even after encodings are converted,
> > >       as these documents are 3-6 years old.
> > 
> >         Agree.
> 
> "Agree" means that you will change Japanese documents to
> UTF-8 with timestamps kept as original?
> 
> Will do that.
 
recently I got to maintain this package and have no idea at all about its
packaging. So will take some time with this review to understand its packaging.

Thanks for your comments.


Comment 13 Parag Nemade 2007-03-27 01:24:06 EDT
(In reply to comment #11)
> In fact there *IS* a separate gc package already in Fedora Extras, but IIRC 
> Fedora Core packages currently aren't allowed to depend on Extras packages. Or 
> isn't http://redhat.download.fedoraproject.org/pub/fedora/linux/extras/
> development/SRPMS/gc-6.8-3.fc7.src.rpm the same type of gc like in w3m? I would 
> leave this point open until the merge of Core and Extras happend.

Ohh now I got confused whether I should update new gc or not? I think as Merge
still requires time, I should update gc.
Comment 14 Robert Scheck 2007-03-27 01:27:49 EDT
Updating gc is okay to me, but don't split out another gc package as suggested 
before. When the Core and Extras merge happend, the w3m internal gc should be 
dropped and replaced by a build requirement to the already existing gc package.
Comment 15 Mamoru TASAKA 2007-03-27 01:32:07 EDT
(In reply to comment #13)
> (In reply to comment #11)
> > In fact there *IS* a separate gc package already in Fedora Extras, but IIRC 
> > Fedora Core packages currently aren't allowed to depend on Extras packages. Or 
> > isn't http://redhat.download.fedoraproject.org/pub/fedora/linux/extras/
> > development/SRPMS/gc-6.8-3.fc7.src.rpm the same type of gc like in w3m?

Exactly the same

> I would 
> > leave this point open until the merge of Core and Extras happend.
> 
> Ohh now I got confused whether I should update new gc or not? I think as Merge
> still requires time, I should update gc.

For now, simply upgrading gc to 6.8 (and not spliting gc tarball
until Core/Extras merge is actually happened) is the best IMO


Comment 16 Parag Nemade 2007-03-27 02:44:57 EDT
Mtasaka,
    Can you help me in converting all the documents in doc-jp/ files from EUC-JP
to UTF-8?
     E.g. I tried following command to convert README to UTF-8
 iconv -f ISO_8859-1 -t UTF-8 /usr/share/doc/w3m-0.5.1/doc-jp/README

Is that right?
Comment 17 Mamoru TASAKA 2007-03-27 05:12:16 EDT
(In reply to comment #16)
> Mtasaka,
>     Can you help me in converting all the documents in doc-jp/ files from EUC-JP
> to UTF-8?
>      E.g. I tried following command to convert README to UTF-8
>  iconv -f ISO_8859-1 -t UTF-8 /usr/share/doc/w3m-0.5.1/doc-jp/README
> 
> Is that right?

Well, actually it is not ISO-8859-1, although "file" command
shows this (well, for Japanese documents, "file" command is
not useful...)

The following works for me.
-------------------------------------------------------
# Change encodings
pushd doc-jp
for f in * ; do
   case $f in
      README.pre_form | README.tab )
         CHARSET=ISO-2022-JP ;
         ;;
      keymap.* )
         CHARSET=UTF-8
         ;;
      * )
         CHARSET=EUC-JP
         ;;
    esac
    iconv -f $CHARSET -t UTF-8 $f > $f.tmp && \
      ( touch -r $f $f.tmp ; mv $f.tmp $f ) || rm -f $f.tmp
done
popd
------------------------------------------------------
Comment 18 Mamoru TASAKA 2007-03-27 05:14:10 EDT
A unneeded semicolon is inserted...
Again:
--------------------------------------------
pushd doc-jp
for f in * ; do
   case $f in
      README.pre_form | README.tab )
         CHARSET=ISO-2022-JP
         ;;
      keymap.* )
         CHARSET=UTF-8
         ;;
      * )
         CHARSET=EUC-JP
         ;;
    esac
    iconv -f $CHARSET -t UTF-8 $f > $f.tmp && \
      ( touch -r $f $f.tmp ; mv $f.tmp $f ) || rm -f $f.tmp
done
popd
-----------------------------------------------------
Comment 19 Parag Nemade 2007-03-27 05:55:27 EDT
Thanks for help.
Updated SPEC and built new package w3m-0.5.1-18.2.fc7
Can you please check this package again for any missing things?
Comment 20 Mamoru TASAKA 2007-03-27 06:02:53 EDT
Okay, I will recheck it after I go back from
taking dinner.
Comment 21 Parag Nemade 2007-03-27 06:24:02 EDT
(In reply to comment #20)
> Okay, I will recheck it after I go back from
> taking dinner.

Thanks
Comment 22 Mamoru TASAKA 2007-03-27 10:26:31 EDT
Created attachment 151033 [details]
0.5.1-19 spec file

If you would agree with this spec file attached,
I can approve this package.

Changes:
* IMO "NEWS" file should be added to documents
* License is changed from BSD to MIT.
  Upstream http://sourceforge.net/projects/w3m/
  declares this is MIT.
* Now all files under doc-jp are converted to UTF-8
  at %prep stage, the line
--------------------------------------------
{!?_without_utf8:for i in $RPM_BUILD_ROOT%{_mandir}/ja/man*/*;
--------------------------------------------
  is no longer needed, and leaving this line
  destroys ja man file.
* The line
---------------------------------------------
rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/w3m.1
----------------------------------------------
   does nothing. w3m.1 is under $RPM_BUILD_DIR/w3m-0.5.1/doc* .
Comment 23 Parag Nemade 2007-03-28 00:41:52 EDT
(In reply to comment #22)
> Created an attachment (id=151033) [edit]
> 0.5.1-19 spec file
> 
> If you would agree with this spec file attached,
> I can approve this package.
> 
> Changes:
> * IMO "NEWS" file should be added to documents
> * License is changed from BSD to MIT.
>   Upstream http://sourceforge.net/projects/w3m/
>   declares this is MIT.
> * Now all files under doc-jp are converted to UTF-8
>   at %prep stage, the line
> --------------------------------------------
> {!?_without_utf8:for i in $RPM_BUILD_ROOT%{_mandir}/ja/man*/*;
> --------------------------------------------
>   is no longer needed, and leaving this line
>   destroys ja man file.
> * The line
> ---------------------------------------------
> rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/w3m.1
> ----------------------------------------------
>    does nothing. w3m.1 is under $RPM_BUILD_DIR/w3m-0.5.1/doc* .

Thanks Very Much for this Log review.
Updated Package with your SPEC in CVS.
Comment 24 Mamoru TASAKA 2007-03-28 02:26:54 EDT
Okay.

------------------------------------------
This merge review (w3m) is APPROVED by me.
------------------------------------------
Comment 25 Parag Nemade 2007-03-28 02:30:19 EDT
Thanks for your help and Review. :)
Comment 26 Mamoru TASAKA 2007-03-30 12:41:18 EDT
-19 is now in public and I close this bug.
Comment 27 Parag Nemade 2014-08-30 00:00:30 EDT
Package Change Request
======================
Package Name: w3m
New Branches: epel7
Owners: pnemade
InitialCC: i18n-team
Comment 28 Jon Ciesla 2014-09-02 08:20:09 EDT
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.