Bug 226561 - Merge Review: xjavadoc
Merge Review: xjavadoc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:19 EST by Nobody's working on this, feel free to take it
Modified: 2012-06-15 12:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-29 08:58:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:19:51 EST
Fedora Merge Review: xjavadoc

http://cvs.fedora.redhat.com/viewcvs/devel/xjavadoc/
Initial Owner: dbhole@redhat.com
Comment 1 Stanislav Ochotnicky 2010-09-24 07:49:17 EDT
I'll look into this
Comment 2 Stanislav Ochotnicky 2010-09-24 09:38:53 EDT
Package Review
==============

Key:
- = N/A
x = Check
! = Problem
? = Not evaluated

=== REQUIRED ITEMS ===
[!]  Rpmlint output:
xjavadoc.src: W: name-repeated-in-summary C XJavaDoc
Improve the summary

xjavadoc.src: W: non-standard-group Development/Testing
Development/Libraries or Tools?

xjavadoc.src:183: W: libdir-macro-in-noarch-package (main package) %attr(-,root,root) %{_libdir}/gcj/%{name}
this would be fixed by removing gcj support alltogether.
I'll leave this up to you, but it would be nice

xjavadoc.src:92: W: mixed-use-of-spaces-and-tabs (spaces: line 92,tab:line 35)
obvious fix...

xjavadoc.src: W: invalid-url Source0: xjavadoc-src-1.1-RHCLEAN.tar.bz2
This needs at least an explanation in the spec file

xjavadoc.x86_64: W: name-repeated-in-summary C XJavaDoc
xjavadoc.x86_64: W: non-standard-group Development/Testing
xjavadoc-javadoc.x86_64: W: non-standard-group Development/Documentation
Group: Documentation

xjavadoc-javadoc.x86_64: W: dangerous-command-in-%post rm
xjavadoc-javadoc.x86_64: W: dangerous-command-in-%postun rm
...you know what to do here.

4 packages and 0 specfiles checked; 0 errors, 10 warnings.
[x]  Package is named according to the Package Naming Guidelines.
[x]  Spec file name must match the base package name, in the format %{name}.spec.
[x]  Package meets the Packaging Guidelines.
[x]  Package successfully compiles and builds into binary rpms.
[!]  Buildroot is correct (%{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n))
[x]  Package is licensed with an open-source compatible license and meets other legal requirements as defined in the legal section of Packaging Guidelines.
[x]  License field in the package spec file matches the actual license.
License type: BSD
[x]  If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package is included in %doc.
[!]  All independent sub-packages have License of their own
javadoc subpackage should include license or depend on main package
[x]  Spec file is legible and written in American English.
[!]  Sources used to build the package matches the upstream source, as provided in the spec URL.
Unable to checkout sources using provided comments
[x]  All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section of Packaging Guidelines.
[x]  Package must own all directories that it creates.
[x]  Package requires other packages for directories it uses.
[x]  Package does not contain duplicates in %files.
[!]  Permissions on files are set properly.
Fix defattrs for files to -,root,root,-
[x]  Package has a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT).
but I don't see point in checking if build root equals '/' (nice failsafe, but shouldn't be needed)
[x]  Package consistently uses macros.
[x]  Package contains code, or permissable content.
[-]  Fully versioned dependency in subpackages, if present.
[-]  Package contains a properly installed %{name}.desktop file if it is a GUI application.
[x]  Package does not own files or directories owned by other packages.
[x]  Javadoc documentation files are generated and included in -javadoc subpackage
[!]  Javadoc subpackages have Require: jpackage-utils
They have requires on coreutils (unneeded)
[!]  Package uses %global not %define
[!]  If package uses tarball from VCS include comment how to re-create that tarball (svn export URL, git clone URL, ...)
As mentioned before, that comment needs expanding/fixing
[x]  If source tarball includes bundled jar/class files these need to be removed prior to building
[x]  All filenames in rpm packages must be valid UTF-8.

=== SUGGESTED ITEMS ===
[x]  If possible use upstream build method (maven/ant/javac)
[!]  Javadocs are placed in %{_javadocdir}/%{name} with %{_javadocdir}/%{name}-%{version} symlink
that unsafe command in post/postun issue from rpmlint
[?]  If package contains pom.xml files install it even when building with ant
there seems to be project.xml but that seems like old version..might be worth looking into if you have some time
[x]  Avoid having BuildRequires on exact NVR unless necessary
[!]  Package has BuildArch: noarch (if possible)
Is it not possible to have
[?]  Latest version is packaged.t
[x]  Reviewer should test that the package builds in mock.
Tested on: fedora-rawhide-x86_64


=== Issues ===
1. several rpmlint issues
2. license in javadoc subpackage
3. buildroot
4. way to get source tarball is not exact
5. gcj support/noarch and quite a few things related to this
6. define->global
7. requires in jpackage-utils in javadoc subpackage
8. permissions on files
9. ugly post/postun for javadoc subpackage
Comment 3 Alexander Kurtakov 2010-09-24 15:14:43 EDT
=== Issues ===
1. several rpmlint issues
Fixed.
2. license in javadoc subpackage
Fixed.
3. buildroot
Removed.
4. way to get source tarball is not exact
Shell script added.
5. gcj support/noarch and quite a few things related to this
Removed.
6. define->global
Fixed. No more defines/globals
7. requires in jpackage-utils in javadoc subpackage
Fixed.
8. permissions on files
Fixed.
9. ugly post/postun for javadoc subpackage
Removed.

Koji build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=196748
Comment 4 Stanislav Ochotnicky 2010-09-29 08:58:07 EDT
Nice, I consider this package clean and review finished. Closing
Comment 5 Parag AN(पराग) 2012-06-15 12:46:30 EDT
This bug just popped out when I searched for packages under review but this looks completed without setting fedora-review+

Setting the flag therefore.

Note You need to log in before you can comment on or make changes to this bug.