Bug 226599 - Merge Review: xorg-x11-drv-i810
Merge Review: xorg-x11-drv-i810
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Package Reviews List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 16:26 EST by Nobody's working on this, feel free to take it
Modified: 2009-01-13 18:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 18:18:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tibbs: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 16:26:23 EST
Fedora Merge Review: xorg-x11-drv-i810

http://cvs.fedora.redhat.com/viewcvs/devel/xorg-x11-drv-i810/
Initial Owner: ajackson@redhat.com
Comment 1 Jason Tibbitts 2007-06-20 23:32:03 EDT
Abbreviated mass review of xorg-x11-drv-* packages.

30d0cd555d8b8b5bb53d93eaae1ad2aecb5c94a760e2346d60b6e194c254e40f 
xf86-video-i810-1.6.5.tar.bz2
d563e47e908710b0c4c5122237b05a977b16d5c7a57e69c880a885014102e695 
xf86-video-intel-2.0.0.tar.bz2

Is there an upstream source for the xf86-video-intel-2.0.0.tar.bz2 file?  Yes,
it seems to be the same as the legacy driver;  I suggest changing Source1: to
ftp://ftp.x.org/pub/individual/driver/xf86-video-intel-%{version}.tar.bz2

rpmlint has a few things to complain about:
W: xorg-x11-drv-i810-devel no-documentation
W: xorg-x11-drv-i810-devel no-documentation
W: xorg-x11-drv-i810 mixed-use-of-spaces-and-tabs (spaces: line 7, tab: line 3)
The usual.

E: xorg-x11-drv-i810 configure-without-libdir-spec
This is bogus because --libdir is passed in ${OPTS}.  However, these are regular
autoconf-generated scripts.  Can they not be called as usual with %configure? 
Not doing so misses out on those fancy Fedora CFLAGS and such, although -g is
there on the gcc command lines so the debuginfo package comes out OK.

E: xorg-x11-drv-i810 library-without-ldconfig-postin /usr/lib64/libI810XvMC.so.1.0.0
E: xorg-x11-drv-i810 library-without-ldconfig-postun /usr/lib64/libI810XvMC.so.1.0.0
I think you do want to call ldconfig here.

W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0 XFree
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmAvailable
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
XvMCQueryExtension
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmGetMagic
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmOpen
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmMap
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmCommandNone
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmUnlock
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
XGetGeometry
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
_xvmc_destroy_subpicture
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmCommandWriteRead
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmClose
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
_xvmc_destroy_surface
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
_xvmc_create_surface
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
XInternAtom
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
_xvmc_create_subpicture
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
_xvmc_create_context
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
_xvmc_destroy_context
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
XvMCQueryVersion
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmUnmap
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
XQueryTree
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmGetLock
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmUnmapBufs
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
drmCommandWrite
W: xorg-x11-drv-i810 undefined-non-weak-symbol /usr/lib64/libI810XvMC.so.1.0.0
XvGetPortAttribute
I'm not sure what's up with these.  This would generally seem to break linking,
but I know that X modules in general and the XvMC libraries in particular are
rather strange.  I'm sure you know what's up here; can you give me a hint?
Comment 2 Adam Jackson 2008-12-05 15:03:48 EST
The XvMC libraries are just weird like that.  It's a dlopen-only lib, and it's loaded from libXvMC which provides all those undefined syms.  They're like DRI drivers.

Also, therefore, it's okay to not do ldconfig.

And it uses %configure now.  Has for some time, in fact.
Comment 3 Jason Tibbitts 2008-12-05 16:44:02 EST
Agreed.

And I hadn't noticed the change to configure; it has been a while since my original comments.

Summarizing other stuff we chatted about on IRC:

The autotools calls before %configure aren't currently necessary and cause build problems on rawhide, but then again they don't cause problems for the release branches.

Even without the autotools calls, things fail to build in rawhide, but that is due to new kernel stuff.

At this point I don't see any packaging-related that would hold up this ticket.  It is probably a good idea to comment out the autotools calls if they aren't necessary, but I don't see this as a blocker.

APPROVED

You might as well go ahead and do a regular CVS request to get the new package name imported.
Comment 4 Jason Tibbitts 2009-01-13 18:18:25 EST
I guess I can close this; if you do want the name changed, you can make a CVS request at any time.

Note You need to log in before you can comment on or make changes to this bug.