Bug 226730 - [ko_KR] page number displayed garbled characters
[ko_KR] page number displayed garbled characters
Status: CLOSED DUPLICATE of bug 250212
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gedit (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
: i18n, Reopened, Translation
Depends On:
  Show dependency treegraph
Reported: 2007-02-01 04:25 EST by Nicole Dai
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-06 22:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot for gedit (121.28 KB, image/png)
2007-02-01 04:25 EST, Nicole Dai
no flags Details
screenshot for gedit in gu_IN (30.97 KB, image/png)
2007-02-12 03:30 EST, Nicole Dai
no flags Details
Problem was solved. (45.04 KB, image/png)
2007-02-13 02:07 EST, Mayank Jain
no flags Details

  None (edit)
Description Nicole Dai 2007-02-01 04:25:01 EST
Description of problem:
In ko_KR env, the page number was displayed garbled characters when print
document. Pls refer to the attached screenshot for details.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Log in ko_KR system.
2.Launch gedit.
3.Copy and paste some text to gedit and print it.
4.Check the page number.
5.Print the same doc in LANG=en_US.UTF-8 gedit.
6.Check the page number.
Actual results:
page number displayed garbled characters in ko_KR env but ok in en_US env.

Expected results:

Additional info:
Comment 1 Nicole Dai 2007-02-01 04:25:01 EST
Created attachment 147080 [details]
screenshot for gedit
Comment 2 Mayank Jain 2007-02-12 02:52:27 EST
Hi Nicole,

Both Gedit & Evolution use libgnomeprintui for the printing. Hence, I think this
is a libgnomeprintui bug rather than gedit.

Further, this seems to be a duplicate of Bug 222974.

Closing as DUP. Please feel free to reopen it if you think otherwise.

*** This bug has been marked as a duplicate of 222974 ***
Comment 3 Nicole Dai 2007-02-12 03:30:21 EST
Created attachment 147877 [details]
screenshot for gedit in gu_IN

Hi Mayank,
I found this bug only in ko_KR locale. Other locales I tested before have no
problem and I also found it works well in gu_IN (as I noticed Bug 222974 was
reported for gu_IN). Could you please double-check it? Thanks.
Comment 4 Mayank Jain 2007-02-13 02:05:52 EST
Hmm, okay, everything apart, I just checked & found that this was no more a
problem in gedit.

Check the screenshot in next comment.
Comment 5 Mayank Jain 2007-02-13 02:07:14 EST
Created attachment 147965 [details]
Problem was solved.
Comment 6 Mayank Jain 2007-02-13 02:21:15 EST
Nicole, is this looking correct now?
Comment 7 Hu Zheng 2007-02-13 02:24:43 EST
I dig it and fint it is gedit ko translation's bug.
See gedit/po/ko.po, line 1834
#: ../gedit/gedit-print.c:194
msgid "Page %N of %Q"
msgstr "%2%Q 중 %1$N쪽"

Fix the translation will be OK. This need to be done by a people who understand
Korean :)
This bug exist in FC6 and RHEL5, and we may need to report this to upstream too.
Comment 8 Hu Zheng 2007-02-13 03:15:50 EST
The upstream version have already fixed this.

#: ../gedit/gedit-print.c:194
msgid "Page %N of %Q"
msgstr "전체 %Q쪽 중 %N쪽"

gtksourceprintjob only use %N and %Q as mark, so to revert their order, we
needn't write %1$Q %2$N, just %Q %N is OK.
Comment 9 Mayank Jain 2007-02-13 04:42:07 EST
Ah... very true.
This is fixed in upstream, thats why my gedit-2.17.4-1.fc7 had it fixed.

Thanks Hu Zheng :)
Comment 10 Akira TAGOH 2007-09-06 22:52:08 EDT

*** This bug has been marked as a duplicate of 250212 ***

Note You need to log in before you can comment on or make changes to this bug.