Bug 22689 - Upgrade fails for mysql-3.23.29-1.i386.rpm
Summary: Upgrade fails for mysql-3.23.29-1.i386.rpm
Status: CLOSED DUPLICATE of bug 22783
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mysql   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-21 20:03 UTC by rwmcgwier
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-22 04:02:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rwmcgwier 2000-12-21 20:03:38 UTC
[root@pc7 i386]# rpm -q gcc
gcc-2.96-69
[root@pc7 i386]# rpm -q gcc-c++
gcc-c++-2.96-69
[root@pc7 i386]# rpm -Uvh mysql-3.23.29-1.i386.rpm
error: failed dependencies:
	libstdc++ >= 2.96-69 is needed by mysql-3.23.29-1
	mysql = 3.23.24 is needed by mysql-devel-3.23.24-1
	mysql = 3.23.24 is needed by mysql-server-3.23.24-1
	libmysqlclient.so.9 is needed by mysql-server-3.23.24-1
[root@pc7 i386]# rpm -q mysql
mysql-3.23.24-1

Comment 1 Lee Howard 2000-12-22 04:02:05 UTC
Here's what I get on a fully-installed and fully updated 7.0 system:

[root@providence mysqlupdate]# dir
mysql-3.23.29-1.i386.rpm        mysql-server-3.23.29-1.i386.rpm
mysql-devel-3.23.29-1.i386.rpm
[root@providence mysqlupdate]# rpm -Fvh *rpm
error: failed dependencies:
        libmysqlclient.so.9 is needed by php-mysql-4.0.3pl1-1
[root@providence mysqlupdate]# ls -l /usr/lib/mysql/libmysqlclient.so.9
lrwxrwxrwx    1 root     root           23 Nov 10 18:52 /usr/lib/mysql/libmysqlc
lient.so.9 -> libmysqlclient.so.9.0.0
[root@providence mysqlupdate]# rpm -qf /usr/lib/mysql/libmysqlclient.so.9
mysql-3.23.24-1
[root@providence mysqlupdate]#

Looks like the mysql package needs a symlink to be included in it somewhere.

Comment 2 Trond Eivind Glomsrxd 2000-12-26 23:02:03 UTC

*** This bug has been marked as a duplicate of 22783 ***


Note You need to log in before you can comment on or make changes to this bug.