Bug 226987 - New mhash probably broken under ppc arch
New mhash probably broken under ppc arch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mhash (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 226762
  Show dependency treegraph
 
Reported: 2007-02-02 08:56 EST by Dmitry Butskoy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 10:37:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Butskoy 2007-02-02 08:56:43 EST
I maintain "php-extras" package, which includes "php-mhash" subpackage.
The "php-extras" shares the same source as the main php package in Core (i.e.,
its idea is to compile some of modules not compiled for Core by default).

There are a couple of tests in the php tarball, such tests are used by both
Core's "php" and "php-extras" to check the compiled modules (in the "%check"
.spec section).

When I tried recently to re-build my "php-extras" for "devel" target, the test
for "mhash" php module was failed under "ppc" arch.

The i386 and x86_64 arches are OK for the same "mhash" test.
Another modules' tests was succeed under PPC, except "mhash" test.
It seems to me that it is not PHP issue, it looks like some mhash library issue.
Since the devel/fc7 target has mhash undated to 0.9.7.1 (from 0.9.2 in the
previous Fedora releases) it seems that the PPC issue just was introduced by
this update.

I've found some mhash's own testing stuff (in "src/" subdir of the tarball).

Could you add some "%check" section to mhash's .spec file to make sure the
package is built properly for PPC arch? (Such check will be executed for all 3
arches in the buildsystem, including i386, ppc and x86_64).
Or maybe you have access to some PPC machine to test that manually?
Comment 1 Michael Schwendt 2007-02-02 09:20:03 EST
I'm going to add %check shortly and submit a test-build. I don't have
a ppc machine, and upstream has not responded to all bug reports either.
E.g. there have been rumours about breakage on some big-endian hw, and
ppc is big-endian, too.

Unfortunately, my mail to maintainers-list, from Nov last year, about
this upgrade has not seen any reply. I've tried to stay at the known
good 0.9.2 for a very long time, skipped many versions, such as 0.9.3
and 0.9.4.

Note You need to log in before you can comment on or make changes to this bug.