This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 227192 - F7t1 Abiword crashes, even after update on 2/2/07
F7t1 Abiword crashes, even after update on 2/2/07
Status: CLOSED DUPLICATE of bug 234765
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
: 231001 233774 (view as bug list)
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2007-02-03 00:00 EST by Gerry Tool
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-06 11:06:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback from abiword crash on startup (3.92 KB, text/plain)
2007-02-03 00:00 EST, Gerry Tool
no flags Details
backtraces with full debug goodness (8.33 KB, text/plain)
2007-02-09 08:16 EST, David Nielsen
no flags Details
Bug Report (8.42 KB, text/plain)
2007-02-25 14:19 EST, Kyle Schmidt
no flags Details

  None (edit)
Description Gerry Tool 2007-02-03 00:00:24 EST
Description of problem: Abiword crashes on start


Version-Release number of selected component (if applicable):2.4.6-2.fc7


How reproducible:Always


Steps to Reproduce:
1.Select abiword from Applications > Office menu
2.
3.
  
Actual results:Abiword crashes with traceback


Expected results:Word Processor should open.


Additional info: Traceback file attached.
Comment 1 Gerry Tool 2007-02-03 00:00:24 EST
Created attachment 147270 [details]
Traceback from abiword crash on startup
Comment 2 Marc Maurer 2007-02-04 19:04:39 EST
Weird... it looks like no single usable font can be found. Does anyone know if
anything in FC7 regarding locating fonts changed? Trace with debugging info:

DEBUG: searchFont [Sans]

**** (1) Assert ****
**** (1) font at gr_UnixGraphics.cpp:1198 ****
**** (1) Continue ? (y/n) [y] : 

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208903984 (LWP 26097)]
0x082c0f9e in XAP_UnixFont::getName (this=0x0) at xap_UnixFont.cpp:408
408             return m_name;
(gdb) bt
#0  0x082c0f9e in XAP_UnixFont::getName (this=0x0) at xap_UnixFont.cpp:408
#1  0x082c2d44 in XAP_UnixFontHandle (this=0x9da3220, font=0x0, size=12)
    at xap_UnixFont.cpp:93
#2  0x082ffc7e in GR_UnixGraphics::getGUIFont (this=0x9d9b1e0)
    at gr_UnixGraphics.cpp:1202
#3  0x08300c8c in GR_UnixGraphics::setZoomPercentage (this=0x9d9b1e0, 
    iZoom=100) at gr_UnixGraphics.cpp:754
Comment 3 David Nielsen 2007-02-09 08:16:20 EST
Created attachment 147762 [details]
backtraces with full debug goodness

I'm seeing this as well, attached a backtrace with debug symbol
Comment 4 Kyle Schmidt 2007-02-25 14:19:27 EST
Created attachment 148761 [details]
Bug Report
Comment 5 Marc Maurer 2007-03-06 05:50:21 EST
*** Bug 231001 has been marked as a duplicate of this bug. ***
Comment 6 David Nielsen 2007-03-29 11:54:35 EDT
We are now at test3, is there any information you need to get this fixed so we
can ensure a working Abiword for F7?
Comment 7 Marc Maurer 2007-03-30 07:31:17 EDT
I plan on upgrading to the unstable AbiWord 2.5 (which does work) really soon
now if no-one can come up with a patch.
Comment 8 Marc Maurer 2007-03-30 07:32:08 EDT
*** Bug 233774 has been marked as a duplicate of this bug. ***
Comment 9 Marc Maurer 2007-04-06 11:06:15 EDT
Marking as dupe of 234765, as that has a patch attached

*** This bug has been marked as a duplicate of 234765 ***

Note You need to log in before you can comment on or make changes to this bug.