Bug 234765 - Abiword fails on the Live CD
Abiword fails on the Live CD
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
:
: 227192 235322 (view as bug list)
Depends On:
Blocks: FC7Blocker Fedora7LiveCD
  Show dependency treegraph
 
Reported: 2007-04-01 13:49 EDT by William Lovaton
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-06 12:14:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Report of the crash generated by bug-buddy (7.45 KB, text/plain)
2007-04-01 13:55 EDT, William Lovaton
no flags Details
handle one font having multiple families (4.20 KB, patch)
2007-04-05 16:01 EDT, Ray Strode [halfline]
no flags Details | Diff

  None (edit)
Description William Lovaton 2007-04-01 13:49:08 EDT
Description of problem:
Abiword fails to start on the Live CD, it always crash when I click on the
launcher, then bug-buddy comes up.

I guess this is a known problem because it happened in Test 2 and now in Test3
Live CD.  The funny thing is that on my test system updated as of today April 1
it works fine and even before Test 3 were released (but after Test 2) it didn't
fail either.

I am reporting this because the version in Test 3 Live CD and my test system is
exactly the same.

Version-Release number of selected component (if applicable):
abiword-2.4.6-3.fc7

How reproducible:
Always

Steps to Reproduce:
1. Open abiword from system menu or command line using the Live CD
2.
3.
  
Actual results:
Abiword fails to start

Expected results:
Abiword works fine
Comment 1 William Lovaton 2007-04-01 13:55:15 EDT
Created attachment 151392 [details]
Report of the crash generated by bug-buddy

Maybe useless but this is the crash report from bug-buddy when running from the
Live CD (Fedora 7 Test 3).
Comment 2 Ray Strode [halfline] 2007-04-05 16:01:27 EDT
Created attachment 151808 [details]
handle one font having multiple families

The above patch seems to fix things for me.  The problem seems to be that we
default to "Sans" which is an alias for the DejaVu Sans font that has two
family names "DejaVu Sans" and "DejaVu LGC Sans".  At startup abiword creates a
hash table of every font on the system and later assumes if a font is asked for
and fontconfig knows about it, then it will be in the hash table.  It only
added the first family for the font pattern to the hash table, however. The
crash in this case was because the font was being requested by a family that
didn't get added to the hash table.
Comment 3 Marc Maurer 2007-04-06 11:06:41 EDT
*** Bug 227192 has been marked as a duplicate of this bug. ***
Comment 4 Marc Maurer 2007-04-06 12:14:52 EDT
Slightly modified version of the patch committed upstream. Will be in the next
build. Thanks a lot!
Comment 5 Marc Maurer 2007-04-06 12:22:08 EDT
*** Bug 235322 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.