Bug 227207 - CDRom device not recognized by F7 (pata_ali)
CDRom device not recognized by F7 (pata_ali)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
: 231081 238095 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-02-03 10:44 EST by Mark Drago
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-18 13:47:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (29.64 KB, text/plain)
2007-03-24 11:31 EDT, William Shotts
no flags Details
lspci output (8.34 KB, text/plain)
2007-03-24 11:36 EDT, William Shotts
no flags Details
patch that alan sent upstream, altered for 3025.fc7, and does not fix the problem (4.94 KB, patch)
2007-04-01 08:48 EDT, Mark Drago
no flags Details | Diff
lspci -vvxxx output stock fc6 kernel (20.95 KB, text/plain)
2007-04-26 23:50 EDT, Vegard Lima
no flags Details
lspci -vvxxx output 2.6.21-rc6-mm1 kernel using pata_ali driver (22.85 KB, text/plain)
2007-04-26 23:51 EDT, Vegard Lima
no flags Details
lspci -vvxxx output for 2.6.21-rc6-mm1 (20.92 KB, text/plain)
2007-04-27 12:02 EDT, Vegard Lima
no flags Details

  None (edit)
Description Mark Drago 2007-02-03 10:44:30 EST
Description of problem:
I tried installing F7T1 from DVD on my HP Pavilion ZE4400 laptop and it fails to
find my CD device after booting.  It brings up the 'Installation Method' screen
asking me where the packages are located (Local CDROM, Hard Drive, etc.).  If I
select Local CDROM it asks me to select a driver to load.

The 3rd VT says that it successfully loaded the libata and pata_ali modules from
/modules/modules.cgz, but then it says 'got to setupCdrom without a CD device'.

The 4th VT seems to have the following text repeated a few times:
<4>ata2.00: limiting speed to MWDMA2
<3>ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
<3>ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in
<4>         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
<6>ata2: soft resetting port
<6>ata2.00: configured for MWDMA1
<6>ata2: EH complete

Version-Release number of selected component (if applicable):
Fedora 7 Test 1 DVD

How reproducible:
Always.
Comment 1 Mark Drago 2007-02-05 21:09:05 EST
I thought I would add a few more details.  First, my hard drive is detected just
fine, which I would have thought was on the same IDE controller as the dvd
drive.  I am guessing that it is, but it is detected and the CD/DVD drive is
not.  I was able to complete the F7T1 installation by performing an HTTP
installation.  After booting in to the new system the CD drive is still not
detected.  Updating to the latest kernel, which is now 2.6.20-1.2922.fc7, also
leaves the CD drive undetected.
Comment 2 Mark Drago 2007-02-22 18:59:54 EST
This problem still exists with kernel 2.6.20-1.2936.fc7.  I have included more
extensive output from dmesg.  I'm assuming that the ACPI Exception & Error stuff
is probably not helping.  If there is any other information that may be of help
I can provide that.


SCSI subsystem initialized
libata version 2.10 loaded.
ACPI: Unable to derive IRQ for device 0000:00:10.0
ACPI: PCI Interrupt 0000:00:10.0[A]: no GSI
ata1: PATA max UDMA/133 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x00018080 irq 14
ata2: PATA max UDMA/133 cmd 0x00010170 ctl 0x00010376 bmdma 0x00018088 irq 15
scsi0 : pata_ali
Synaptics Touchpad, model: 1, fw: 5.9, id: 0x236eb3, caps: 0x904713/0x10008
input: SynPS/2 Synaptics TouchPad as /class/input/input2
usb 1-2: new low speed USB device using ohci_hcd and address 2
ata1.00: ATA-5: IC25N040ATCS04-0, CA4OA71A, max UDMA/100
ata1.00: 78140160 sectors, multi 16: LBA 
ata1.00: configured for UDMA/100
scsi1 : pata_ali
usb 1-2: configuration #1 chosen from 1 choice
input: Kensington Kensington USB Wheel Mouse as /class/input/input3
input: USB HID v1.10 Mouse [Kensington Kensington USB Wheel Mouse] on
usb-0000:00:02.0-2
ata2.00: ATAPI, max MWDMA2
ata2.00: configured for MWDMA2
scsi 0:0:0:0: Direct-Access     ATA      IC25N040ATCS04-0 CA4O PQ: 0 ANSI: 5
SCSI device sda: 78140160 512-byte hdwr sectors (40008 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
SCSI device sda: 78140160 512-byte hdwr sectors (40008 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO
or FUA
 sda: sda1 sda2 sda3
sd 0:0:0:0: Attached scsi disk sda
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in
         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata2: soft resetting port
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in
         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata2: soft resetting port
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in
         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata2: soft resetting port
ata2.00: configured for MWDMA2
ata2: EH complete
ata2.00: limiting speed to MWDMA1
ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in
         res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
ata2: soft resetting port
ACPI Exception (exoparg2-0442): AE_AML_PACKAGE_LIMIT, Index (0FFFFFFFF) is
beyond end of object [20070126]
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.IDE_.GTF0]
(Node dbc0e4a4), AE_AML_PACKAGE
_LIMIT
ACPI Error (psparse-0537): Method parse/execution failed
[\_SB_.PCI0.IDE_.SECN.MAST._GTF] (Node dbc0e964), AE_A
ML_PACKAGE_LIMIT
ata2.00: configured for MWDMA1
ata2: EH complete
Comment 3 William Shotts 2007-03-24 11:31:46 EDT
Created attachment 150828 [details]
dmesg output
Comment 4 William Shotts 2007-03-24 11:34:38 EDT
I see this problem on an old HP Pavillion I use for testing.  dmesg reports:

ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00: cmd a0/01:00:00:00:00/00:00:00:00:00/a0 tag 0 cdb 0x46 data 8 in
         res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
ata2: port is slow to respond, please be patient (Status 0xd0)
ata2: port failed to respond (30 secs, Status 0xd0)
ata2: soft resetting port
ata2.00: configured for MWDMA2
ata2: EH complete
Comment 5 William Shotts 2007-03-24 11:36:05 EDT
Created attachment 150829 [details]
lspci output
Comment 6 Alan Cox 2007-03-28 10:51:26 EDT
Test patch posted upstream for the pata_ali problems.
2.6.21 final will turn off the ACPI extras for now so that problem should also
be fixed very soon and then will be addressed in full in 2.6.22
Comment 7 Mark Drago 2007-04-01 08:45:55 EDT
Alan,

I saw that patch that you posted to lkml here and rebuilt the 3025.fc7 kernel
with that patch applied.  I had to recreate the patch so that it would apply
against 3025.fc7, but I will attach my patch just to show that it is not a
cobbled up mess.  However, the patch did not seem to fix the problem.  Someone
has already reported this on LKML here:
http://marc.info/?l=linux-kernel&m=117510420427468&w=2  I figured it would be
good to keep the information here on this bug report as well.  The relevant
output in dmesg is identical to what I posted above except it reports that it is
running libata version 2.20 instead of 2.10, and it says this about limiting its
speed: 'ata2.00: limiting speed to MWDMA1:PIO4' instead of saying 'ata2.00:
limiting speed to MWDMA1'.  If there is any information I can provide that would
be of assistance please let me know.
Comment 8 Mark Drago 2007-04-01 08:48:50 EDT
Created attachment 151386 [details]
patch that alan sent upstream, altered for 3025.fc7, and does not fix the problem

Note that this patch does not fix the problem, and is only attached here so
that we have a complete history of this bug.
Comment 9 Alan Cox 2007-04-01 15:02:06 EDT
Try 2047 instead of 511, let me know what that does ?
Comment 10 Mark Drago 2007-04-03 08:08:29 EDT
I hate being the bearer of bad news.  I changed the patch to read as follows:

+static int ali_check_atapi_dma(struct ata_queued_cmd *qc)
+{
+       /* Don't do DMA except for whole blocks */
+       if (qc->nbytes & 2047)
+               return -1;
+       return 0;
+}

But unfortunately this produced the same results.  There is no /dev/sdb and the
dmesg output is the same.
Comment 11 Alan Cox 2007-04-19 06:36:17 EDT
*** Bug 231081 has been marked as a duplicate of this bug. ***
Comment 12 Ricardo Ariel Gorosito 2007-04-22 20:57:31 EDT
Same problem with ALI M5229 (rev c4) in motherboard ASUS A7A266
Comment 13 Vegard Lima 2007-04-23 14:31:39 EDT
No luck with this patch either:
http://lkml.org/lkml/2007/4/23/106
(Same error message as before.)
Comment 14 Alan Cox 2007-04-23 16:45:18 EDT
Ok three more things to try folks:

#1 Change the check_atapi_dma functions to always return -1 and see what happens

If that doesn't work

#2 Remove all the .mwdma_mask and .udma_mask lines from ali_init_one() struct
ata_port_info entries and see what happens

And finally (irrespective of what both do). Without the changes made can you do an
lspci -vvxxx with an "old IDE" kernel which works on the box, and the same with
the libata which isn't working so I can try and see what PCI config may be
different.

And thanks people for all the testing so far (both those who've added to the bug
or just read it and emailed results)
Comment 15 Vegard Lima 2007-04-26 23:50:48 EDT
Created attachment 153577 [details]
lspci -vvxxx output stock fc6 kernel
Comment 16 Vegard Lima 2007-04-26 23:51:31 EDT
Created attachment 153578 [details]
lspci -vvxxx output 2.6.21-rc6-mm1 kernel using pata_ali driver
Comment 17 Vegard Lima 2007-04-26 23:53:31 EDT
Kernel 2.6.21-rc6-mm1 boots after doing the return -1 change
#1 in Comment #14.
Comment 18 Alan Cox 2007-04-27 11:57:10 EDT
Second attachment appears to be a dmesg not the lspci -vvxxx needed ?

Alan
Comment 19 Vegard Lima 2007-04-27 12:02:54 EDT
Created attachment 153639 [details]
lspci -vvxxx output for 2.6.21-rc6-mm1

This should be the correct file...
Comment 20 Alan Cox 2007-05-14 13:34:20 EDT
*** Bug 238095 has been marked as a duplicate of this bug. ***
Comment 21 Alan Cox 2007-05-14 13:36:55 EDT
Grr why can't bugzilla hand propogate blocks on dup marking. Add blocker 
Comment 22 Vegard Lima 2007-05-15 15:10:57 EDT
Any reason the status of this bug is NEEDINFO?
Is there any more info I should supply?
Comment 23 Alan Cox 2007-05-15 18:32:40 EDT
No more info needed sorry.


For FC7 proposal is we just disable CDROM DMA on the ALi - so at least it
installs for everyone, then try and debug it.
Comment 24 Arkady L. Shane 2007-05-16 05:03:56 EDT
Hm, I have such problem on Asus A8N-VM (with nvidia chipsets) with last
development kernel (2.6.21-1.3149.fc7) after haldaemon starts. But on FC6 with
2.6.21-1.2948.fc6 this problem is absent.
Comment 25 Jeremy Katz 2007-05-18 11:54:02 EDT
Patch to disable DMA for CDs on ALi is in the current kernel.  Can people
confirm that kernels after 3141 recognize their CD device? 

And new live images will be going up after I eat lunch if you need/want to try
that way.
Comment 26 Ricardo Ariel Gorosito 2007-05-18 13:00:30 EDT
With 2.6.21-1.3149.fc7 my DVDROM is working now on ALI M5229 - rev c4
(motherboard ASUS A7A266)
Comment 27 Dan Beard 2007-05-28 23:02:33 EDT
DLed and booted rawhide-20070517-i386-Live.iso thgis afternoon.

Boots just fine on both problematic laptops.


Thank you, gentlemen!


Dan

Note You need to log in before you can comment on or make changes to this bug.