Bug 238095 - LiveCD test 4 fails to boot with pata_ali
LiveCD test 4 fails to boot with pata_ali
Status: CLOSED DUPLICATE of bug 227207
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 239949 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-04-27 00:44 EDT by Dan Beard
Modified: 2013-01-09 23:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-14 13:34:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Beard 2007-04-27 00:44:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
F7 Test 4 LiveCd fails to boot.   "WARNING: Canoot find root file system!

Laptop:  HP ze5170 Pentium 4

Any size HDD.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Insert Live CD press enter.
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Dan Beard 2007-04-27 10:43:50 EDT
Results 100% duplicated on HP ze4427 laptop.

Dan
Comment 2 David Lawrence 2007-05-01 16:44:09 EDT
Assigning to proper component and product.
Comment 3 Jeremy Katz 2007-05-01 16:53:10 EDT
What IDE controller do these laptops use?  Can you get the output of lspci at
least?  Added bonus would be the output of dmesg from when it fails, but that
can be tricky... the same sort of information can also be gotten if you boot the
installer (and then have a more full environment)
Comment 4 Dan Beard 2007-05-01 20:34:27 EDT
Sorry, David.   I'm not sure I can get that for you.   It isn't getting in far
enough to do much of anything.   

The last thing it says is, "Create symlink /dev/root and then exit this shell to
continue the boot sequence."   Then it drops to the shell and is for all intents
and purposes, useless.   If I exit the shell, it says, "Bug in initramfs /init
detected.  Dropping to a shell.  Good luck!"

And there she sits ... blinking.

If you've got an idea how to get the info you need, I'm all ears.

:)

Dan
Comment 5 Dan Beard 2007-05-01 20:42:24 EDT
Hmmm.

Popped in the Debian Etch drive.   Here's the output of lspci:

dan@ze5170:~$ lspci
00:00.0 Host bridge: ALi Corporation M1671 Super P4 Northbridge [AGP4X,PCI and
SDR/DDR] (rev 02)
00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:0a.0 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller
(rev 01)
00:0a.1 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller
(rev 01)
00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000
Controller (PHY/Link)
00:0f.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815
(MacPhyter) Ethernet Controller
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
dan@ze5170:~$


Dan
Comment 6 Dan Beard 2007-05-01 20:59:31 EDT
Here are the lspci results from the other laptop.

[root@ze4400 ~]# lspci
00:00.0 Host bridge: ATI Technologies Inc AGP Bridge [IGP 320M] (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus
Controller
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815
(MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1
[root@ze4400 ~]# 

Hope it helps.

Dan
Comment 7 Jeremy Katz 2007-05-01 21:26:50 EDT
Looks like another pata_ali problem
Comment 8 Elio Tondo 2007-05-08 07:26:05 EDT
Same problem here, on an old Acer TravelMate 612TX (Pentium III 900, 512 MB RAM,
HDD 40 GB IDE, CD-ROM IDE, i815 chipset). When booting the LiveCD, the kernel
starts but then the IDE CD recognized with 1 sector of 512 bytes (!), and
(obviously) the root FS is not mounted, and after some IDE errors and retries a
shell prompt appears.
This happened since F7test1; up to test3 I used to have problems also on other
"old" hardware (e.g. a desktop PIII probably with a VIA chipset) but now test4
boots with no problem on that hardware; however it still fails on the laptop.

I had no problem so far with FC3 to FC6 on the same laptop; if this can be
useful, I can boot the intalled FC6 and send you the output of lspci and/or
dmesg from that version; I also can send a picture of the laptop screen; anyway
the important part seems:

sdb: sector size 0 reported, assuming 512
SCSI device sdb: 1 512-byte hdwr sectors (0 MB)
sdb: Write Protect is off
sdb: Mode Sense: 00 00 00 00
sdb: cache data unavailable
(the above lines repeated another time, then:)
sdb: assuming drive cache: write through
sdb:<3>ata2.00: exception Emask
ata2.00: cmd a0/01:00:00:....
         res 40/00:03:00:....

I am available to test a modified LiveCD if this can be useful.

Elio
Comment 9 Bruce Brackbill 2007-05-14 01:42:26 EDT
I think I just posted a duplicate of this bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=239949

My machine is a sony vaio pcg-frv35 notebook

Here is the lspci output:

00:00.0 Host bridge: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M]
(rev 02)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
00:03.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link
Controller Audio Device (rev 02)
00:06.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0a.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0a.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 02)
00:0c.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 50)
00:0c.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 50)
00:0c.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:12.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M

Comment 10 Jeremy Katz 2007-05-14 12:12:15 EDT
*** Bug 239949 has been marked as a duplicate of this bug. ***
Comment 11 Alan Cox 2007-05-14 13:34:10 EDT

*** This bug has been marked as a duplicate of 227207 ***

Note You need to log in before you can comment on or make changes to this bug.