Bug 2272149 - Loupe cannot open JPEG images
Summary: Loupe cannot open JPEG images
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: loupe
Version: 40
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David King
QA Contact:
URL:
Whiteboard: openqa AcceptedBlocker
: 2272930 (view as bug list)
Depends On: 2272614
Blocks: F40FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2024-03-29 02:29 UTC by Rubén
Modified: 2024-04-05 23:10 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-04-05 23:10:08 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
example (5.11 MB, image/jpeg)
2024-03-29 02:30 UTC, Rubén
no flags Details

Description Rubén 2024-03-29 02:29:53 UTC
Loupe cannot open JPEG images. It shows the following error message: "Unknown image format: image/jpeg". I'm running Fedora 40 beta. It worked in Fedora 39.

Reproducible: Always

Steps to Reproduce:
1.Set loupe a the default image viewer
2.Open a JPEG file with Nautilus
Actual Results:  
Error message "Unknown image format: image/jpeg"

Expected Results:  
Image opened

I'm running Fedora 40 beta.

Comment 1 Rubén 2024-03-29 02:30:51 UTC
Created attachment 2024105 [details]
example

Comment 2 Andreas 2024-03-29 09:45:42 UTC
I can reproduce this on Fedora Workstation 40 beta both on a bare metal and on a VM installation. For me the problem also occurs with PNG, and SVG images. So It seems to be a general problem with Loupe 46.

Comment 3 Andreas 2024-03-29 09:49:00 UTC
The problem does not occur with the Flatpak version of Loupe, so it seems to be related to the RPM packaging of the app.

Comment 4 Rubén 2024-03-29 10:03:07 UTC
It actually happens with ALL file formats.

Comment 5 Fabio Valentini 2024-03-29 11:54:03 UTC
Is this happening with loupe 46.0 (still in updates-testing) or loupe 45.3?

Comment 6 Andreas 2024-03-29 11:56:18 UTC
It's happening with Loupe 46.0. It was not happening with 45.3 on Fedora Workstation 39.

Comment 7 Fabio Valentini 2024-03-29 12:54:29 UTC
(In reply to Andreas from comment #6)
> It's happening with Loupe 46.0. It was not happening with 45.3 on Fedora
> Workstation 39.

I was trying to say: Does this issue also occur *on Fedora 40* with loupe *45.3* too?
The package for loupe has only been updated to version 46.0 in Fedora 40 two days ago, and it's still in "testing".

Can somebody on Fedora 40 try downgrading to loupe 45.3 to see if some other change on Fedora 40 is the cause, or indeed the update from loupe 45.3 to 46.0?

Comment 8 Andreas 2024-03-29 14:20:10 UTC
(In reply to Fabio Valentini from comment #7)
> (In reply to Andreas from comment #6)
> > It's happening with Loupe 46.0. It was not happening with 45.3 on Fedora
> > Workstation 39.
> 
> I was trying to say: Does this issue also occur *on Fedora 40* with loupe
> *45.3* too?
> The package for loupe has only been updated to version 46.0 in Fedora 40 two
> days ago, and it's still in "testing".
> 
> Can somebody on Fedora 40 try downgrading to loupe 45.3 to see if some other
> change on Fedora 40 is the cause, or indeed the update from loupe 45.3 to
> 46.0?

Just tested it. Loupe 45.3 on Fedora 40 works fine. I tested JPEG, PNG, and SVG files, they all work. The same files fail to open with Loupe 46.0 on the same computer.

Comment 9 Fabio Valentini 2024-03-29 20:34:21 UTC
Thank you!

At this point I can think of two possible culprits:

1) loupe 46.0 also requires updated glycin / glycin-loaders

This would explain why both loupe 45.3 on F40 and the loupe flatpak work.

2) loupe 46.0 switched to building with vendored Rust dependencies instead of the distro-provided packages, and some vendored dependency is behaving differently than the packaged version.

I am working on updating the Rust dependencies for loupe and snapshot 46.0, so comparing to a build of loupe without vendored sources should be possible soon.

Comment 10 msmafra 2024-03-30 16:48:46 UTC
I upgrade from my F39 to F40 Beta, with the rpm installed loupe I can't visualize any images, with feh, flatpak loupe etc works fine. The glycin-loaders packes is already installed (I did not install it) and is the only one available besides rust dev ones.


❯ doas dnf5 search glycin
Updating and loading repositories:
Repositories loaded.
Matched fields: name
 glycin-loaders.x86_64: Sandboxed image rendering
 rust-glycin+default-devel.noarch: Sandboxed image decoding
 rust-glycin-devel.noarch: Sandboxed image decoding
 rust-glycin-utils+default-devel.noarch: Sandboxed image decoding
 rust-glycin-utils+image-devel.noarch: Sandboxed image decoding
 rust-glycin-utils+image-rs-devel.noarch: Sandboxed image decoding
 rust-glycin-utils-devel.noarch: Sandboxed image decoding
 
❯ doas dnf5 info glycin
Updating and loading repositories:
Repositories loaded.
No matching packages to list
~ 
❯ doas dnf5 info glycin-loaders
Updating and loading repositories:
Repositories loaded.
Installed packages
Name            : glycin-loaders
Epoch           : 0
Version         : 0.1.2
Release         : 4.fc40
Architecture    : x86_64
Installed size  : 15.7 MiB
Source          : glycin-loaders-0.1.2-4.fc40.src.rpm
From repository : <unknown>
Summary         : Sandboxed image rendering
URL             : https://gitlab.gnome.org/sophie-h/glycin
License         : (Apache-2.0 OR MIT) AND BSD-3-Clause AND (MIT OR Apache-2.0) A
                : ND Unicode-DFS-2016 AND (0BSD OR MIT OR Apache-2.0) AND Apache
                : -2.0 AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-excepti
                : on OR Apache-2.0 OR MIT) AND BSD-2-Clause AND LGPL-2.1-or-late
                : r AND MIT AND (MIT OR Apache-2.0) AND (MIT OR Apache-2.0 OR Zl
                : ib) AND (MIT OR Zlib OR Apache-2.0) AND MPL-2.0 AND (MPL-2.0 O
                : R LGPL-2.1-or-later) AND (Unlicense OR MIT) AND (Zlib OR Apach
                : e-2.0 OR MIT)
Description     : Sandboxed and extendable image decoding.
Vendor          : Fedora Project

Comment 11 greenrat 2024-03-31 19:23:03 UTC
After updating from Fedora 38 to beta 40, jpeg files stopped opening with Loupe.


- Version: 46.0
- App ID: org.gnome.Loupe
- Sandboxed: false 

##### OS Information
```
NAME="Fedora Linux"
VERSION="40 (Workstation Edition Prerelease)"
ID=fedora
VERSION_ID=40
VERSION_CODENAME=""
PLATFORM_ID="platform:f40"
PRETTY_NAME="Fedora Linux 40 (Workstation Edition Prerelease)"
ANSI_COLOR="0;38;2;60;110;180"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:40"
DEFAULT_HOSTNAME="fedora"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/f40/system-administrators-guide/"
SUPPORT_URL="https://ask.fedoraproject.org/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=40
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=40
SUPPORT_END=2025-05-13
VARIANT="Workstation Edition"
VARIANT_ID=workstation

```

Comment 12 Adam Williamson 2024-04-01 07:17:17 UTC
openQA has been running into this for several days, I hadn't had time to investigate it yet. Thanks for the report. probably a Final blocker, per https://fedoraproject.org/wiki/Fedora_40_Final_Release_Criteria#Default_application_functionality .

Comment 13 Brian Morrison 2024-04-01 14:17:21 UTC
It may be significant that if loupe is opened from the Image Viewer icon, then click on "Open Files..." and select a directory that is full of jpegs in nautilus, no files are displayed with Supported Image Formats selected. It's as if loupe doesn't know what formats it supports.

Comment 14 Michael Catanzaro 2024-04-01 14:47:46 UTC
Sophie says "the loupe package should depend on glycin-loaders 1.0"

Comment 15 Sophie Herold 2024-04-01 15:03:48 UTC
> It's as if loupe doesn't know what formats it supports.

It's the exact opposite. Loupe knows which formats it supports. If no glycin-loaders are installed, that's none.

Comment 16 Brian Morrison 2024-04-01 15:19:23 UTC
(In reply to Sophie Herold from comment #15)
> > It's as if loupe doesn't know what formats it supports.
> 
> It's the exact opposite. Loupe knows which formats it supports. If no
> glycin-loaders are installed, that's none.

I see, I had never heard of glycin-loaders until today. But I now know that my F40 machines have glycin-loaders-0.1.2-4 which seems to be too old for loupe-46.0

Comment 17 Neil Hanlon 2024-04-01 16:28:13 UTC
Discussed at the 2024-04-01 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/

This was **Accepted** as a Release Blocker as a violation of Final criterion:

"For all release-blocking desktop / arch combinations, the following applications must start successfully and withstand a basic functionality test: ... image viewer"

Comment 19 Navroop Singh 2024-04-01 20:14:59 UTC
Loupe 46.0 installed from flathub works perfect. Only the RPM package is not working.

Comment 20 Fabio Valentini 2024-04-01 20:30:59 UTC
It looks like the updates for GNOME components that are written in Rust (loupe, snapshot, glycin) were partially missed.

I'll try to work on getting glycin-loaders updated for Fedora 40+.

Comment 21 Adam Williamson 2024-04-01 21:09:39 UTC
CC Dave so he knows about this in future.

Comment 22 Fabio Valentini 2024-04-02 09:32:10 UTC
I started preparing the glycin-loaders update.

I've added DependsOn/Blocks to the appropriate bugzillas, but a better overview of TODO items is here:
https://hackmd.io/@decathorpe/glycin-update

Comment 23 Adam Williamson 2024-04-02 15:22:09 UTC
Ooof. Sorry about that. Let me know if you need any provenpackager help.

Comment 24 Fedora Update System 2024-04-02 20:17:42 UTC
FEDORA-2024-2d6f70c275 (glycin-loaders-1.0.1-1.fc40, rust-ashpd0.6-0.6.7-1.fc40, and 46 more) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-2d6f70c275

Comment 25 Fedora Update System 2024-04-03 01:22:04 UTC
FEDORA-2024-2d6f70c275 has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-2d6f70c275`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-2d6f70c275

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 26 Fabio Valentini 2024-04-03 17:24:18 UTC
(In reply to Adam Williamson from comment #23)
> Ooof. Sorry about that. Let me know if you need any provenpackager help.

Thanks, but it should all be dealt with.
I have access to all related packages via rust-sig group membership (and I'm also provenpackager, but I don't like abusing that for pushing non-critical fixes).

Comment 27 Fabio Valentini 2024-04-04 11:24:51 UTC
*** Bug 2272930 has been marked as a duplicate of this bug. ***

Comment 28 greenrat 2024-04-04 17:58:33 UTC
After installing OS updates today, all images open well. Tried it on several devices.

Comment 29 Kamil Páral 2024-04-05 08:26:28 UTC
I can also verify it works now after the update.

Comment 30 Fedora Update System 2024-04-05 23:10:08 UTC
FEDORA-2024-2d6f70c275 (glycin-loaders-1.0.1-1.fc40, rust-ashpd0.6-0.6.7-1.fc40, and 46 more) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.