Bug 227257 - latest firefox update shows broken webs
latest firefox update shows broken webs
Status: CLOSED DUPLICATE of bug 227406
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Christopher Aillon
:
: 227269 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-03 20:35 EST by acount closed by user
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 09:09:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spiegel (409.36 KB, image/png)
2007-02-05 07:31 EST, Matěj Cepl
no flags Details
The similar problem in Thunderbird (301.02 KB, image/png)
2007-02-05 10:07 EST, Matěj Cepl
no flags Details

  None (edit)
Description acount closed by user 2007-02-03 20:35:55 EST
firefox-1.5.0.9-2.fc6 shows broken webs like these:

http://www.osnews.com
http://google.dirson.com


old release works OK.


-thanks-
Comment 1 Eric Tanguy 2007-02-04 07:05:19 EST
I have also problems with this version : 
see http://perso.orange.fr/eric.tanguy/Capture.png

Thanks
Comment 2 Enrico Scholz 2007-02-04 10:44:22 EST
ditto here (http://www.spiegel.de -> only the first letter of <h4> headings is
shown).
Comment 3 Lars E. Pettersson 2007-02-04 12:00:09 EST
I noted that with Pango disabled, firefox had problems rendering some header
lines, only the first letter shown, just as stated above.

With Pango enabled (the default) the headers looked OK.

Looks like a problem with rendering when Pango is disabled.
Comment 4 Matěj Cepl 2007-02-05 07:29:55 EST
Can reproduce with http://www.spiegel.de and firefox-1.5.0.9-6.el5
Comment 5 Matěj Cepl 2007-02-05 07:31:06 EST
Created attachment 147349 [details]
Spiegel

See "Themen des Tages" on the right side of the page.
Comment 6 Matěj Cepl 2007-02-05 10:07:39 EST
Created attachment 147359 [details]
The similar problem in Thunderbird

Seems that I can reproduce this with Thunderbird thunderbird-1.5.0.9-6
Comment 7 Christopher Aillon 2007-02-05 10:49:57 EST
If this is only a problem with pango disabled, then I'd say enable it.
Comment 8 Eric Tanguy 2007-02-05 13:42:37 EST
Tha problem is i need to disable pango to have a correct rendering of mathml so
what can i do ?
Comment 9 Christopher Aillon 2007-02-05 13:45:59 EST
We fixed the mathml issues already in pango.
Comment 10 Eric Tanguy 2007-02-05 14:11:08 EST
OK but the problem is that pango seems to be enabled (#MOZ_DISABLE_PANGO=1 and
#export MOZ_DISABLE_PANGO are commented). But i still have the problem with my
account. If i rename .mozilla to make firefox create a new one the problem still
persist. If i open a cli and su to root and then launch firefox it seems there
is no rendering problem. So i think there is something on my home that breaks
firefox rendering but i can't find what. Some help ?
Comment 11 Eric Tanguy 2007-02-05 16:11:54 EST
I have found where the problem come from i put export MOZ_DISABLE_PANGO=1 in
.bash_profile so i delete this and now all is fine. Sorry for the noise.
Comment 12 Matěj Cepl 2007-02-05 18:23:32 EST
Probably related to this is bug 227406.
Comment 13 Matěj Cepl 2007-02-06 10:51:56 EST
*** Bug 227269 has been marked as a duplicate of this bug. ***
Comment 14 Matěj Cepl 2007-02-07 09:09:44 EST

*** This bug has been marked as a duplicate of 227406 ***

Note You need to log in before you can comment on or make changes to this bug.