Bug 227406 - (gecko-nopango) garbage characters on some websites (pango disabled)
garbage characters on some websites (pango disabled)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 227257 227475 227761 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-05 15:40 EST by Nikos Charonitakis
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 09:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot example (291.84 KB, image/png)
2007-02-05 15:41 EST, Nikos Charonitakis
no flags Details
proposed patch (11.08 KB, patch)
2007-02-07 19:19 EST, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Nikos Charonitakis 2007-02-05 15:40:20 EST
Description of problem:
I used to browse without pango enabled. Everything was ok until few days ago
(probably after a firefox update) that some sites shows text as scattered
letters all over the text place. Firefox works ok
I have to enable pango to solve the problem (menu->system tools->system settings)
example sites:
http://oneiros.gr/blog/2007/02/04/etbloginlay
http://avi.alkalay.net/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nikos Charonitakis 2007-02-05 15:41:58 EST
Created attachment 147398 [details]
screenshot example
Comment 2 Matěj Cepl 2007-02-05 18:23:08 EST
Probably related to Firefox bug 227257. The solution is that you just should not
disable Pango -- running gecko without pango is not supported in Fedora (it is
there just for debugging/development reasons). See for more details the
mentioned bug.
Comment 3 Matěj Cepl 2007-02-05 18:24:55 EST
sorry the braces in the previous comment should read
(the ability to switch off Pango stays in gecko just for ...)
Comment 4 Nikos Charonitakis 2007-02-05 19:02:37 EST
(In reply to comment #2)
> Probably related to Firefox bug 227257. The solution is that you just should not
> disable Pango -- running gecko without pango is not supported in Fedora (it is
> there just for debugging/development reasons). See for more details the
> mentioned bug.

ok i have done that (disable pango) but this turns epiphany pretty useless.
Performance is so bad that you have to simply change browser to firefox.
Dont tell me switch to firefox :)


Comment 5 Matěj Cepl 2007-02-06 10:54:45 EST
I am using epiphany myself :-), so I would tell you to file a bug against it and
describe thoroughly your problems with its performance.
Comment 6 Simos Xenitellis 2007-02-06 21:16:01 EST
The effect of the screenshot shows that something has gone terribly wrong.
The course of action would be to save the offending page, chop it in small
pieces so that a simple small test case can be extracted.

We now test only with Pango as enabled. There is no going back.
Make sure that "MOZ_DISABLE_PANGO" is not set.
Comment 7 Christopher Aillon 2007-02-06 22:15:34 EST
Behdad/Akira, any chances you might know what may have caused this?
Comment 8 Christopher Aillon 2007-02-06 22:17:36 EST
*** Bug 227475 has been marked as a duplicate of this bug. ***
Comment 9 Behdad Esfahbod 2007-02-07 00:48:46 EST
What was pushed to FC6?  Some of Akira's patches may be causing this.  Akira,
can you check?
Comment 10 Akira TAGOH 2007-02-07 04:28:26 EST
Well, there seems not implemented GetRangeWidth in nsFontMetricsXft.
Comment 11 Christopher Aillon 2007-02-07 08:47:40 EST
Can we implement that?
Comment 12 Matěj Cepl 2007-02-07 09:10:10 EST
*** Bug 227257 has been marked as a duplicate of this bug. ***
Comment 13 Akira TAGOH 2007-02-07 09:32:49 EST
Yes, I'm trying
Comment 14 Matěj Cepl 2007-02-07 18:46:36 EST
*** Bug 227761 has been marked as a duplicate of this bug. ***
Comment 15 Akira TAGOH 2007-02-07 19:19:43 EST
Created attachment 147619 [details]
proposed patch

attached patch will fixes this issue.
Comment 16 Martin Stransky 2007-02-09 05:47:12 EST
That patch works fine for me...
Comment 17 Martin Stransky 2007-09-10 09:59:37 EDT
fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.