This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 227266 - dhclient ignores dhcp replies
dhclient ignores dhcp replies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
: 227286 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-04 07:11 EST by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-04 14:35:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2007-02-04 07:11:33 EST
Description of problem:
dhclient seems to ignore dhcp replies sent in response to it's dhcp requests,
resulting in non working dhcp.
tcpdump shows dhcp requests being sent and replies being received on the
relevant interfaces.
This bug was reported to happen on FC6, too, where disabling selinux fixed it.
This is not the case on devel.

Version-Release number of selected component (if applicable):
dhclient-3.0.5-14.fc7

How reproducible:
Always

Steps to Reproduce:
1. try to get an ip address using dhclient
2.
3.
  
Actual results:
dhclient times out eventually without configuring the interface

Expected results:
get an ip address

Additional info:
Comment 1 David Cantrell 2007-02-04 14:35:31 EST
The Xen partial UDP checksum patch was breaking dhclient.  Disabled the patch
for now, so dhclient should be working fine in dhcp-3.0.5-16.
Comment 2 David Cantrell 2007-02-04 15:13:47 EST
*** Bug 227286 has been marked as a duplicate of this bug. ***
Comment 3 Sander Hoentjen 2007-02-04 15:19:23 EST
sorry for being slow and filing the duplicate, I will check the new one when it
hits rawhide.
Comment 4 Peter Bieringer 2007-07-28 04:20:35 EDT
Can it be that this issue is rising up again using

kernel-2.6.22.1-33.fc7
dhclient-3.0.5-38.fc7

happen here on F7. While IPv6 router advertisements are received properly, IPv4
DHCP won't work...

Also dhclient-3.0.6-2.f8 from development won't fix this issue - is there a
kernel bug somewhere?
Comment 5 Carl Henrik Lunde 2007-08-01 16:26:24 EDT
(In reply to comment #4)
> Can it be that this issue is rising up again using
> 
> kernel-2.6.22.1-33.fc7

I had the same issue with -33, however it seems to work again with -41

Note You need to log in before you can comment on or make changes to this bug.