Bug 22742 - Anaconda Installer crash for Loopback install
Anaconda Installer crash for Loopback install
Status: CLOSED DUPLICATE of bug 19040
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-22 09:52 EST by Alan Robinson
Modified: 2007-03-26 23:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 11:31:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Robinson 2000-12-22 09:52:34 EST
When installing to a loopback file on a Fat32 formated drive, I get the 
following error:


Traceback (innermost last):
  File 

"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 

20, in run
    rc = self.todo.doInstall ()
  File 

"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 

doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 

self.hdList.selected()):
  File 

"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 

systemMounted
    self.loopbackFile = mntPoint + 

fstab.filesystemSpace(mntPoint)[0][0] + \
IndexError: list index out of range


------
Note that this happens on 3 different machines, all with fat32 partitions. 
It also happens independent of loopback size (from 300 mb to 1900).   Most 
noteable, however, is that this error only happens with the 7.0 respin 
iso's. The original 7.0 release does not crash in this way.
Comment 1 Michael Fulbright 2000-12-27 11:31:02 EST

*** This bug has been marked as a duplicate of 19040 ***
Comment 2 Alan Robinson 2000-12-27 17:05:50 EST
LoopBack bug described above does not happen if you select a custom install, 
but do not change any of the packages to be installed from the default 
selections.  Again, this problem does not show up on the non respin ISOs.

Note You need to log in before you can comment on or make changes to this bug.