Bug 19040 - Partionless Upgrade Failure (6.2->7.0)
Partionless Upgrade Failure (6.2->7.0)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
: 19163 19928 22334 22742 22931 23113 24305 30411 31253 34276 35058 36426 41455 44026 44378 44779 49597 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-13 07:52 EDT by Peter J. Brand
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 16:35:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter J. Brand 2000-10-13 07:52:26 EDT
I get the following error while the installer is getting ready to install 
the packages:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/tmp/updates/todo.py", line 1499, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.GuiFstab instance at 84b9fa8>
mntPoint: /mnt/sysimage
selected: [ElectricFence, ImageMagick, LPRng, MAKEDEV, Mesa, Mesa-devel, 
ORBit, SysVinit, XFree86, XFree86-3DLabs, XFree86-75dpi-fonts, XFree86-
8514, XFree86-AGX, XFree86-FBDev, XFree86-I128, XFree86-Mach32, XFree86-
Mach64, XFree86-Mach8, XFree86-Mono, XFree86-P9000, XFree86-S3, XFree86-
devel, XFree86-doc, XFree86-libs, XFree86-tools, XFree86-twm, XFree86-xdm, 
XFree86-xfs, Xaw3d, Xaw3d-devel, Xconfigurator, anacron, apmd, arpwatch, 
ash, aspell, at, audiofile, aumix, authconfig, autoconf, automake, 
autorun, awesfx, basesystem, bash, bc, bdflush, bind-utils, binutils, 
bison, byacc, bzip2, bzip2-devel, cdecl, cdp, chkconfig, chkfontpath, 
compat-egcs, compat-egcs-c++, compat-glibc, compat-libstdc++, console-
tools, control-center, control-panel, cpio, cpp, cproto, cracklib, 
cracklib-dicts, crontabs, ctags, cvs, cyrus-sasl, db1, db1-devel, db2, db2-
devel, db3, db3-devel, db3-utils, dev, dev86, dhcpcd, dialog, diffstat, 
diffutils, dip, docbook, dosfstools, dump, e2fsprogs, ed, eject, elm, 
emacs, emacs-X11, emacs-nox, esound, exmh, expect, fetchmail, file, 
filesystem, fileutils, findutils, finger, flex, fortune-mod, freetype, 
freetype-devel, ftp, fvwm2, fvwm2-icons, gawk, gcc, gcc-c++, gd, gd-devel, 
gdb, gdbm, gdbm-devel, gdk-pixbuf, gettext, getty_ps, ghostscript, 
ghostscript-fonts, gimp, gimp-devel, glib, glib-devel, glib10, glibc, 
glibc-devel, gmp, gnome-audio, gnome-core, gnome-libs, gnome-linuxconf, 
gnupg, gpm, gpm-devel, grep, groff, groff-perl, gtk+, gtk+-devel, gtk+10, 
gv, gzip, hdparm, ical, imlib, indent, indexhtml, inews, info, 
initscripts, ipchains, iproute, iputils, irda-utils, isapnptools, jadetex, 
kbdconfig, kdeadmin, kdebase, kdebase-lowcolor-icons, kdegraphics, 
kdelibs, kdelibs-devel, kdemultimedia, kdenetwork, kdesupport, kdesupport-
devel, kdeutils, kdoc, kdpms, kernel, kernel-headers, kernel-pcmcia-cs, 
kernel-utils, kernelcfg, kgcc, korganizer, kpackage, kpilot, kpppload, 
krb5-devel, krb5-libs, kudzu, kudzu-devel, less, libglade, libjpeg, 
libjpeg-devel, libpng, libpng-devel, librep, libstdc++, libstdc++-devel, 
libtermcap, libtermcap-devel, libtiff, libtiff-devel, libtool, libtool-
libs, libungif, libungif-devel, libxml, lilo, linuxconf, linuxconf-devel, 
logrotate, losetup, lrzsz, lsof, ltrace, lynx, m4, mailcap, mailx, make, 
man, man-pages, memprof, metamail, mikmod, mingetty, minicom, mkbootdisk, 
mkinitrd, mktemp, mkxauth, modemtool, modutils, mount, mouseconfig, mpage, 
mpg123, mt-st, mtools, multimedia, mutt, ncftp, ncompress, ncurses, 
ncurses-devel, ncurses4, net-tools, netcfg, netpbm, netpbm-devel, netpbm-
progs, netscape-common, netscape-communicator, newt, newt-devel, nfs-
utils, nmh, ntsysv, openjade, openldap, openssl, pam, passwd, patch, 
pciutils, pciutils-devel, perl, pidentd, pilot-link, pilot-link-devel, 
pine, playmidi, playmidi-X11, pmake, pnm2ppa, popt, portmap, ppp, 
printtool, procmail, procps, psgml, psmisc, pspell, pump, pwdb, pygnome, 
pygnome-libglade, pygtk, pygtk-libglade, python, python-xmlrpc, pythonlib, 
qt, qt-devel, qt1x, qt1x-devel, quota, raidtools, rcs, rdate, readline, 
readline-devel, readline2.2.1, redhat-logos, redhat-release, rep-gtk, rep-
gtk-gnome, rhn_register, rhn_register-gnome, rhs-printfilters, rmt, 
rootfiles, rpm, rpm-build, rpm-devel, rpm-python, rsh, rsync, rusers, 
rwho, rxvt, samba-client, samba-common, sash, sawfish, screen, sed, 
sendmail, setserial, setup, setuptool, sgml-common, sgml-tools, sh-utils, 
shadow-utils, shapecfg, sharutils, slang, slang-devel, slocate, slrn, 
sndconfig, sox, stat, statserial, strace, stylesheets, switchdesk, 
switchdesk-kde, sysklogd, talk, tar, tcl, tclx, tcp_wrappers, tcsh, 
telnet, termcap, tetex, tetex-afm, tetex-dvilj, tetex-dvips, tetex-fonts, 
tetex-latex, tetex-xdvi, texinfo, textutils, time, timeconfig, timetool, 
tin, tix, tk, tkinter, tksysv, tmpwatch, traceroute, trn, unzip, up2date, 
up2date-gnome, urlview, urw-fonts, usermode, utempter, util-linux, uucp, 
vim-common, vim-minimal, vixie-cron, which, whois, wmconfig, words, 
wvdial, xinitrc, xloadimage, xmailbox, xmms, xmorph, xpaint, xpdf, xrn, 
xscreensaver, xsri, xxgdb, yp-tools, ypbind, zip, zlib, zlib-devel]
self: <image.CdromInstallMethod instance at 8470ae0>
p: db2-devel
changeloop: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-18 18:18:47 EDT
*** Bug 19163 has been marked as a duplicate of this bug. ***
Comment 2 Michael Fulbright 2000-10-27 16:08:36 EDT
Brock please try to reproduce.
Comment 3 Brock Organ 2000-11-01 16:20:04 EST
reassigning these to dale@redhat.com for further review ...
Comment 4 Michael Fulbright 2000-12-18 12:40:00 EST
*** Bug 22334 has been marked as a duplicate of this bug. ***
Comment 5 Brock Organ 2000-12-20 17:10:35 EST
verified the error:  a stock 6.2 Gnome workstation partitionless install was
upgraded to 7 via CDROM and this error occurred ... thanks for your report!
Comment 6 Michael Fulbright 2000-12-27 11:30:58 EST
*** Bug 22742 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2001-01-03 13:20:53 EST
*** Bug 22931 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2001-01-03 16:35:18 EST
*** Bug 23113 has been marked as a duplicate of this bug. ***
Comment 9 Erik Troan 2001-01-09 15:03:02 EST
An updates disk for this is available as:

	ftp://people.redhat.com/ewt/mountupd.img.gz
Comment 10 Michael Fulbright 2001-01-19 12:04:44 EST
*** Bug 24305 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2001-02-20 14:34:37 EST
*** Bug 28090 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2001-03-05 15:21:52 EST
*** Bug 19928 has been marked as a duplicate of this bug. ***
Comment 13 Michael Fulbright 2001-03-05 15:22:36 EST
*** Bug 19928 has been marked as a duplicate of this bug. ***
Comment 14 Brock Organ 2001-03-05 15:29:51 EST
*** Bug 30411 has been marked as a duplicate of this bug. ***
Comment 15 Michael Fulbright 2001-03-12 11:41:28 EST
*** Bug 31253 has been marked as a duplicate of this bug. ***
Comment 16 Brent Fox 2001-04-03 12:23:28 EDT
*** Bug 34276 has been marked as a duplicate of this bug. ***
Comment 17 Brent Fox 2001-04-09 16:26:52 EDT
*** Bug 35058 has been marked as a duplicate of this bug. ***
Comment 18 Brent Fox 2001-04-21 19:39:16 EDT
*** Bug 36426 has been marked as a duplicate of this bug. ***
Comment 19 Brent Fox 2001-05-20 19:38:53 EDT
*** Bug 41455 has been marked as a duplicate of this bug. ***
Comment 20 Brent Fox 2001-06-10 21:19:27 EDT
*** Bug 44026 has been marked as a duplicate of this bug. ***
Comment 21 Brent Fox 2001-06-13 14:26:14 EDT
*** Bug 44378 has been marked as a duplicate of this bug. ***
Comment 22 Brent Fox 2001-07-23 12:30:53 EDT
*** Bug 49597 has been marked as a duplicate of this bug. ***
Comment 23 Brent Fox 2001-08-10 00:15:54 EDT
*** Bug 44779 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.