Bug 22760 - [GUI] Changing keyboard configuration doesn't work
Summary: [GUI] Changing keyboard configuration doesn't work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-22 23:45 UTC by Enrico Scholz
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-18 10:28:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-12-22 23:45:51 UTC
Changing the keyboard configuration (language/dead keys) fails with 'Error
loading new keyboard description' (shown on the console).

Comment 1 Brent Fox 2000-12-24 17:27:40 UTC
What language and keyboard layout did you select?

Comment 2 Enrico Scholz 2000-12-26 12:05:22 UTC
I tried this:

1. Selecting "German" as language (screen 1), pressing 'Next' (all with mouse)
(2. Pressing 'y' - Key on German keyboard ('z' on English one) in the testfield:
'y')
3. "Deadkeys deaktivieren" (deactivating deadkeys in 3rd field of screen 2)
(4. Pressing 'y' - Key on German keyboard ('z' on English one) in the testfield:
'y')
5. Choosing "U.S. English w/ deadkeys" (2nd field)
(6. Pressing 'y' - Key on German keyboard ('z' on English one) in the testfield:
'y' !!!)

7. Further changes of keyboard will fail


Comment 3 Brent Fox 2001-01-03 22:40:45 UTC
The installer calls a program called setxkbmap to set the keymap for the
currently running X session.  The problem is that there's a pretty significant
bug in setxkbmap.  If you call setxkbmap with the "-variant nodeadkeys" option
(which the installer does when you select any keyboard with the nodeadkeys
option enabled) then subsequent attempts to use a keymap such as "us" fail. 
However, changing to some keymaps such as fr (French) seem to work.  


Comment 4 Brent Fox 2001-01-03 22:41:50 UTC
Changing component to XFree86.

Comment 5 Glen Foster 2001-01-11 21:04:32 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 6 Mike A. Harris 2001-03-13 16:43:45 UTC
Are people still having a problem with this in the 4.0.2-11.4.0 release?

Comment 7 Mike A. Harris 2001-03-19 04:04:22 UTC
*** Bug 28277 has been marked as a duplicate of this bug. ***

Comment 8 Mike A. Harris 2001-03-19 18:37:04 UTC
Bug #28277 has been unmarked as a dupe because it is a public bug and
the poster of it cannot read this private bug report, so instead I made
it dependant on this bug.  Never did that before, hope I understand the
field correctly.

Comment 9 Mike A. Harris 2001-05-12 13:15:32 UTC
Fixed in rawhide anaconda.  Problem was misuse of setxkbmap in installer.

Comment 10 Enrico Scholz 2001-07-17 21:45:57 UTC
Seen in Fairfax beta1 again...

Comment 11 Mike A. Harris 2001-07-18 10:28:44 UTC
This is not an XFree86 problem.  setxkbmap only does what it is told to do.

Has this code regressed?

Comment 12 Jeremy Katz 2001-07-22 06:01:20 UTC
Code got lost in merging a branch.  I've re-integrated the fix into CVS HEAD. 
Please reopen if this remains a problem in Fairfax beta3


Note You need to log in before you can comment on or make changes to this bug.