Bug 2276314 - Cannot change IRQ 75 affinity: Read-only file system
Summary: Cannot change IRQ 75 affinity: Read-only file system
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: irqbalance
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-04-21 21:31 UTC by Garry T. Williams
Modified: 2024-04-26 09:23 UTC (History)
6 users (show)

Fixed In Version: irqbalance-1.9.4-2.fc41
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-04-25 12:17:54 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
kernel message log (127.64 KB, text/plain)
2024-04-21 21:31 UTC, Garry T. Williams
no flags Details

Description Garry T. Williams 2024-04-21 21:31:07 UTC
Created attachment 2028221 [details]
kernel message log

Description of problem:
System log is filled with these:
Apr 21 14:57:10 irqbalance[975]: -----------------------------------------------------------------------------

This starts about 10 minutes after boot with these messages:
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 75 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 75 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 65 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 65 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 114 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 114 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 77 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 77 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 31 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 31 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 16 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 16 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 56 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 56 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 57 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 57 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 58 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 58 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 59 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 59 affinity is now unmanaged
Apr 21 14:57:10 irqbalance[975]: Cannot change IRQ 76 affinity: Read-only file system
Apr 21 14:57:10 irqbalance[975]: IRQ 76 affinity is now unmanaged

Version-Release number of selected component (if applicable):
irqbalance-1.9.4-1.fc39.x86_64

How reproducible:
Always

Additional info:
kernel log attached.

Problem started on previous boot immediately after upgrade from version irqbalance-2:1.9.2-2.fc39.x86_64.  The upgrade produced these messages prior to reboot and the messages noted above after reboot:

Apr 20 22:13:06 systemd[1]: Stopping irqbalance.service - irqbalance daemon...
...
Apr 20 22:13:06 systemd[1]: irqbalance.service: Deactivated successfully.
Apr 20 22:13:06 systemd[1]: Stopped irqbalance.service - irqbalance daemon.
Apr 20 22:13:06 systemd[1]: irqbalance.service: Consumed 59.897s CPU time.
...
Apr 20 22:13:06 (qbalance)[113590]: irqbalance.service: Referenced but unset environment variable evaluates to an empty string: IRQBALANCE_ARGS
Apr 20 22:13:06 /usr/sbin/irqbalance[113590]: libcap-ng used by "/usr/sbin/irqbalance" failed dropping bounding set due to not having CAP_SETPCAP in capng_apply
...
Apr 20 22:13:16 irqbalance[113590]: Prevent irq assignment to these isolated CPUs: 00000000
Apr 20 22:13:16 irqbalance[113590]: Prevent irq assignment to these adaptive-ticks CPUs: 00000000
Apr 20 22:13:16 irqbalance[113590]: Banned CPUs: 00000000
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 30 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 24 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 106 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 104 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 91 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 96 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 94 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 92 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 90 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 80 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 89 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 95 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 93 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 100 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 102 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 83 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 81 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 88 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 86 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 84 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 82 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 79 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 87 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 85 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 98 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 109 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 110 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 27 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 107 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 78 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 105 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 55 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 45 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 73 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 63 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 53 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 43 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 71 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 61 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 51 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 41 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 68 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 48 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 66 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 46 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 74 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 64 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 54 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 44 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 72 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 62 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 52 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 42 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 70 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 60 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 50 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 40 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 69 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 49 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 39 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 67 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 47 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 75 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 65 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 103 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 114 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 25 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 112 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 11 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 76 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 77 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 29 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 35 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 33 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 31 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 38 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 36 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 34 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 32 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 37 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 16 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 108 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 0 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 1 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 8 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 9 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 56 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 57 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 58 to database
Apr 20 22:13:16 irqbalance[113590]: Adding IRQ 59 to database
Apr 20 22:13:16 irqbalance[113590]: IRQ 24 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 27 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 25 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 11 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 29 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 35 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 33 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 38 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 36 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 34 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 32 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: IRQ 37 is removed from interrupts_db.
Apr 20 22:13:16 irqbalance[113590]: -----------------------------------------------------------------------------
Apr 20 22:13:16 irqbalance[113590]: Cannot change IRQ 91 affinity: Read-only file system
Apr 20 22:13:16 irqbalance[113590]: IRQ 91 affinity is now unmanaged
[... same as above from here]

Comment 1 dex 2024-04-22 01:18:44 UTC
I'm also seeing this in F40.

Comment 3 Timothée Ravier 2024-04-22 16:32:44 UTC
*** Bug 2276442 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2024-04-22 16:46:50 UTC
FEDORA-2024-adc0bf6d51 (irqbalance-1.9.4-2.fc41) has been submitted as an update to Fedora 41.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-adc0bf6d51

Comment 5 Fedora Update System 2024-04-22 16:51:13 UTC
FEDORA-2024-adc0bf6d51 (irqbalance-1.9.4-2.fc41) has been pushed to the Fedora 41 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2024-04-22 16:58:02 UTC
FEDORA-2024-ae4ea3235c (irqbalance-1.9.4-2.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-ae4ea3235c

Comment 7 Fedora Update System 2024-04-22 16:58:22 UTC
FEDORA-2024-9a8a0023e5 (irqbalance-1.9.4-2.fc39) has been submitted as an update to Fedora 39.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-9a8a0023e5

Comment 8 dex 2024-04-22 22:57:07 UTC
I'm still seeing lots of this in F40 after reboot. irqbalance-1.9.4-2.fc40

Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: Selecting irq 137 for rebalancing
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: Selecting irq 137 for rebalancing
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: Selecting irq 135 for rebalancing
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: Selecting irq 134 for rebalancing
Apr 22 23:38:57 irqbalance[862]: Selecting irq 135 for rebalancing
Apr 22 23:38:57 irqbalance[862]: Selecting irq 139 for rebalancing
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: Selecting irq 140 for rebalancing
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------
Apr 22 23:38:57 irqbalance[862]: Selecting irq 137 for rebalancing
Apr 22 23:38:57 irqbalance[862]: Selecting irq 134 for rebalancing

Comment 9 ltao 2024-04-23 02:40:05 UTC
I can reproduce the issue with f39+irqbalance-1.9.4-2.fc39, not sure why this happens, let's see how upstream [1] will response.

[1]: https://github.com/Irqbalance/irqbalance/issues/281#issuecomment-2071301268

Comment 10 Fedora Update System 2024-04-23 02:43:27 UTC
FEDORA-2024-9a8a0023e5 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-9a8a0023e5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-9a8a0023e5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 ltao 2024-04-23 02:44:00 UTC
To make it clear "reproduce the issue", I mean the output of

Apr 22 23:38:57 irqbalance[862]: -----------------------------------------------------------------------------

not the "Cannot change IRQ 31 affinity: Read-only file system" issue.

Comment 12 Fedora Update System 2024-04-23 03:44:42 UTC
FEDORA-2024-ae4ea3235c has been pushed to the Fedora 40 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-ae4ea3235c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-ae4ea3235c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Timothée Ravier 2024-04-25 12:16:45 UTC
We'll need to backport https://github.com/Irqbalance/irqbalance/pull/282 as well

Comment 14 Timothée Ravier 2024-04-25 12:17:54 UTC
Let's use https://bugzilla.redhat.com/show_bug.cgi?id=2276442 for that. This one was about the /proc RO issue.


Note You need to log in before you can comment on or make changes to this bug.