Bug 2276442 - After updating to 1.9.4-1 irqbalance spams the journal
Summary: After updating to 1.9.4-1 irqbalance spams the journal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: irqbalance
Version: 39
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2024-04-22 14:47 UTC by Ingo Weiss
Modified: 2024-05-12 04:20 UTC (History)
5 users (show)

Fixed In Version: irqbalance-1.9.4-3.fc41 irqbalance-1.9.4-3.fc40 irqbalance-1.9.4-3.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-05-02 01:57:26 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Ingo Weiss 2024-04-22 14:47:17 UTC
Hi,

After updating irqbalance to 1.9.4-1, irqbalance started spamming the journal with gibbering:

> journalctl --follow --unit irqbalance
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------

Seems related to https://github.com/Irqbalance/irqbalance/issues/281.

Reproducible: Always

Steps to Reproduce:
1. Update irqbalance to 1.9.4-1
2. Run "journalctl --follow --unit irqbalance"

Actual Results:  
> journalctl --follow --unit irqbalance
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------
Apr 22 15:32:44 starfox irqbalance[1087490]: -----------------------------------------------------------------------------

Expected Results:  
No logging messages with just "----------------"

Comment 1 Timothée Ravier 2024-04-22 16:32:44 UTC
Thanks for the report.

*** This bug has been marked as a duplicate of bug 2276314 ***

Comment 2 Timothée Ravier 2024-04-25 12:17:22 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=2276314#c13

Comment 3 Timothée Ravier 2024-04-25 12:19:01 UTC
Hum, it's not just that. This patch is supposed to be in the 1.9.4 release.

Comment 4 ltao 2024-04-30 07:51:08 UTC
Hi Timothée,

I figured out why this issue still exist in 1.9.4 release.

The patch [1] only take effect on "HAVE_LIBSYSTEMD" is defined. To achieve it, we need to specify "./configure --with-systemd", so the following code will be generated in config.h:

    /* Define to 1 if you have the `systemd' library (-lsystemd). */
    #define HAVE_LIBSYSTEMD 1

With this change, there will be no extra "irqbalance[1087490]: -----------------------------------------------------------------------------" string in systemd journal.

However, to enable "./configure --with-systemd", we need to add systemd-devel dependence in irqbalance.spec like:

--- a/irqbalance.spec
+++ b/irqbalance.spec
@@ -12,7 +12,7 @@ Patch3:         0001-Drop-ProtectKernelTunables.patch
 
 BuildRequires:  autoconf automake libtool libcap-ng
 BuildRequires:  glib2-devel pkgconf libcap-ng-devel
-BuildRequires:  systemd ncurses-devel
+BuildRequires:  systemd ncurses-devel systemd-devel
 BuildRequires:  make
 Requires: ncurses-libs
 
@@ -32,7 +32,7 @@ multiple CPUs for enhanced performance.
 
 %build
 ./autogen.sh
-%configure
+%configure --with-systemd
 %{make_build}
 
 %install

Or we add an out-of-tree patch to directly delete the line in irqbalance.c:

 gboolean scan(gpointer data __attribute__((unused)))
 {
- 	log(TO_CONSOLE, LOG_INFO, "\n\n\n-----------------------------------------------------------------------------\n"); 
	clear_work_stats();
	parse_proc_interrupts();

Which approach to you prefer?

Thanks,
Tao Liu

[1]: https://github.com/Irqbalance/irqbalance/pull/282/files

Comment 5 Timothée Ravier 2024-04-30 15:20:40 UTC
Created: https://src.fedoraproject.org/rpms/irqbalance/pull-request/13

Comment 6 Fedora Update System 2024-05-01 08:18:37 UTC
FEDORA-2024-b1d38016d5 (irqbalance-1.9.4-3.fc41) has been submitted as an update to Fedora 41.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-b1d38016d5

Comment 7 Fedora Update System 2024-05-01 08:20:53 UTC
FEDORA-2024-b1d38016d5 (irqbalance-1.9.4-3.fc41) has been pushed to the Fedora 41 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2024-05-01 08:23:17 UTC
FEDORA-2024-ce4eef9f94 (irqbalance-1.9.4-3.fc40) has been submitted as an update to Fedora 40.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-ce4eef9f94

Comment 9 Timothée Ravier 2024-05-01 09:20:49 UTC
I'll wait for positive feedback on the F40 update before pushing it to F39.

Comment 10 Fedora Update System 2024-05-02 01:57:26 UTC
FEDORA-2024-ce4eef9f94 (irqbalance-1.9.4-3.fc40) has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 dex 2024-05-02 14:49:42 UTC
works for me F40 irqbalance-1.9.4-3
thanks.

Comment 12 Fedora Update System 2024-05-03 09:16:12 UTC
FEDORA-2024-39b90624ac (irqbalance-1.9.4-3.fc39) has been submitted as an update to Fedora 39.
https://bodhi.fedoraproject.org/updates/FEDORA-2024-39b90624ac

Comment 13 Fedora Update System 2024-05-04 03:17:52 UTC
FEDORA-2024-39b90624ac has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-39b90624ac`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2024-39b90624ac

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2024-05-12 04:20:36 UTC
FEDORA-2024-39b90624ac (irqbalance-1.9.4-3.fc39) has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.