Bug 227639 - kernel 2895 doesn't hibernate and suspend
kernel 2895 doesn't hibernate and suspend
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-07 03:58 EST by Cristian Oancea
Modified: 2015-03-04 20:18 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.19-1.2911.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 01:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cristian Oancea 2007-02-07 03:58:50 EST
Description of problem:

On a Thinkpad T60 - type 2007-6RG with Intel core 2 Duo T7200 , 2Gb RAM.

System doesn't go into the hibernate hibernate state and also suspend
for second time.

same error is produced also when the computer is suspended to memory for the
second time.
instead of module pm-hibernate is pm-suspend

Version-Release number of selected component (if applicable):


How reproducible:
Gnome Menu System -> System Shutdown -> Hibernate 

Steps to Reproduce:
1. Hibernate oe suspend via Gnome menu
2.Sistem hangs and suspend led is blinking 
3.
  
Actual results:
 system hangs

Expected results:
system goes into hibernation state (suspend on disk) or suspend to memory

Additional info:


Feb  7 09:38:00 localhost kernel: Unable to handle kernel NULL pointer
dereference at 0000000000000000 RIP: 
Feb  7 09:38:00 localhost kernel:  [<ffffffff802bf6ed>] __drain_pages+0x20/0x60
Feb  7 09:38:00 localhost kernel: PGD 5d13d067 PUD 5d13c067 PMD 0 
Feb  7 09:38:00 localhost kernel: Oops: 0000 [1] SMP 
Feb  7 09:38:00 localhost kernel: last sysfs file: /power/state
Feb  7 09:38:00 localhost kernel: CPU 0 
Feb  7 09:38:00 localhost kernel: Modules linked in: hidp rfcomm l2cap bluetooth
cpufreq_ondemand dm_mirror dm_multipath dm_mod video sbs ibm_acpi i2c_ec dock
battery asus_acpi ac fglrx(P)(U) ipv6 parport_pc lp parport joydev snd_hda_intel
snd_hda_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm sg ipw3945(F)(U) serio_raw
pcspkr snd_timer snd e1000 ata_piix ieee80211(F)(U) soundcore shpchp i2c_i801
snd_page_alloc iTCO_wdt i2c_core ieee80211_crypt(F)(U) nsc_ircc irda crc_ccitt
ide_cd cdrom ahci libata sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
Feb  7 09:38:00 localhost kernel: Pid: 5745, comm: pm-hibernate Tainted: PF    
2.6.19-1.2895.fc6 #1
Feb  7 09:38:00 localhost kernel: RIP: 0010:[<ffffffff802bf6ed>] 
[<ffffffff802bf6ed>] __drain_pages+0x20/0x60
Feb  7 09:38:00 localhost kernel: RSP: 0018:ffff81005de4fd88  EFLAGS: 00010046
Feb  7 09:38:00 localhost kernel: RAX: 0000000000000001 RBX: 0000000000000046
RCX: ffff810001000000
Feb  7 09:38:00 localhost kernel: RDX: ffff81000000c000 RSI: ffff81000000c768
RDI: ffff81000000c500
Feb  7 09:38:00 localhost kernel: RBP: 0000000000000000 R08: ffff81005de4e000
R09: 0000000000000000
Feb  7 09:38:00 localhost kernel: R10: ffff81000304fbe0 R11: ffffffff802f9d55
R12: ffff81000000ca00
Feb  7 09:38:00 localhost kernel: R13: 0000000000000000 R14: 0000000000000001
R15: 00002aaaae1cb000
Feb  7 09:38:00 localhost kernel: FS:  00002aaaaaac1db0(0000)
GS:ffffffff8064d000(0000) knlGS:0000000000000000
Feb  7 09:38:00 localhost kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Feb  7 09:38:00 localhost kernel: CR2: 0000000000000000 CR3: 000000005ddd3000
CR4: 00000000000006e0
Feb  7 09:38:00 localhost kernel: Process pm-hibernate (pid: 5745, threadinfo
ffff81005de4e000, task ffff81006e3c27b0)
Feb  7 09:38:00 localhost kernel: Stack:  0000000000000001 0000000000000001
0000000000000007 ffff810064a790c0
Feb  7 09:38:00 localhost kernel:  0000000000000001 ffffffff802bf73f
ffffffff80577810 ffffffff80265081
Feb  7 09:38:00 localhost kernel:  0000000000000001 0000000000000001
0000000000000000 ffffffff802a18aa
Feb  7 09:38:00 localhost kernel: Call Trace:
Feb  7 09:38:00 localhost kernel:  [<ffffffff802bf73f>]
page_alloc_cpu_notify+0x12/0x28
Feb  7 09:38:00 localhost kernel:  [<ffffffff80265081>]
notifier_call_chain+0x20/0x32
Feb  7 09:38:00 localhost kernel:  [<ffffffff802a18aa>] _cpu_down+0x15b/0x217
Feb  7 09:38:00 localhost kernel:  [<ffffffff802a1ba5>]
disable_nonboot_cpus+0xa9/0x14c
Feb  7 09:38:00 localhost kernel:  [<ffffffff802a8688>] prepare_processes+0x10/0xe0
Feb  7 09:38:00 localhost kernel:  [<ffffffff802a89c8>] pm_suspend_disk+0xb/0x18d
Feb  7 09:38:00 localhost kernel:  [<ffffffff802a78a9>] enter_state+0x5f/0x1a1
Feb  7 09:38:00 localhost kernel:  [<ffffffff802a7a49>] state_store+0x5e/0x79
Feb  7 09:38:00 localhost kernel:  [<ffffffff80300cb4>] sysfs_write_file+0xcb/0xff
Feb  7 09:38:00 localhost kernel:  [<ffffffff80216582>] vfs_write+0xce/0x174
Feb  7 09:38:00 localhost kernel:  [<ffffffff80216fb3>] sys_write+0x45/0x6e
Feb  7 09:38:00 localhost kernel:  [<ffffffff8025c11e>] system_call+0x7e/0x83
Feb  7 09:38:00 localhost kernel:  [<000000398fcbfc00>]
Comment 1 Cristian Oancea 2007-02-07 04:02:37 EST
Feb  7 09:38:00 localhost kernel: Code: 8b 75 00 48 8d 55 10 31 c9 4c 89 e7 e8
e4 fd ff ff c7 45 00 
Feb  7 09:38:00 localhost kernel: RIP  [<ffffffff802bf6ed>] __drain_pages+0x20/0x60
Feb  7 09:38:00 localhost kernel:  RSP <ffff81005de4fd88>
Feb  7 09:38:00 localhost kernel: CR2: 0000000000000000
Feb  7 09:38:00 localhost kernel:  <3>BUG: sleeping function called from invalid
context at kernel/rwsem.c:20
Feb  7 09:38:00 localhost kernel: in_atomic():0, irqs_disabled():1
Feb  7 09:38:00 localhost kernel: 
Feb  7 09:38:00 localhost kernel: Call Trace:
Feb  7 09:38:00 localhost kernel:  [<ffffffff8026999a>] show_trace+0x34/0x47
Feb  7 09:38:00 localhost kernel:  [<ffffffff802699bf>] dump_stack+0x12/0x17
Feb  7 09:38:00 localhost kernel:  [<ffffffff8029e5fb>] down_read+0x15/0x23
Feb  7 09:38:00 localhost kernel:  [<ffffffff8029661a>]
blocking_notifier_call_chain+0x13/0x36
Feb  7 09:38:00 localhost kernel:  [<ffffffff80215050>] do_exit+0x1f/0x8df
Feb  7 09:38:00 localhost kernel:  [<ffffffff80264fe6>] do_page_fault+0x7a1/0x81c
Feb  7 09:38:00 localhost kernel:  [<ffffffff8026307d>] error_exit+0x0/0x84
Feb  7 09:38:00 localhost kernel:  [<ffffffff802bf6ed>] __drain_pages+0x20/0x60
Feb  7 09:38:00 localhost kernel:  [<ffffffff802bf73f>]
page_alloc_cpu_notify+0x12/0x28
Feb  7 09:38:00 localhost kernel:  [<ffffffff80265081>]
notifier_call_chain+0x20/0x32
Comment 2 Stefan Becker 2007-02-15 04:30:10 EST
Duplicate of bug #205144: Hibernate fails on Thinkpad T60

Duplicate of bug #227715: suspend to ram produces soft CPU lockup.
Comment 3 Cristian Oancea 2007-02-15 05:10:53 EST
On the same Notebook but running 2.6.19-1.2911.fc6 the Problem seems to be solved.
Comment 4 Nigel Cunningham 2007-06-12 01:59:40 EDT
Closing as fixed in current release as per previous comment.

Note You need to log in before you can comment on or make changes to this bug.