Bug 228210 - PiotriPawel web site crashes firefox
PiotriPawel web site crashes firefox
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
http://www.piotripawel.pl/e-zakupy/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-11 13:27 EST by Michael De La Rue
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-12 09:38:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of firefox crashing (30.88 KB, text/plain)
2007-02-11 13:27 EST, Michael De La Rue
no flags Details
log of attempting and failing to get a backtrace showing X errors (30.69 KB, text/plain)
2007-02-11 13:31 EST, Michael De La Rue
no flags Details

  None (edit)
Description Michael De La Rue 2007-02-11 13:27:18 EST
Description of problem:
Firefox crashes randomly on me when using piotripawel's web site for internet
shopping.

Version-Release number of selected component (if applicable):
firefox-1.5.0.9-2.fc6
gnash-0.7.2-1.mikedlr

How reproducible:
very random.  Happens quite often when I am actually shopping and do product
searches.   During testing I could reproduce it with strace running and not at
all with --verbose --sync options to FireFox.  

Steps to Reproduce:
0. Create a completely fresh user.  
1. log in to http://www.piotripawel.pl/e-zakupy/
2. choose "Warszawa" and press "WEJśCIE
3. type things into the "ZNAJDż TORWAR" box (search) such as "piwo", "wino", "ser" 
4. select items to buy / go backwards.  

Actual results:
mozilla crashes randomly.

Expected results:
mozilla is stable and fine.
or
mozilla gives a clear error message.  

Additional info:
this appears to be a heisenbug.  Turning on debugging output from firefox makes
it go away.. maybe timing related?

I have a build of gnash which I did myself; see Bug #217020 however a) it's just
a rebuild of the redhat srpm.  b) gnash crashing should at least have firefox
give an error message.  

Recommendations for troubleshooting appreciated; particularly how to get a
proper backtrace.
Comment 1 Michael De La Rue 2007-02-11 13:27:18 EST
Created attachment 147858 [details]
strace of firefox crashing
Comment 2 Michael De La Rue 2007-02-11 13:31:15 EST
Created attachment 147859 [details]
log of attempting and failing to get a backtrace showing X errors

running "firefox -g -d gdb" I managed to see some X errors.  No backtrace since
the program seems to exit normally.
Comment 3 Matěj Cepl 2007-02-12 08:19:52 EST
Cannot reprorduce with flash-plugin-9.0.31.0-1 (half-liter of the Czech
Budweiser is terribly expensive, which IMHO is much important bug than that
gnash is broken ;-)), which IMHO means that this is bug in gnash. Changing
component accordingly.
Comment 4 Matěj Cepl 2007-02-12 09:38:23 EST
After discussion with FF people closing this bug as WORKSFORME. If you can
reproduce it using our own packages, then please reopen with additional
information. As far as recommendation for troubleshooting, it probably really
belongs to somewhere else than to our Bugzilla.
Comment 5 Jens Petersen 2007-02-12 22:00:18 EST
Sounds like a gnash issue anyway.
Comment 6 Matěj Cepl 2007-02-13 07:41:24 EST
(In reply to comment #5)
> Sounds like a gnash issue anyway.

That's what I meant -- especially with custom-made gnash. We really cannot
support that.
Comment 7 Patrice Dumas 2007-02-13 07:48:17 EST
(In reply to comment #6)
> (In reply to comment #5)
> > Sounds like a gnash issue anyway.

Not completely sure. There could also be a firefox or an X bug somewhere.
Agreed, a bug in gnash is the best guess.
 
> That's what I meant -- especially with custom-made gnash. We really cannot
> support that.

I can't see why. The rpm from fedora is unusable on some systems while
a rebuild leads to something that works. See Bug 217020. So in this case I
think it is acceptable to support a custom-made gnash done by recompiling
the srpm.

However I cannot reproduce that bug because I don't understand the polish
language.
Comment 8 Matěj Cepl 2007-02-13 08:36:02 EST
(In reply to comment #7)
> I can't see why. The rpm from fedora is unusable on some systems while
> a rebuild leads to something that works. See Bug 217020. So in this case I
> think it is acceptable to support a custom-made gnash done by recompiling
> the srpm.

OK, whatever. If you want, it is your package, so do whatever you feel right.
Reopen it, dance with it, really whatever. :-)

> However I cannot reproduce that bug because I don't understand the polish
> language.

You don't have to -- yes, I can understand Polish (being a Czech), but I think
the instruction above are pretty usable even without any real understanding of
Polish.
Comment 9 Patrice Dumas 2007-02-13 08:38:21 EST
(In reply to comment #8)
> (In reply to comment #7)
> > I can't see why. The rpm from fedora is unusable on some systems while
> > a rebuild leads to something that works. See Bug 217020. So in this case I
> > think it is acceptable to support a custom-made gnash done by recompiling
> > the srpm.
> 
> OK, whatever. If you want, it is your package, so do whatever you feel right.
> Reopen it, dance with it, really whatever. :-)

;-)

> > However I cannot reproduce that bug because I don't understand the polish
> > language.
> 
> You don't have to -- yes, I can understand Polish (being a Czech), but I think
> the instruction above are pretty usable even without any real understanding of
> Polish.

I don't want to add myself as a user when I don't understand the conditions...
Comment 10 Patrice Dumas 2007-02-13 08:51:37 EST
The gnash 7.2 version isn't supported by the gnash developers, 
so it would be convenient if the CVS version could be tried to
see if it is reproducible. I don't think it is really worth to 
fix the gnash 7.2 version which is the fedora version since the
upstream gnash has already changed a lot. If this is an issue 
present in CVS and there is a common fix, however I'll do the fix.

Note You need to log in before you can comment on or make changes to this bug.