Bug 22822 - rpm dependencies on dev prevent uninstall for devfs
Summary: rpm dependencies on dev prevent uninstall for devfs
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: dev (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-25 17:55 UTC by Alex Yacoub
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-20 01:04:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Yacoub 2000-12-25 17:55:44 UTC
dev and MAKEDEV have a couple of dependencies that prevent their
uninstallation in favor of devfs.  This is a bug that needs to be fixed
before anything based on 2.4 goes gold.

openssh requires the dev rpm for some odd reason, and if that is fixed, the
dev package can probably be taken out.  MAKEDEV is a bigger issue, and all
packages that rely on it, such as raidtools, need to be revamped to become
"devfs-aware"  Kudzu (see bug 22810).

Comment 1 Andrew Bartlett 2001-01-20 01:04:46 UTC
There is no need to actualy remove /dev (or its contents) before using devfs -
it will run regardless.  When any filesystem is mounted the files under the
mountpoint dissapear in favor of the mouted filesystem.  
In any case kernel 2.4 works perfectly well without devfs (and I understand that
this is what RedHat intends to do).


Comment 2 Nalin Dahyabhai 2001-01-20 22:50:07 UTC
Several scripts require /dev.  OpenSSH *needs* the /dev/urandom device in order
to start up and seed its random-number generator.  Because devfs mounts over
/dev, this is not likely to change.


Note You need to log in before you can comment on or make changes to this bug.