Bug 22860 - gnorpm: error while loading shared libraries: gnorpm: undefined symbol: rpmErrorSetCallback
Summary: gnorpm: error while loading shared libraries: gnorpm: undefined symbol: rpmEr...
Status: CLOSED DUPLICATE of bug 22498
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnorpm (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Need Real Name
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-27 01:49 UTC by Bill Crawford
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 01:49:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Crawford 2000-12-27 01:49:00 UTC
Latest RPM library version does not include rpmErrorSetCallback.

I am unable to rebuild gnorpm from source due to other errors:

gcc -DHAVE_CONFIG_H -I. -I. -I. -I/usr/include -DNEED_GNOMESUPPORT_H
-I/usr/lib/gnome-libs/include -I/usr/lib/glib/include -I/usr/X11R6/include
-I/usr/include/rpm            -DGNOMELOCALEDIR=\""/usr/share/locale"\"    
-DG_LOG_DOMAIN=\"GnoRPM\"    -O2 -march=i386 -mcpu=i686 -Wall -Wunused  -c
install.c
install.c: In function `printProblems':
install.c:457: incompatible type for argument 1 of `rpmProblemString'
install.c: In function `do_install':
install.c:601: warning: passing arg 2 of `rpmRunTransactions' from
incompatible pointer type
install.c:609: warning: passing arg 2 of `rpmRunTransactions' from
incompatible pointer type
install.c:623: warning: passing arg 4 of `rpmInstallSourcePackage' from
incompatible pointer type
make[2]: *** [install.o] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/gnorpm-0.95.1'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/gnorpm-0.95.1'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.27291 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.27291 (%build)

Comment 1 Bill Nottingham 2000-12-27 04:39:45 UTC

*** This bug has been marked as a duplicate of 22498 ***

Comment 2 David Lawrence 2000-12-28 15:19:46 UTC
The bug that this marked as a duplicate of is a private bug unfortunately. I
have spoken the developers about linking to private bugs and that they need to
make sure that the proper comments are added to the public bugs to show how to
resolved the problem. Here is the comment made in the  other report that should
be helpful.

rpmErrorSetCallback() has been resurrected in rpm-4.0.2-0.8 and rpm-4.0.1-0.30
and later. These should be obtainable in the rawhide section of
ftp://ftp.redhat.com.

Comment 3 Bill Crawford 2000-12-31 11:44:06 UTC
The mirror I use for Rawhide still only has rpm-4.0.2-0.7 (not -0.8) ... appears
ftp.redhat.com is the same.
When will this new release be available for public chewing on ?



Note You need to log in before you can comment on or make changes to this bug.