Bug 228667 - yum whatprovides xalan shows 40 times the same package
Summary: yum whatprovides xalan shows 40 times the same package
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-14 10:47 UTC by Till Maas
Modified: 2014-01-21 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 14:21:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Till Maas 2007-02-14 10:47:19 UTC
Description of problem:
When I run "yum whatprovides xalan" 40 times the package xalan-j2-demo.i386    
                  2.7.0-6jpp.1           core is shown.

Version-Release number of selected component (if applicable):
3.0.3-1

How reproducible:
always

Steps to Reproduce:
1. yum whatprovides xalan > /tmp/xalan.log
2. grep "xalan-j2-demo.i386                       2.7.0-6jpp.1           core" 
/tmp/xalan.log |wc -l

  
Actual results:
40

Expected results:
1

Comment 1 Seth Vidal 2007-06-22 12:31:27 UTC
Are you running fedora 7, yet? If so could you tell me if you have a similar
problem on yum there?

Comment 2 Till Maas 2007-07-27 09:15:14 UTC
With yum-3.2.2-1.fc7 "yum whatprovides xalan" returns "No Matches found". With
"yum whatprovides xalan\*" it seems to work fine, but it downloads all
filelists.sqlite.bz2 files.



Comment 3 Seth Vidal 2007-07-27 13:54:53 UTC
I'm looking in my release and there's nothing that actually does provide xalan.
So I wouldn't expect yum whatprovides xalan to work.

And the reason yum whatprovides xalan\* downloads all of the filelists is b/c it
is looking in the files, too, b/c of the wildcard.



Comment 4 Till Maas 2007-07-27 14:21:32 UTC
Hm, ok, seems that yum changed the behaviour regarding "whatprovides", because
earlier versions applied some kind of wildcarding on the argument itself. But
with yum not being stuck in an endless loop, this works for me.


Note You need to log in before you can comment on or make changes to this bug.