Bug 22890 - fix rh ppp "failed to active interface"
fix rh ppp "failed to active interface"
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-27 14:09 EST by Rui Li
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 20:23:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rui Li 2000-12-27 14:09:49 EST
after create an account by using dialup configuration.
the debug works fine. but can not use RH PPP Dialer.
it return the message "failed to active interface"

here is how to fix it

1. use dialup configuration to create your account.
2. click on edit
3. click on advanced
3. make sure "let ppp do all autoentication" is checked.
4. make sure "Bring link up and down automaticlly" is un-checked!
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
then, the ppp will works fine. 
if you select "Bring link up and down automaticlly"
then you will get the error message "failed to active interface"
under RH ppp Dialer but you still can dial out by using "debug" 
function under dialup configuration.
Comment 1 John J. Germs 2001-01-03 20:23:22 EST
**I posted this information in bug  21667**
**But it applies strongly to this Summary**

I have had a similar problem which I noticed when 7 first came out ... The
reason I didn't mention anything earlier was it suddenly worked one day, so I
dismissed it as something I did. Well.. I recently did a fresh install and the
same thing happened.(failed to activate interface)..... 
Another thing that was interesting was if I entered my dns numbers in Network
Configurator I would be able to open Netscape and go to an address after the rp3
failed to activate.... What would happen was it would dial out...strange.
Turns out the reason I got it working before was I downloaded and compiled a 2.4
kernel, booted with it and tried the Dailup Configuration utility from scratch
again. That's all it took. Once I had this interface working I tried booting
from the stock 2.2.16-22 kernel and it worked without any problems as well.
I did not change authentication or the link at all...It is still at the
defaults.

...G...
Comment 2 Nalin Dahyabhai 2001-01-15 21:31:01 EST
Looks like the demand-dialing support isn't working right.  Please go to the
advanced options dialog in rp3-config and switch off "Bring link up and down
automatically".  We'll disable this default setting in rp3 until we fix it.

Note You need to log in before you can comment on or make changes to this bug.