Bug 228928 - oddjob: $RPM_OPT_FLAGS not used
oddjob: $RPM_OPT_FLAGS not used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: oddjob (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-15 16:57 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 20:09:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2007-02-15 16:57:06 EST
http://www.redhat.com/archives/fedora-maintainers/2007-January/msg00339.html

There's something odd (pun intended :)) going on here, none of my usual suspects
apply, but the result is that CFLAGS from the environment is not used during
build, even though %configure sets it.  It gets lost somewhere.

A bit off topic, but %configuring with --disable-dependency-tracking would make
the build output cleaner and easier to notice problems like this, and could
provide a slight build speedup.
Comment 1 Nalin Dahyabhai 2007-02-15 18:39:51 EST
Ugh, this isn't a packaging bug.  I'll have to roll a new release to fix it.
Comment 2 Ville Skyttä 2007-07-28 16:10:05 EDT
Any news?
Comment 3 Nalin Dahyabhai 2007-09-05 17:16:50 EDT
Should be fixed in 0.29.

Note You need to log in before you can comment on or make changes to this bug.